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Isco Flowlink 5.1® Software

Welcome

Thank you for choosing to use Flowlink® software. Flowlink is a 
powerful application that allows you to monitor instruments 
manufactured by Teledyne Isco. With Flowlink you can:

• Manage instrument sites using the familiar interface of 
Microsoft® Windows®.

• Remotely retrieve data from installed instruments.
• Present site data graphically.
• Generate and manipulate statistical information from 

the site data.
• Edit site data.
• Convert site data created in earlier Isco software systems 

for management in Flowlink.
For help on any Flowlink window, press the F1 keyboard button 
at any time. Doing so will bring up help topics that relate to the 
active window.

See also:

About Teledyne Isco on page 2
Flowlink 5.1 Software Version Information on page 2
Compatible Teledyne Isco Instruments on page 3

Do not use Add/Remove Programs to uninstall previous versions 
of Flowlink software. Loss of all data may result. Upgrade 
Flowlink only by double-clicking on setup.exe on this CD.
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About Teledyne Isco

Contacting 
Teledyne Isco Teledyne Isco

P.O. Box 82531
Lincoln, Nebraska 68501 USA
Phone: (402) 464-0231
USA & Canada: (800) 228-4373
Fax: (402) 465-3022
Internet: http://www.isco.com
E-mail:

iscoinfo@teledyne.com (for product information)
iscoservice@teledyne.com (for technical service)

Isco, Inc., was founded in 1958, and since its inception has been 
headquartered in Lincoln, Nebraska, USA. Through our focus on 
designing and building products to meet specialized customer 
needs, the company grew from founder Dr. Robert Allington’s 
garage into its current 200,000 square foot plant.

In June of 2004, Isco was acquired by Teledyne Technologies. 
(www.teledyne.com), becoming Teledyne Isco and beginning a 
new chapter in the company’s story.

Today, Teledyne Isco manufactures a wide range of products for 
professionals working in water pollution monitoring and 
abatement, chemical compound and drug discovery, chemical 
reaction engineering, and geochemical engineering studies of oil 
and gas reservoirs.

We have always taken pride in the fact that the products we 
produce are used by our customers to improve the quality of life 
on Earth. Benefits realized from the use of Teledyne Isco 
products range from maintaining a clean environment, to 
developing disease-curing drugs and finding new energy sources.

About Flowlink... Select the Help>About Flowlink... menu command to display 
information about your version of Flowlink, including the version 
number, license, and serial numbers. Note that Flowlink can be 
installed as Flowlink LE (a lite edition), Flowlink 5.1 (the 
standard edition), and Flowlink Pro (an enterprise edition). The 
differences are summarized in a comparison matrix on page 4. 

Flowlink 5.1 can be installed as a permanent license, or a 
temporary license in a 45-day demonstration mode or fixed-term 
lease.

In the Flowlink License window, if you click Cancel instead of 
entering the serial number, and exit the Activation Wizard, 
Flowlink LE will run with no time limit until licensing is 
completed.

http://www.isco.com
mailto:iscoinfo@teledyne.com
mailto:iscoservice@teledyne.com
http://www.teledyne.com
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Compatible 
Instruments

Flowlink is compatible with the following instruments:

• 2100 Series
• 2101 Field Wizard
• 2102 Wireless Communication Module
• 2103 Modem Modules
• 2105 Interface Modules
• 2160 Laser Flow Module
• 2108 Analog Output Module
• 2110 Ultrasonic Level Module
• 2150 Area Velocity Module
• 2150EX Area Velocity Module
• 2151 Area Velocity Modules

• Flow Meters
• 4210 Ultrasonic
• 4220 Submerged Probe
• 4230 Bubbler
• 4250 Area Velocity
• Signature Flow Meter
• Signature Bubbler

• Samplers
• 6712 Portable Sampler
• 6712FR Refrigerated Sampler
• Avalanche Transportable Refrigerated Sampler

• Modules (when connected to a 6700 Series or Avalanche 
Sampler)
• 701 pH/Temperature
• 710 Ultrasonic
• 720 Submerged Probe
• 730 Bubbler
• 750 Area Velocity
• 780 4-20 mA

• Pulse Doppler Flow Meters
• ADFM (Standard Open Channel)
• H-ADFM (Wide Channel)
• HotTap (Closed/Pressurized Pipe)
• accQmin (Shallow Water ADFM)
• accQpro (Deep Water ADFM)

• Miscellaneous
• 581 Rapid Transfer Device (RTD)
• 675 Logging Rain Gauge (no longer available)
• 676 Logging Rain Gauge
• 677 Logging Rain Gauge (Model 674 combined with a 

2105 Module)
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• SDI-12 devices (when connected to a 6712 Series or 
Avalanche Sampler controller, or 2105 Interface 
Module)

• YSI 600 Sonde (when connected to a 6700 Series or 
Avalanche Sampler controller, or a 4200 Series Flow 
Meter)

Flowlink 
Comparison Matrix

The table below summarizes the differences between Flowlink 
LE (a lite edition), Flowlink 5.1 (the standard edition), and 
Flowlink Pro (an enterprise edition).

Feature LE 5.1 Pro

Instrument Compatibility (see pages 3-4)

All 2100 Series Modules X X

2100 Series Modules, except 2101 Field Wizard X

4100, 4200, 6700* Series Instruments X X X

Signature Series Instrument X X X

700 Series Flow Modules (when connected to a
6700* Series Sampler)

X X X

581 Rapid Transfer Device X X X

675, 676, 677 Logging Rain Gauge X X X

SDI-12 Devices (when connected to a 6700* Series 
Sampler or 2105 Interface Module)

X X X

YSI 600 Sonde (when connected to a 6700* or 4200 
Series instrument)

X X X

All Pulse Doppler Instruments X X X

Graphs and Tables

Graph and Table View of single data
set (page 115)

X X X

Graph and Table View of multiple data sets (page 115) X X

User-specified graph display defaults (page 39) X X X

User-customized graph and table display properties, 
adjustable column widths, and templating (page 119)

X X

Statistical Functions, Off-line Flow and Volume 
Calculation, User-defined Series Formulas (page 122)

X X

User-defined graph Start Times (page 119) X X

Graph Annotations (page 132) X X

Scatter Plots (page 131) X X
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* 6700 Series Samplers include the Avalanche transportable 
refrigerated sampler.

Create and save global graphs in an enterprise 
database (page 21)

X

Data Editing

Graphical and Tabular views during
edit mode (page 137)

X X

Cut, Copy, Paste, and Insert (page 141) X X

Advanced editing tools to adjust data (page 139) X X

Restrict editing to only authorized users (page 45) X

Data Importing and Exporting

CSV Format Import (page 16) X X

CSV Format Export (page 19) X X X

PDF Format Export (page 19) X X

HTML Format Export (page 19) X X

Database Management

Use an Access (.MDB) database (page 27) X X X

Use an enterprise (Microsoft SQL or Oracle) database 
(page 27)

X

Receive data pushed from sites (page 55) X

Defragmenting (page 29) X X X

Archive, Restore from Archive (page 29) X X X

Backup, Restore from Backup (page 31) X X

Miscellaneous

Automation of Flowlink tasks
using Schedules (page 149)

X X

Recent Measurement display (page 35) X X

Flowlink activity log (page 43) X X X

Flowlink Server Logs (page 43) X

Manage Flowlink user accounts (page 45) X

Data Integrity Verification

Signature Flow Meter event viewer (page 110) X X X

Feature LE 5.1 Pro
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Isco Flowlink 5.1® Software

Getting Started

To get started quickly, it is important to be familiar with 
Flowlink’s main window. Items you will regularly use are the 
menu, toolbar, desktop, and most notably, the workspace. 
Please take a moment to locate these items below.

Getting Started - The 
Database

The powerful database gives Flowlink the strength and 
flexibility needed to manage your flow monitoring program. The 
Flowlink database is graphically depicted in the workspace.

The Flowlink workspace contains:

• Sites - instrument settings and retrieved data, and 
imported data

• Graphs and Tables - built from the readings held in the 
site records

• Schedules - Automated operations and the times they 
are to be performed

• Log - a record of scheduled activity.
At least one database must be created in order for the folders to 
appear in the workspace. Any number of databases may be 
located within the same directory.

Title Bar - Supports standard Windows commands such as, move, minimize, maximize, close, etc.

Menu - The Flowlink 5 menu commands are listed here. Click on a menu item to view a list of options.

Toolbar - The toolbar contains buttons that simplify routine actions performed in Flowlink 5.

Workspace - The workspace graphically displays the contents of the database.

Desktop - The Flowlink 5 desktop holds the open windows and dialog boxes.

Status Bar - Displays messages regarding the activities that Flowlink 5 is currently performing. When idle, it normally displays For Help, press F1.



Isco Flowlink 5.1® Software
Getting Started

8

Getting Started - 
Data

To create a new database, select Database > New. The default 
location for a database is in your computer’s local directory. 
Name your database and click OK.

Note: If you have just installed Flowlink, your database will be 
empty. You will not be able to open any folders in the workspace 
until the database contains some records. There are many ways 
to add data, but in this tutorial, we will discuss just two of them.

Convert existing site 
data

If you have upgraded from Flowlink 3, 4, or 5.0, you most likely 
have many site files containing instrument settings and data 
from interrogations. If you need to convert data created in 
Flowlink 3 for use with Flowlink 5.1, contact Teledyne Isco for 
assistance.

Updating a Flowlink 4 or 5.0 Database

If you need to convert data created in Flowlink 4 or 5.0 for use 
with Flowlink 5.1, open the Database Converter, a separate 
application included with your Flowlink 5.1 installation. (From 
the Windows Start button, choose Programs>Flowlink 
5.1>Database Converter.) For Flowlink 5.1, the Database 
Converter will convert .MDB and .SDB databases and archived 
.ZIP files; for Flowlink Pro, the Database Converter will 
convert the file types mentioned above, as well as central server 
databases (Microsoft SQL or Oracle). The Database Converter 
will also convert .zip files (leaving them in zipped format) and 
data transfer files (.sdb). Open the application and click 
Select DB.... In the Open Database window, browse to the 
database to be converted. From this window, you can also access 
detailed steps by clicking Help and then clicking on a topic in the 
left column.

Updating a Flowlink 5.1 Database

If you are attempting to open a Flowlink 5.1 database and 
receive a message that the database detected is a previous 
version, you can quickly convert it by clicking “Update Now.”

Note:

Although any Flowlink 5.1 user can perform this procedure, it is 
only necessary for 4300/4330 flow meter users. If you are not 
using a 4300/4330 system, you can also select “Don’t ask me 
again.”

Connect to an Isco 
Instrument

Connecting to an instrument will add the site information and 
instrument settings to the database. While connected, Flowlink 
can retrieve data from the instrument and save it in the 
database.

Getting Started - 
Connecting to 
Instruments

To connect to an Isco instrument (see pages 3-4 for a list of 
compatible instruments), you must first determine the method 
you will be using. Flowlink calls the serial or USB port 
connection a direct connection. Select a direct connection when 
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using an Isco interrogator or communication cable, or a short-
haul modem attached to your computer.

Select the modem connection when you want to communicate 
with an Isco instrument equipped with its own modem, through 
your computer’s telephone modem. Select wireless when you are 
using 2102 Wireless Communication Modules. Select TCP for 
remote serial communication with a 2100 CDMA modem-
equipped module, CDMA/GSM modem-equipped 6712 sampler, 
or CDMA/GSM/ethernet modem-equipped Signature flow meter, 
via a static IP or public domain address.

For initial communications setup, you need to connect your 
computer directly (physically) to the instrument.

Connecting - 2100/
4100/4200/6700/
4300 Instruments

1. Click the  Quick Connect button on the Flowlink 
toolbar, or press F11 on the keyboard. Flowlink opens the 
Quick Connect window.

2. Select the Type of connection- Direct, Modem, Wireless, 
or TCP.

3. Check the Create new site check box and then click on 
the large button for the type of instrument Flowlink will 
connect to.

4. After Flowlink reads the instrument settings, it will 
pause and ask if you would like to clear the memory 
partitions (4100/4200/6700), or delete all of the data in 
the modules (2100). Select “No” to retain the data. 
Flowlink then completes the connection process.

5. Once connected, Flowlink adds the instrument settings 
to its database and the site appears in the workspace.

6. Click the Retrieve Data/Interrogate button. Flowlink 
downloads the stored readings and adds it to the 
database.
NOTE: To retrieve only the data collected since the last 
interrogation, press Shift + F8 to open the Retrieve 
Options window.

Connecting - Pulse 
Doppler 
Instruments

1. Click the  Quick Connect button on the Flowlink 
toolbar, or press F11 on the keyboard. Flowlink opens the 
Quick Connect window.

2. Select the Type of connection- Direct, Modem, or 
Wireless.

3. Check the Create new site check box and then click on 
the large button for pulse doppler instruments.
The Pulse Doppler Connect window will appear.

4. Enter a site name and a device name, and select the 
radio button for ADFM (Standard or HotTap), accQmin, 
accQpro, or HADFM.
Click OK, and Flowlink creates a site window.

5. Click the Connect button, and Flowlink starts 
communication with the Pulse Doppler instrument.
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6. Once connected, Flowlink adds the instrument settings 
to its database and the site appears in the workspace.

7. Click the Retrieve Data button. Flowlink downloads the 
stored readings and adds it to the database.

8. NOTE: To retrieve only the data collected since the last 
interrogation, press Shift + F8 to open the Retrieve 
Options window.

Connecting - 
Signature 
Instruments

You can connect with the Connect window, or if you have 
connected with this site before, highlight the Signature site file 
in the workspace (left column in Flowlink) and select 
Item > Connect.

1. Click the  Quick Connect button on the Flowlink 
toolbar, or press F11 on the keyboard. Flowlink opens the 
Quick Connect window.

2. Select the Type of connection- Direct, Modem, Wireless, 
or TCP.

3. If you do not want the flow meter matched with an 
existing site in the database, select the Create new site 
check box. (If this is the first time the flow meter is 
connected to Flowlink, a new site will be created 
automatically.) Then click the large button under the 
heading Signature Series.

The Signature site screen has three tabs:

Site Info contains information specific to this site. Enter all 
relevant information into the Site Info fields, including the 
desired Site Name, and save the information by clicking Apply.

Devices lists the name, software version, and hardware version 
of the flow meter for offline viewing of the site file.

Program is the portal through which you access the Signature 
browser. The programming functions and displayed data in the 
browser are functions of the flow meter firmware, not Flowlink.

Getting Started - 
Instrument Data

If you connected to and retrieved data from an Isco instrument, 
your workspace should look similar to the one below.
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As you can see, the database now holds the site and instrument 
information, as well as downloaded readings such as Level, 
Rainfall, etc., contained in Data Sets. 

At this point, you may want to take a look at a few features. 
Three items are introduced in this Getting Started tutorial.

• The Site Window 
• Graphing Data 
• Editing Data 

A site file may be moved up or down to appear higher or lower in 
the list by clicking and dragging it to the desired position. You 
can quickly locate a single site in a large list by pressing 
Control+F to open a search window. This function will always 
take you to the first occurrence of the word you enter, and 
continue on to the next and so on.

You can find general instructions on typical Flowlink tasks in the 
“How do I…” section of Flowlink Help.

Getting Started - Site 
Window

The Site Window If you are connected to the instrument, you can see the Site 
window on the Flowlink desktop. If not, double-click on a site in 
the workspace and it will appear.

The Site Window (see pages 49, 77, and 113) lists the site name 
and the instrument model number, and a series of tabs where 
more specific instrument settings can be found.

Click on any tab in the site window to access the instrument 
settings. If you are familiar with programming the instrument, 
the settings on the tabs will be easy to recognize.

To make changes to an instrument’s settings, you must first be 
connected. Then, modify the settings and click the Apply button 
at the bottom of the Site Window. Flowlink will update the 
database and send the new settings to the instrument.

Getting Started - 
Graphing Data

Graphing Data To graph the readings in the data set, do the following.

1. Using the mouse, click once on a data set to highlight it.
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2. Double-click the data set or click the  Quick Graph 
button on the Flowlink toolbar.

Flowlink opens the Graph Window (see page 115) and displays 
the data as a graph. The graph toolbar should also appear beside 
the main toolbar. The graph toolbar will help you navigate (page 
118) through the display. If data is not present in the graph, click 

the  End of Data button on the graph toolbar to jump to a 
time span that contains data. 

Flowlink used its default graph settings to display the quick 
graph. You can change these by selecting Utilities>Options from 
the Flowlink menu and choosing the Graph Defaults tab (see 
page 39).

Right-click in the Graph Window and a menu appears. Select 
Properties, you will find that there are many options that allow 
you to customize the appearance of the graph (see page 119).

Graph Window

Getting Started - 
Editing Data

Editing Data To view or edit the readings in the data set, you must open the 
editor.

1. Using the mouse, click once on a data set to highlight it.

2. Click on the  Edit Data Set button on the Flowlink 
toolbar.

Flowlink opens the Editor Window and displays the data as a 
graph and as a table. The graph toolbar should also appear 
beside the main toolbar. The graph toolbar and the Actions menu 
will help you navigate (page 118) through the readings. 

Right-click while the cursor is over the Editor window and a list 
of possible actions appears. You can find additional actions on the 
Editor toolbar above the Flowlink desktop.
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Menu Commands

File Commands

File>New The File>New menu command brings up the options of creating a 
new:

• Site
• Graph or Table
• Schedule
• Schedule Task.

To create a new item:

1. Select File>New from the menu or click the  New 
button on the Flowlink toolbar.

2. Choose an option and click OK to create the new item.

File>Open File>Open displays a window where you can select the type of file 
to be opened. These options include: 

• Site
• Graph/Table
• Scheduled Time
• Schedule Task.

To open an item:

1. Select File>Open from the menu or click the  Open 
button on the Flowlink toolbar.

2. Select the type of file to open. The right side of the Open 
window will display a list of items that correspond to 
your choice.

3. Highlight an item from the list.
4. Click OK to open the file.

File>Close File>Close from the Flowlink menu closes the active window.

File>Save File>Save from the Flowlink menu or the  Save button on the 
toolbar saves the data in the active window.

File>Save As Select File>Save As from the Flowlink menu to save the data 
under a different name.
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File>Quick Connect File>Quick Connect from the Flowlink menu or the  button 
on the toolbar opens the Quick Connect window. The Quick 
Connect window is where you specify the type of connection and 
the settings to use for communicating with the Isco instrument. 
When using the Direct, Modem, and TCP connections, Flowlink 
will locate the correct site in the database for you. If the site is 
not in the database, a new one will be created. When using the 
Wireless connection, you must identify the site before Flowlink 
can continue.

Quick Connect This window specifies the type of connection and the settings to 
use for communicating with an instrument. It can be opened by 
selecting File>Quick Connect from the menu, pressing F11 on 
your keyboard, or clicking on the Quick Connect toolbar button. 
When using the Direct, Modem, and TCP connections, Flowlink 
will locate the correct site in the database for you. If the site is 
not in the database, a new one will be created. When using the 
Wireless connection, you must identify the site before Flowlink 
can continue.

Note: If you select a Pulse Doppler instrument, you will select 
the instrument type from the Pulse Doppler Connect window.

To connect to a site:

1. Review, and update if necessary, the connection settings.
2. Click on the large button that matches the type of 

instrument at the site.

Pulse Doppler 
Quick Connect

To connect to a site:

1. Review, and update if necessary, the connection settings.
2. Click on the large button that matches the type of 

instrument at the site.

3. Click the  Quick Connect button on the Flowlink 
toolbar, or press F11 on the keyboard. Flowlink opens the 
Quick Connect window.

4. Select the Type of connection- Direct or Modem.
5. Check the Create new site check box and then click on 

the large button for pulse doppler instruments.
The Pulse Doppler Connect window will appear.

6. Enter a site name and a device name, and select the 
radio button for ADFM (Standard or HotTap), accQmin/
accQpro, or HADFM.
Click OK, and Flowlink creates a site window.

7. Click the Connect button, and Flowlink starts 
communication with the Pulse Doppler instrument.

Connection Settings Type - Select “Direct” when connecting to the instrument 
through an interrogator cable, communication cable, or short 
haul modem attached to your computer’s serial port. Select 
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“Modem” to connect to the instrument through a telephone 
modem. Select “Wireless” when using the 2102 Wireless 
Communication Module. Select “TCP” for serial communication 
with a 2100 CDMA cellular modem-equipped module, CDMA/
GSM modem-equipped 6712 sampler, or CDMA/GSM/ethernet 
modem-equipped Signature flow meter, via static IP or public 
domain address.

Com Port - (Direct and Wireless) Select the Com Port from the 
pull-down list.

Baud Rate - (Direct and Wireless) Select the Baud Rate from 
the pull-down list. A rate of 9600 is recommended for 4100/4200/
6700 instruments when using Direct or Wireless. 

Select 38400 when direct connecting to 2100 and Pulse Doppler 
instruments, 19200 for wireless communication. 

Select 38400 when direct connecting to a 2101 Field Wizard.

Modem - (Modem only) Select an installed modem on the 
computer from the pull-down list. Flowlink will only list those 
modems installed in Windows. Flowlink will use the selected 
Modem and its Windows settings (Com port, baud, etc.) to make 
the connection. If you need to change the modem settings, open 
the Modem Control Panel. (Windows Start>Settings>Control 
Panel.) A baud rate of 9600 is recommended for 4100/4200/6700 
instruments, 38400 for 2100 and Pulse Doppler instruments.

• Select Default from the list to use the modem 
specified in Utilities>Options for the appropriate 
device type. This automatically selects the modem 
used for a specific site, from any computer.

Phone number - (Modem only) Enter a phone number with or 
without dashes. This number can include the following 
commands:

T (tone dial)
, (pause)
@ (wait for silence)
W (wait for dial tone)

TCP Address - (2100 w/ CDMA modem, 6712 w/ CDMA or GSM 
modem, or CDMA/GSM/ethernet modem-equipped Signature 
flow meter) Enter the correct static IP or public domain address.

Use the Create new site check box when you do not want 
Flowlink to match the instrument to a site in the database. This 
is useful when you have relocated an instrument to a new site. 
Flowlink creates a new site, lets you rename it, allows you to 
delete all the data from the instrument, and adds the new site to 
the workspace.

As a default setting, this window is displayed every time 
Flowlink is started. To disable this feature, leave the Show this 
dialog on startup check box (at the bottom of the dialogue box) 
blank.
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Notes: 

• You can control the default connection settings from 
Utilities>Options menu command. After opening the 
Options window, enter your default settings on the 4100/
4200/6700, 2100, Field Wizard, and Pulse Doppler tabs.

• You can quick connect by: 

• clicking the  Quick Connect toolbar button

• selecting File>Quick Connect from the menu
• pressing F11 on the keyboard
• highlighting a site in the workspace and selecting the 

Item>Connect menu command. 

File>RTD Transfer File>RTD Transfer from the Flowlink menu or the  button on 
the toolbar retrieves data stored in an Isco 581 Rapid Transfer 
Device (RTD).

This option starts the transfer of data from an RTD to the 
Flowlink database. Once started, Flowlink opens the Connect 
window and locates the first site stored in the RTD. Flowlink 
then reads the instrument information and matches it to a site in 
the database. If the site name is not found, a new site is created 
in the workspace. If the site name is found, but the instrument 
ID does not match, Flowlink will generate a new name for the 
site and add it to the workspace.

Next, Flowlink retrieves the site data stored in the RTD. The 
window displays a progress bar to monitor the activity. The data 
retrieval will continue for each of the instrument’s partitions. 
Flowlink repeats the site matching and data retrieval process for 
each instrument stored in the RTD.

File>Import Data Flowlink provides import functions for your data. The import file 
function allows you to load data from other sources such as non-
Isco instruments, or other information that exists in spreadsheet 
form. Select File>Import to import data in several formats.

Flowlink can import files created with WinADFM (software 
formerly used with Pulse Doppler instruments). These include 
station files (*.stn), which contain site information, and their 
corresponding data files (*.nnn where nnn is a number from 0-9). 
Both file types must be imported before the data can be viewed.

Flowlink can also import 2100 data dump files (*.ddp) and data 
files in comma-delimited format, also known as comma-
separated values (*.csv).

How to Import a Formatted CSV File:

1. From the Flowlink menu, select File>Import.
2. Type the path and file name, or browse for the file by 

clicking the Select… button.
3. Click Import. Flowlink begins to import the file.
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You can monitor the Status box that reports the current status 
and a progress bar, and the Statistics box that reports the 
number of data records, data types, and total records imported.

Flowlink is only able to import properly formatted CSV files. The 
format must include a data definition header to instruct Flowlink 
how to handle the information in the file. Data from non-Isco 
instruments and data from spreadsheet applications must also 
comply with this specific header format.

CSV imports: data 
definition header

The Data Definition Header is a format that is necessary for 
Flowlink’s Import and Export features.

The Header refers to the first rows in the .CSV file that classify 
the data. Flowlink supports a five or six line header. The first 
line, “Site Name” is optional and may be omitted.

If you have a Microsoft Excel or similar spreadsheet file to 
convert, check to ensure that it is formatted with the header. The 
example below shows the arrangement of data in this format.

Header Terms • Site Name - The site name stored within the 
instrument.

• Isco Quantity - The quantity of measurements such as 
flow, level, temperature, etc.

• Label - Sub-names such as test or specific titles you 
want for your data.

• Units - The unit of measure for each measurement.
• Resolution - The number of digits right of the decimal 

point as an indication of the number to be rounded. In 
the above example, level will always be displayed with 3 
digits after the decimal point.

• Significant Digits - The total number of digits to be 
displayed. In the example above, level will be displayed 
with as many as five significant digits.

Once in the proper format, the spreadsheet file should be saved 
(or exported) as a comma-separated-values (.CSV) file, also 
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known as a comma-delimited format. The lines below show the 
spreadsheet cells as a CSV text file:

Site Name, 5th & Main, 5th & Main

Isco Quantity, Level, Flow Rate

Label, Level, Flow Rate

Units, ft, gpm

Resolution,0.001,1

Significant Digits,5,7

12/18/04 14:45,0.2,40

12/18/04 15:00,0.201,40

12/18/04 15:15,0.2,40

12/18/04 15:30,0.2,40

12/18/04 15:45,0.2,40

12/18/04 16:00,0.2,40

Flowlink’s database can accept many different types of data once 
you’ve specified the necessary items in the header. For example:

Note: If you are unsure of how to correctly format a data 
definition header, export similar data from the Flowlink 
database. The resulting .CSV file can then be opened in a text 
editor or spreadsheet application where it can be viewed or 
copied.

File>Import Graphs 
and Tables

Flowlink can add graphs and tables to the database. This option 
allows you to share graph and table templates.

To import graphs and tables:

1. Select File>Import from the Flowlink menu. Flowlink 
opens a window to select which files to import.

2. From Files of type, select *.IGD.
3. Select the file(s) to import and click Open. Flowlink adds 

the graph and table files to the workspace where they are 
ready to be used as a global (shared via server) or local 
template.
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Graph and Table 
Templates

You can create and save your own graph and table templates, or 
use a template from Flowlink. Flowlink includes ready-made 
stock templates you can import into your database. The default 
location for these templates is in your local 
Programs\Flowlink 5.1 directory. In this directory, locate the 
Templates folder, where you will find subfolders for Graphs and 
Tables. These folders are further divided into Daily, Weekly, or 
Monthly templates for Single or Multiple Data Types, and for 
either raw data or averages for single-data type table templates.

File>Export Graphs 
and Tables

When a graph, table, or scatter plot is active on the Flowlink 
desktop, selecting File>Export will export the series data shown 
on the graph, table, or plot. Several export formats are available: 

• CSV (“Comma Separated Values”, also known as comma-
delimited), without summary. 
Flowlink exports CSV files with a Data Definition 
Header.

• CSV, with summary. For tables, the summary 
information appears in the last line of the file.

• PDF (Portable Document Format), for sharing and 
viewing data using Adobe Acrobat family of products, 
including the free Adobe Reader.

• HTML (HyperText Markup Language), for sharing and 
viewing data using an Internet browser.

• IGD (Isco Graph Document), for sharing of graph and 
table templates.

How to export data:

1. From the Flowlink menu, select File>Export.
2. Type the path and file name, or browse for the new 

location by clicking the Select… button.
3. Select the export format from the Save As Type box and 

click OK.
4. Click Export.

Flowlink displays its progress on the bar in the status box.

Notes:

• If transferring a graph exported as HTML to a new 
location, be sure to transfer two files: the HTML file and 
the referenced image file. Because of this requirement, 
PDF is often more suitable, especially when sending the 
exported file as an E-mail attachment.

• Exports can be automated using schedules (see page 
149). 

• If a CSV file with summary is imported into Flowlink, 
the summary data is not imported.

http://www.adobe.com/products/acrobat/readstep2.html
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File>Print File>Print from the Flowlink menu or the  button on the 
toolbar prints the graph or table that is currently active. 
Flowlink will use the print properties specified in the Print 
Setup.

File>Print Preview File>Print Preview from the Flowlink menu or the  button on 
the toolbar lets you see how your graph or table will look when 
printed. You can zoom in/zoom out, browse through multiple 
pages, or close the preview. To print from the print preview 
screen, click the Print button.

File>Print Setup File>Print Setup from the Flowlink menu opens a dialogue box 
where you specify printer settings for your installed printer. To 
modify printer settings, refer to your Windows and printer 
documentation.

File>Exit File>Exit on the Flowlink menu terminates the Flowlink 
application. If necessary, Flowlink will prompt you to save any 
open items before it shuts down.

Item Commands Options on the Item menu are the same as those available when 
you right-click on an item in the workspace. The options are 
variable and will change according to the item that is active. 
Typically, the options include several of the choices below:

• New: Creates a new Graph/Table, Schedule, or 
Scheduled Task according to which item or folder is 
highlighted in the workspace.

• Open: Opens the highlighted item. It will appear on the 
Flowlink desktop.

• Copy: Copies the highlighted graph or table.
• Connect: Starts communications with the highlighted 

site.
• Rename: Allows you to rename the item highlighted in 

the workspace.
• Delete: Deletes the item highlighted in the workspace. 

Note: Delete permanently removes the information from 
your database. Deleting a folder removes the contents of 
the folder. Deleting a site also removes the data sets.

• Schedule: Opens the Schedule Task window so you can 
automate a task.

• Quick Graph: When a site is highlighted, this graphs 
the site data using a pre-defined graph template. When a 
data set is highlighted, this graphs the selected data 
using the default graph properties (Utilities>Options 
from the menu, then select the graph defaults tab).

• Quick Graph with DEFAULT: This graphs the site 
data using the DEFAULT graph/table template located in 
the Graphs and Tables folder of the workspace. 
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• Copy to Default: This replaces the DEFAULT graph 
with the selected graph and its properties.

• Archive: When a site is highlighted, you can archive the 
site data.

• Save to Global folder: Flowlink Pro can create local 
graphs that only one user can view, or global graphs that 
can be viewed by all user accounts. The Save to Global 
Folder command saves the local graph settings in a 
Global folder so that other Flowlink Pro users can 
reproduce the graph their computer. See About Local and 
Global Graph Folders for more information.

• View Log: Opens the log file for review. This file is a 
history of Flowlink activities.

• Create Folder: Adds a folder to the workspace.
• Disable/Enable Task: Places an individual scheduled 

task on temporary hold.
• Run Now: Available when a Schedule is highlighted in 

the workspace. This runs the schedule immediately, 
regardless of the preprogrammed time and date.

• Help: Click on help to view help topics related to the 
highlighted item.

Notes:

Double-clicking on an item in the workspace performs the same 
operation as the first item in its right-click menu.

“Special” menu options are simply placeholders for menu 
commands that are not active for the highlighted item. 

About Local and 
Global Graph 
Folders

Flowlink Pro manages graphs (including scatter plots and tables) 
locally and globally. Local graphs are saved on the Flowlink Pro 
user’s computer and therefore are only visible to that user.

If you have made a graph that should be available to all Flowlink 
Pro users, you can save it in the Global folder using the 
Item>Save to Global Folder menu command. This saves the 
graph properties (not the data) on the Flowlink Server. When 
other users open the graph from the Global folder, Flowlink Pro 
reads the graph properties and reproduces it as a local graph on 
the user’s computer.

It is important to remember that all graphs are opened, viewed, 
and modified locally. Opening a Global graph, making changes, 
and then saving it (File>Save) will create a like-named graph in 
the local folder; however it is no longer the same as the Global 
graph. To update the Global graph, use the Item>Save to Global 
Folder menu command and overwrite the Global graph. 

Item>Quick Graph When a site or data set is highlighted in the workspace, clicking 
the Quick Graph button (or Item>Quick Graph from the menu) 
opens the data in a new graph.



Isco Flowlink 5.1® Software
Menu Commands

22

When a site’s data set is highlighted, Flowlink will use the 
default graph properties (Utilities>Options from the menu), then 
select the graph defaults tab, page 39, for the display settings.

When a site is highlighted in the workspace, the Quick Graph 
button or (Item>Quick Graph from the menu), opens the Select 
window so you can choose a template graph. The template is any 
graph that has already been created and formatted according to 
your needs. Once you have selected a template, Flowlink 
substitutes the template’s original data sets with those of the 
highlighted site.

Item>Quick Graph 
with DEFAULT

This graphs the site data using the DEFAULT graph/table 
template you specify in the Graphs and Tables folder of the 
workspace.

To save a graph as the DEFAULT template, first highlight the 
graph in the workspace. Then select Item>Copy to DEFAULT. To 
change the properties of the DEFAULT template, right click on 
the graph after it is displayed, and select Properties (see page 
119).

DEFAULT graphs can be generated by first highlighting a site in 
the workspace. Then, right click and select the Quick Graph with 
DEFAULT option.

DEFAULT graphs may also be generated while a site Window is 
open. To do so, click the DEFAULT button at the bottom of the 
site window, or press the F3 keyboard button. A common use of 
this feature is to quickly graph the site data before disconnecting 
from a site so you can view the data at a glance to check site 
conditions.

Item>Archive Site This menu option opens the Archive window (see page 29), 
allowing you to archive the data from the site highlighted in the 
workspace.

Item>Edit Data Set When a data set is highlighted in the workspace, clicking the 
Edit Data Set button (or Item>Edit from the menu) opens the 
Editor window (see page 137). Use the Editor to review or change 
the readings.

Item>Properties Selecting Item>Properties from the menu while a data set is 
highlighted in the workspace displays the properties window. 
The window reveals the data set name, the date and time of the 
first and last readings, and the number of data points.

Data Set Properties This window, opened by selecting Item>Properties from the 
menu, displays information about the selected data set. The top 
half of the window reveals the name, the first and last reading, 
and the number of data points. 

The Data type box displays how the information is stored in the 
Flowlink database.
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• Label - the type of reading
• Units - the units of measure for the data type
• Resolution - the possible number of places to the right 

of the decimal point
• Significant digits - the total number of digits that may 

be used to express the data
Click OK to close the Properties window.

Actions Commands The options available on the Actions menu will vary according to 
what is active on the Flowlink desktop. The options allow you to 
make selections from the keyboard instead of using the mouse.

Actions>Connect When a site is opened on the desktop, selecting Actions>Connect 
or pressing F7 starts Flowlink’s communications with the site. 

Actions>Retrieve 
Data

When connected to a site, selecting Actions>Retrieve Data from 
the menu or pressing F8 starts the transfer of data from the site 
to Flowlink’s database. To set what data to retrieve, select 
Retrieve Options.

Actions>Retrieve 
Options

To specify which data you wish to retrieve, select 
Actions>Retrieve Options. You can retrieve all data since the last 
interrogation, all data after a certain date, all data within a date 
range, or all data.

Actions>Diagnostics Select Actions>Diagnostics from the Flowlink menu to download 
and display a text file from a 2100 Series site. This file reports 
the performance of the module and its sensor. The measurement 
type will determine which information is included in this report.

Actions>Disconnect When connected to a site, selecting Actions>Disconnect from the 
menu or pressing F2 stops Flowlink’s communications with the 
instrument.

Actions>Apply When connected to a site, selecting Actions>Apply from the 
menu, clicking the Apply button on the site window, or pressing 
the F9 keyboard button sends new program settings to the 
instrument. This updates the instrument so it will match 
Flowlink’s site window settings.

Actions>Cancel When connected to a site, selecting Actions>Cancel from the 
menu or clicking the Cancel button on the site window restores 
the displayed site window settings to the program settings stored 
in the instrument. No changes to the instrument’s program 
settings will be made.

Actions>Switch to 
Tab

The Actions>Switch to Tab menu options select tabs in a Site 
window. These allow you use the keyboard to easily move about 
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the tabs. For example, to view the Data Storage tab of the Site 
window press “Alt+A, S, 4,” or use the Ctrl+4 shortcut.

You can also scroll through the Site window tabs by pressing 
Ctrl+Tab or Shift+Ctrl+Tab.

Actions>Maximize To maximize a graph, click on the  Maximize button on the 
graph toolbar, or select Actions>Maximize from the menu. You 
can return to the original view by pressing Esc (escape) or by 
clicking on the preview bar of the maximized graph.

Actions>Unzoom You can zoom in or out of any part of your graph. To zoom in, 
click and drag your cursor across the area of interest. To zoom 

out, click on the  Unzoom button on the graph toolbar, or 
select Actions>Unzoom from the menu.

Actions>Magnify When a graph is active on the Flowlink desktop, selecting 

Actions>Magnify from the menu, or clicking the  Magnify 
button zooms in on starting point of the graph.

Actions>Unmagnify When a graph is active on the Flowlink desktop, selecting 

Actions>Unmagnify from the menu, or clicking the  
Unmagnify button zooms out from the starting point of the 
graph.

Actions>Refresh When a graph is active on the desktop, selecting the 

Actions>Refresh menu option or clicking the Refresh  button 
refreshes the display if data has changed.

Actions>Enable 
Editing

When a graph is active on the desktop, selecting the 
Actions>Enable Editing option or clicking the Edit Data Set 
button activates the Editor Window. Here, you can modify raw 
site data.

Actions>Go To 
Options

When an Editor or Graph window is active on the Flowlink 
desktop, you can navigate by clicking the Actions>Go To from the 
menu. Go To brings up a submenu of navigation options, 
including:

• Beginning of data: Takes you to the first reading in the 
data set.

• End of data: Takes you to the last reading in the data set.
• Next timespan: Jumps to the next timespan. The 

timespan starts at the left-most point on the X-axis and 
ends at the Right-most point. For example, if a full day is 
displayed on the graph, Next timespan would jump to the 
following day. 
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• Previous time span: Jumps to the previous timespan.
• Jog Right: Jogs the display forward by 25%.
• Jog Left: Jogs the display backward by 25%.
• Specific Date/Time: Opens a dialogue box to enter a time/

date to display.
• Home Date/Time: (Graph Window Only) Jumps to the 

Home timespan. Home is a bookmark that you can set 
with the Set Home button on the Graph Toolbar, or 
Actions>Set Home Date/Time from the menu. 

Notes:

(Graph window only) Some actions will round the display times. 
When using the Quick Graph, or the Beginning or End of Data 
functions, Flowlink will round the starting point of the graph to 
the nearest hour or to the closest fifteen minute mark if the total 
timespan is less than ten hours. When using the Set Home Date/
Time, Flowlink also rounds the starting point as described and 
will also round the timespan to the nearest hour.

The timespan can be changed. For the Graph and Editor 
windows, enter a new timespan on the Time Scale tab of the 
Properties window (see page 121). 

Actions>Set Home 
Date/Time

When a Graph or Editor window is active on the Flowlink 
desktop, selecting Actions>Set Home Date/Time menu option or 

clicking the  Set Home button “bookmarks” the start date 
and time of the graph. This allows you to quickly jump to this 
home point from anywhere in the graph. 

Actions>Graph/
Table

When a graph or table is active on the Flowlink desktop, 
selecting Actions>Graph/Table from the menu, or clicking the 

 Graph/Table button toggles the appearance of the window 
between the graph and table views. 

Actions>Properties Selecting Actions>Properties or clicking the  Graph 
Properties button while a Graph or Table is active on the desktop 
opens the Properties window (see page 119). The Properties 
window contains the settings that control the appearance.

Actions>Calculate 
Data Sets

The Calculate Data Sets option is useful when you need “hands-
on” control of the summary intervals and statistical functions 
(see page 122). Calculate Data Sets should be used when a 
statistical function is applied to data and the results are needed 
in a subsequent operation. When attempting to perform complex 
analyses without this feature, you may find it is difficult to 
control the order of execution or specify when recalculated data 
or original data should be used. 

To illustrate this need, consider a level data set with readings 
taken at fifteen-minute intervals. If the data were to be displayed 
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in two different daily graphs - one graph applying an hourly 
summary interval with an averaging statistical function, the 
other without - you may find that the average daily levels are 
quite different. The first graph averages the 24 hourly data and 
the second averages of all the readings. If this series of data were 
to be used in another operation, it is important to understand 
which data, original or recalculated, Flowlink will use. Calculate 
Data Sets give you this hands-on control. 

The Actions>Calculate Data Sets menu option takes a snapshot 
of the data that appears in the graph or table. When you 
calculate a data set, Flowlink adds a site to the workspace. The 
name of the site is the same as the graph or table. This site is not 
an actual site; it is solely used for data storage.

Expanding the site in the workspace shows the data sets. 
Calculating data sets creates one set for each type of data that is 
plotted on the originating graph or table. Each data set will 
contain only those points used to plot the series over the 
timespan shown on the graph. 

Note: Flowlink can only create a data type once. If more than 
one series in a graph or table plots the same data type, Flowlink 
will create only one data set. For example, if the graph plots the 
level from three different sites in three panes, the level data set 
will only contain those points from the first series. If you must 
calculate data sets of the same type, use a separate graph for 
each required set.

Database Commands

Overview: Data retrieved from a site is stored in a Microsoft database 
(.MDB) that holds data from all sites. Any number of databases 
may be located within the same directory.

Note: Flowlink Pro can also store site data in a Microsoft 
database and in an enterprise database (Microsoft SQL 
or Oracle).

Flowlink has several menu commands that allow you to manage 
the database. Database commands include the following. Click on 
your choice for information about them.

• New… 
• Open… 
• Close 
• Defragment… 
• Archive/Transfer… 
• Restore From Archive… 
• Backup… 
• Restore From Backup… 
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Management Normally your site management and data collection is best 
served by a single database. Advantages of a single database can 
include:

• You can easily compare/combine data from different sites.
• You can automate routine tasks with schedules.

However, you may find advantages if you use more than one 
database. Among them:

• You can segregate projects.
• Site data can be held in a smaller database.

Any number of databases may be located within the same 
directory.

Database>New Select Database>New to create a blank Flowlink database.

Selecting this option displays a window to name the new 
database, and to select or create a new directory.

Database>Open The Database>Open menu command displays a dialog box to 
open a database. In Flowlink 5.1 and Flowlink LE, use this 
dialog to open an .MDB database.

In Flowlink Pro, you can use this dialog to connect to an .MDB or 
.SDB database, or a central server database (Microsoft SQL or 
Oracle).

Open Database Use the Open Database dialog to open a database for use.

Flowlink 5.1 and 
Flowlink LE

The Database field lists the selected database. This field will also 
remember databases that you have previously opened. To select a 
different database, view the drop-down list and select the desired 
database. If the desired database is not listed click Browse to 
locate and select the desired database.

Click the OK button to open the selected database.

In the event that a database in the drop-down list no longer 
exists, remove it from the list by selecting it and clicking the 
Delete button.

See Also: About Flowlink 3 Databases and About Flowlink 4 and 
5 Databases

Flowlink Pro Flowlink Pro can connect to an .MDB or .SDB database in the 
same manner described for Flowlink 5.1 and Flowlink LE. 

Flowlink Pro can also connect to a a central server database 
(MS SQL or Oracle). 

To connect to a central server database:

1. Connection to server database requires a .CFG 
(configure) file from the Server Database Administrator. 
Save this file from the administrator in a location easily 
accessed by the Windows PC running Flowlink Pro. 
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2. Click the Configure List button and locate the .CFG file. 
Click the open button to select the .CFG file. 

3. The names of the available databases are now visible in 
the Database field. Use the drop-down list to select the 
desired database.

4. Enter the User Name and Password provided by the 
Flowlink Pro Administrator.

5. Click OK to connect to the central server database. 

Note: Remote connections (not within the same IP domain) will 
require the Server Database Administrator to set up access to 
the database through a VPN, Alias, or similar remote access 
method. After configuring the remote access, steps 1 through 5 
will allow you to connect to the central database server as if it 
were a local connection. 

About Flowlink 3 
Databases

Data created in Flowlink version 3 must first be converted for 
use in version 5.1. Contact Teledyne Isco for assistance.

About Flowlink 4 
and 5 Databases

In order to use a Flowlink 4 or 5 database in Flowlink 5.1 or 
later, you must first convert the database structure. Database 
Converter is a utility opened separately from Flowlink. To 
convert a database:

1. Open Database Converter.
2. In the Database Converter window, click the Select DB... 

button.
3. The Open Database window is displayed. To select the 

database to be converted, use the drop-down list beside 
the Database field, or click Browse.
a. In Flowlink Pro, to connect to a central server, click 

Configure List. Locate and open the .CFG file.

b. The names of the available databases are now visible in 
the Database Field. Use the drop-down list to select the 
database.

c. Enter the User Name and Password provided by the 
Flowlink Pro Administrator.

4. Click OK>Convert.
5. A window is displayed, asking if you want to convert the 

database (filename). If the database is correct, click Yes.
6. During conversion, site names and parameters (Sysproc 

Name) are displayed in the Converter window.
7. At the end of the conversion, the Conversion Complete 

window is displayed. Click OK.
The Converter creates a new database file with the same file 
name followed by _NEW. (e.g., OldFileName_NEW.mdb)

Database>Close Database>Close closes the database.
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Database>
Defragment

The database (.MDB) file will continue to grow, reducing 
available disk space. Defragmenting the database will keep the 
growth of this file to a minimum. Defragmenting the database is 
also recommended if your PC has lost power or “hangs-up” while 
the database was open.

To defragment the database:

1. Select Database>Defragment from the menu. A window 
is displayed to note that this activity may take a few 
moments.

2. To continue, click OK. To defragment at a later time, click 
Cancel.

3. Locate the database and click OK. Flowlink then begins 
to defragment the database.

4. A window will notify you when Flowlink has finished this 
activity and whether it was successful or not.

Allowing Flowlink to automatically defragment the .MDB 
database at regular intervals is recommended.

Database>Archive/
Transfer

Allows you to copy or move data and/or site information from the 
open database and to put it into another location. Selecting 
Archive/Transfer from the menu opens the Archive window. 

The Archive/Transfer function allows you to selectively extract 
information from the open database by site name and by date 
ranges.

Archive This window, opened by selecting Database>Archive/Transfer, 
allows you to copy or move data and/or site information, or copy 
ensemble data from a Pulsed Doppler site, from the current 
database to another location.

Related Topics:

Use the Database>Backup command when you want to create a 
copy of the full database in a compressed format.

Use the Database>Restore command when you want to restore 
data in the current database from another database or archive 
file

Archive or Transfer: 
2100/4100,4200/
6700

1. Define what is to be archived: site information and/or 
data. If you select Archive to csv, no site information will 
be archived, and you will be given a dropdown list of data 
types to be archived.

2. If you have selected Data, define the data to be archived/
transferred.

3. Select the Site(s) to archive.
a. Check the box next to Selected Site(s). This makes the 

Select Site(s) button active.
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b. Click the Select Site(s) button to open the Select Site(s) 
window.

c. Check the box next to each site you want available to 
archive, or check the box next to Select All.

d. Click OK. The sites you selected now appear in the 
window.

e. Highlight the site to archive for each destination. Only 
one site may be archived at a time.

4. Select the type of archive - Copy or Move. Use the Move 
option with caution; Move deletes the data from the 
current database.

5. Identify the destination. Type a path and file name or 
click on the Select… button to open a dialogue box for 
saving the data to the desired database.

6. Compress destination file check box:
• Left unchecked, Archive will create an uncompressed 

.MDB file in the destination location. If storage space 
is not a consideration, this option is advantageous 
because Flowlink can directly open the .MDB file. 
When this box is left unchecked, the destination file 
must be saved in a folder other than the current 
folder.

• Checked, Archive will create a compressed .ZIP in 
the destination location. Compressed archives will 
save disk space and speed transfer times when you 
later move the files. File compression supports 
multiple disks when the entire archive will not fit on 
a single disk. Compressed .ZIP files may be saved in 
the current directory.

7. Click the Archive button to start the archiving. A 
progress bar will appear for each consecutive data set.

Archive: Pulsed 
Doppler Ensemble 
Data

When you check the box in the Archive window next to Export 
Ensemble Data, the data can only be archived, not transfered, 
meaning the original data is preserved in the database.

1. Define the data to be archived.
2. Select the Site(s) to archive.

a. Check the box next to Selected Site(s). This makes the 
Select Site(s) button active.

b. Click the Select Site(s) button to open the Select Site(s) 
window.

c. Check the box next to each site you want available to 
archive, or check the box next to Select All.

d. Click OK. The sites you selected now appear in the 
window.

e. Highlight the site to archive for each destination. Only 
one site may be archived at a time.
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3. Identify the destination. Type a path and file name or 
click on the Select… button to open a dialogue box for 
saving the data to the desired directory.

Database>Restore 
From Archive

Use this command to restore data in the current database from 
another database or archive file.

Use the Database>Restore from archive… menu option to restore 
data in the current database from another database or archive 
file.

To restore the database:

1. Select the data to restore. You can choose from All data or 
All data in a date range.

2. Identify the source of data. Type in the path and name of 
the .ZIP or .MDB file or locate it by pressing the Select… 
button. The destination will always be the open database.

3. Generally you won’t want to alter the sites and the 
instrument settings. Leaving the Restore site 
information check box blank will retain the existing 
settings. To overwrite the settings using the source 
information, check this box.

4. Click Restore.

Database>Backup This feature compresses the complete database (sites, graphs 
and tables, and schedules) into a backup (.ZIP) file.

To create a Backup:

1. Select Database>Backup from the menu.
2. A window is displayed with an explanation of the 

operation. To continue, click OK.
3. Select or enter the backup destination folder and file 

name.
4. Click OK.

Related Topic:

The Database Archive/Transfer command may be used when 
only part of the database (a site or date range) needs to be saved. 

Database>Restore 
From Backup

This feature decompresses the contents of a backup (.ZIP) file.

To restore from a backup file:

1. Select Database>Restore From Backup from the menu.
2. Locate the backup (.ZIP) file and click OK.
3. Select the destination directory and click OK. Flowlink 

closes the current database and begins to restore the 
backup database.
Note: If the database (.MDB) file already exists, you will 
be asked if you want to overwrite it. Overwrite the 
database only when you want to completely replace its 
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contents. To avoid an overwrite, click cancel. To restore 
the backup database without overwriting, select a 
different directory.

4. Flowlink displays a progress bar while it proceeds with 
the restore. When it is done, Flowlink opens the restored 
database.

View Commands The View options on the Flowlink menu allow you to display or 
hide toolbars and windows. Options include the following:

• Main Toolbar 
• Graph Toolbar 
• Pulsed Doppler Toolbar
• Edit Toolbar
• Status Bar 
• AutoHide Workspace 
• Comm Statistics (Communication Statistics) 
• 2100 Comm Statistics (2100 Communication Statistics) 
• 2100 Prompts 
• View Type>Recent Measurement Screen 

Selecting an option toggles the display of the item ON and OFF. 
Displayed options appear with a check mark.

View>Main Toolbar The main toolbar consists of these options:

• New: Opens a window to select the type of new item to 
create.

• Open: Opens a window to locate the item to open.
• Save: Saves the data, graph, or table that you are 

currently working on.
• Print: Prints the graph or table.
• Print Preview: View how your graph or table will 

appear on the printed page. This option is only active if 
you have a graph or table open.

• Quick Connect: Opens the Quick Connect window.
• RTD Transfer: Starts the transfer of data from an RTD 

to the Flowlink database.
• Quick Graph: Graphs the data in the highlighted data 

set using Flowlink’s default graph properties.
• Edit Data set: Opens the Editor window to review or 

modify the readings in the highlighted data set.
• Help: Activates the context-sensitive help. The cursor 

will change its appearance and Flowlink will display a 
help topic for any item that you click on.
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Flowlink displays the main toolbar when View>Main Toolbar on 
the menu is checked.

View>Graph Toolbar The graph toolbar, opened by selecting View>Graph Toolbar, lets 
you navigate through the data while editing a data set or 
creating a graph or table.

• Beginning of data: Jumps to the first reading in the 
data set.

• Previous time span: Jumps to the previous timespan. 
(Graph/Table timespans are defined on the Properties/
Time Scale tab. The Editor timespans are set on the 
Actions>Go To> Specific Date window.

• Jog Left: Shifts the view to the left 25%.
• Jog Right: Shifts the view to the right 25%.
• Next time span: Jumps to the next time span.
• End of data: Takes you to the last data entry for the 

graph you are working on.
• Go to Home Date/Time: A home date/time is a 

bookmark. Clicking on this option jumps to the bookmark 
set with the Set Home Date/Time button.

• Set Home Date/Time: Sets the current view as the 
Home Date/Time.

• Go To Specific Date/Time: Click on this option to go 
directly to a specific date or time.

• Table/Graph: Toggles the view between graph and table 
views.

• Edit/View: Toggles the view between graph view and 
data edit modes. 

• Scatter: Toggles the graph display between the normal 
view and a scatter plot. Scatter plots require two series of 
data. 

• Maximize: Displays the graph at the full size of your 
monitor. To return the graph to its original position, 
press the Esc (Escape) button or click on the title bar.

• Unzoom: You can zoom in or out of any part of your 
graph. To zoom in, click on the graph and drag your 
cursor to zoom in. You can zoom in horizontally or 
vertically. Right-click on the graph and select a zoom 
option from the pop-up menu. To zoom out (unzoom) click 
on the unzoom button on the graph toolbar.

• Magnify: Decreases the time scale in fixed steps. The 
steps are 1 hour, 4 hours, 12 hours, 1 day, 2 days, 3 days, 
1 week, 2 weeks, 1 month, 1 quarter, and 1 year.

• Unmagnify: Increases the time scale in fixed steps. See 
“Magnify” for the fixed steps.

• Refresh: Replots the graph if changes have been made to 
the data.

The Graph Toolbar display is enabled when the View>Graph 
Toolbar on the menu is checked. Flowlink will then display the 
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Graph toolbar when an Editor or Graph window is active on the 
desktop.

Note: (Graph window only) Some actions will round the display 
times. After clicking the Beginning or End of Data buttons, 
Flowlink will round the starting point of the graph to the nearest 
hour or to the closest fifteen-minute mark if the total timespan is 
less than ten hours. When using the Set Home Date/Time, 
Flowlink also rounds the starting point as described, and will 
also round the timespan to the nearest hour.

View>Pulsed 
Doppler Toolbar

The pulsed Doppler toolbar consists of the following functions:

• Flow Profile Graph: Displays a hydrograph and color 
contour plot of the flow profile.

• Velocity Graph: Shows the raw Doppler-based velocity 
components measured by each individual beam.

• Velocity Vector Graph: Displays the Velocity Graph 
measurements in an XYZ coordinate system.

• Amplitude Graph: Shows a graphical display of the 
received signal strength.

• Correlation Graph: Shows a measure of the quality of 
the processed velocity information.

View>Edit Toolbar The edit toolbar becomes active when you view measured data in 
the Editor window.

• Cut, Copy, Paste, Insert Before, Insert After: Use 
these commands while you are editing a data set.

• Undo All Editing: Undoes all editing to the site data. 
The readings revert to the last saved version.

View>Status Bar The status bar is shown at the bottom of Flowlink’s main window. 
It displays messages about the current activity, or while it is idle 
“For Help, Press F1.” The Status bar also lists the name and path 
of the current database.

Flowlink displays the status bar when View>Status Bar on the 
menu is checked.

View>Autohide 
Workspace

The workspace graphically displays the contents of the database.

The Autohide Workspace feature lets you move smoothly and 
quickly between the workspace and another window displayed on 
the screen. Activate it by selecting View>Autohide Workspace.

With Autohide active, moving the mouse pointer to the far left (or 
far right depending on where the workspace was docked last) will 
display the workspace. The workspace will disappear again when 
the focus (e.g. mouse pointer) is moved to a control other than the 
workspace.

If Autohide Workspace is deselected, the Workspace window will 
always be visible.
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View>2100 Prompts Selecting View>2100 Prompts from the Flowlink menu opens the 
2100 Prompt History window. This option is only active when 
Flowlink is communicating with a 2100 module.

View>Recent 
Measurements

The View>View Type>Recent Measurement Screen menu 
command opens a window that can display the last measurement 
of user-selected sites in the database. This window let’s you 
conveniently check measurements from all sites of interest 
without opening each site.

The Recent Measurement Screen displays:

• Site Name
• Device Name
• Parameter (measurement type)
• Value (of the last measurement added to the database, 

without units)
• Time Stamp (of last measurement)

The Recent Measurement Screen displays only selected sites. To 
select a site:

1. Click the Site Config button. Flowlink opens the Site 
Configuration window.

2. From the left half of the window, check a site to add to 
the Recent Measurement Screen. 
If you check the Select All check box, all sites and 
measurement types in the database are added to the 
Recent Measurement Screen. Be aware that “sites” in the 
database may be reference curves (page 131) or imported 
data (page 16), which may not need to be displayed. If 
you check the Select All box, you can skip step 3 and 4; 
this option also adds all measurement types.

3. From the right half of the window, check the site’s 
measurements that you desire to add to the Recent 
Measurement Screen. Use Select All check box to add all 
measurement types. 

4. Repeat steps 2 and 3 to add other sites.
5. Click the OK button. The Recent Measurement Screen 

displays all of the selected data. 

Graphs Command The Graphs menu options will vary according to the type of 
graph currently open. Flow Profile options are available when a 
Pulse Doppler graph is active on the desktop.

Graphs>Time Series Selecting Graphs>Time Series or clicking the  Time Series 
button while a Graph is active on the desktop displays selected 
data sets in a line graph. The Y-axis displays the units of 
measure and the X-axis displays the time and date. The bottom 
line in the graph window displays the timespan shown on the 
graph. All displayed times are referenced to the first data set of 
the first series.
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Graphs>Scatterplot Selecting Graphs>Scatterplot or clicking the  Scatter Graph 
button while a Graph is active on the desktop displays two 
selected data sets in a scatter graph format. The first series 
specified is always specified on the Y-axis, and the second series 
specified is always on the X-axis.

Graphs>Table Selecting Graphs>Table or clicking the  Table View button 
while a Graph is active on the desktop displays the data in 
tabular format.

Graphs>Flow Profile Graphing options appearing under Graphs>Flow Profile become 
active when a Pulse Doppler graph is active on the desktop.

Graphs>Profile 
Cross Section

Selecting the Graphs>Flow Profile>Profile Cross Section menu 

option or clicking the Flow Profile  button displays a 
hydrograph and color contour plot of the flow profile. The Y-axis 
represents channel height, and the X-axis represents channel 
width. Velocity is represented by different colors.

Graphs>Velocity Selecting the Graphs>Flow Profile>Velocity menu option or 

clicking the Velocity Graph  button shows the raw Doppler-
based velocity components measured by each individual beam.

Graphs>Velocity 
Vectors

Selecting the Graphs>Flow Profile>Velocity Vectors Graph menu 

option or clicking the Velocity Vector Graph  button displays 
these raw measurements in an XYZ coordinate system to 
produce the Vector profiles shown in the XYZ graph.

NOTE: Both the Velocity and Vector graph functions give 
information about the quality of the ADFM sensor installation 
and alignment. In a perfect installation, Beams 1 and 3, and 2 
and 4, will be equal in amplitude and opposite in sign. Beams 2 
and 4 will be approximately 50% greater in amplitude than 1 
and 3.

Graphs>Amplitude Selecting the Graphs>Flow Profile>Amplitude Graph menu 

option or clicking the Amplitude Graph  button shows a 
graphical display of the received signal strength. The amplitude 
normally decays from a high value near the sensor (bottom of 
graph) to a lower value at the end of the profile range (near top of 
graph). Large spikes should be expected where the beams hit the 
water surface.

Graphs>Correlation Selecting the Graphs>Flow Profile>Correlation Graph menu 

option or clicking the Correlation Graph  button shows a 
measure of the quality of the processed velocity information. 
Lower correlation values (e.g., below 100) are an indication of 
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poor quality data. Higher correlation values (e.g., above 150) may 
indicate external interference or the presence of an acoustic 
barrier (such as the surface).

Utilities Command For the Utilities menu options to be active, you must first have a 
database open. The Utilities menu contains the following choices:

• Options: Displays the options window that contains the 
default settings for Flowlink operations.

• Flow Conversions: A complete listing of flow conversion 
methods stored in the database.

• Merge Sites: Allows you to merge site data.
• View Log File: Displays the iscolog.txt file, a record of 

scheduled events as they occur.
• License: Opens the Flowlink License Activation wizard. 

Use this wizard when you need to renew or upgrade your 
Flowlink license. 

• Server Options: Opens the Server Options window to 
manage Flowlink Pro users and server alarms.

Utilities>Options Selecting Utilities>Options from the menu displays the Options 
window. This window contains the default settings for Flowlink’s 
operation. The tabs in the Options window contain settings for 
the following:

• 4100/4200/6700, 2100, Field Wizard, and Pulse Doppler
• Signature Event display time and Export directory
• Default Units of Measurement 
• Graph Defaults 
• Miscellaneous 

Instrument 
Connection Options

You establish default communication settings in the 
Utilities>Options window. There are four tabs, “4100/4200/6700”, 
“2100,” “Field Wizard,” and “Pulse Doppler” that hold these 
defaults. Flowlink will use the settings on both tabs to assume 
the type of instrument to which it is connecting, and which 
method (direct, modem, wireless, or TCP) Flowlink is to use. 

Default Connection 
Type

Connection type options include Direct, Modem, Wireless, and 
TCP. 

• Select the Direct option when connecting to Isco 
instruments through an interrogator cable, 
communications cable, or a short haul modem attached 
to your computer’s serial port.

• Select the Modem option to connect to instruments 
through a telephone modem.

• Select the Wireless option when using the 2102 Wireless 
Communication Module.

• Select TCP for remote serial communication via static IP 
or public domain address with a 2100 CDMA modem-



Isco Flowlink 5.1® Software
Menu Commands

38

equipped module, CDMA/GSM modem-equipped 6712 
sampler, or CDMA/GSM/ethernet modem-equipped 
Signature flow meter.

Default to … check 
box

Check this box on the instrument tab to direct Flowlink 
to use the communication protocol that is compatible for 
the device type to which you are primarily connecting. 
For example, if you are primarily connecting to Isco’s 
2100 devices, check the “Default to 2100” box on the 2100 
tab.

Direct/Wireless 
Connect

• Select the default Com port from the pull-down menu. 
Refer to your computer’s documentation for more 
information on Com ports.

• Select the default Baud rate from the pull-down menu. 
The highest baud rate setting will allow the fastest 
connections and data retrieval.

Modem Connect Select the modem from the pull-down list. All modems 
recognized by your Windows operating system will be 
listed here.
The modem you specify here will be the Default modem 
selectable from the drop down list on the Devices tab in 
the Site window.

Communication 
option check boxes

• Retrieve data gets text reports. Many Isco instruments 
can generate text reports. Check this box to retrieve the 
reports during an interrogation. If the reports are not 
needed, leave this box blank for faster interrogation 
times.

• Retrieve data uses Field Wizard first if included in the 
stack. Check this box if the Field Wizard is connected to 
one or more 2100 Series modules and you want to 
retrieve the Field Wizard’s data first, before the other 
modules.

• Display communication statistics. With this box checked, 
Flowlink displays a communications statistics window 
when it is connected to an instrument. This window 
shows the number of packets transferred between your 
computer and the instrument.

• Show connection dialog on startup. Check this box to 
display a connection window every time Flowlink starts. 

Save Click the OK button to save the default communication options.

Signature Series 
Event Table Defaults

For the Signature flow meter, Utilities>Options provides default 
selections for the time used to display data in Event Viewer, and 
the directory to which this data is exported.
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• Signature event data is displayed by default in tabular 
format, sorted by Event Time (time the event occurred). 
Using the drop down menu next to “Event display time,” 
this default can be changed to the last time the program 
was last downloaded into the database.

• The default location to which event data is exported is 
the My Documents folder on your PC. To change this 
setting, next to “Export directory,” click the Browse 
button and select the preferred default location.

Default Units 
Options

This tab, opened by selecting Utilities>Options from the menu, 
holds the settings for the default display units of measure and 
the default graph format properties.

• Highlighting a Quantity displays the available units of 
measure for that quantity.

• The highlighted Unit is the current default unit of 
measure. To change the default, simply highlight the 
desired unit of measure.

• The Format section on this tab shows the default graph 
properties for the highlighted quantity. To change the 
default properties, use the pull-down lists to specify the 
appearance of the Quantity when it is displayed in a 
graph.

• Click OK to save the Default Units.
You can also specify the units of measure when connected to an 
instrument or in the graph/table properties. The formatting can 
also be changed in the graph properties. These changes apply 
only to the current site or graph and do not change the default 
settings on this tab. 

Graph Default 
Options

The Utilities>Options Graph Defaults tab is used to set graph 
defaults. New and Quick graphs will use the settings to open the 
Graph window. Once the graph is open, you can customize the 
appearance with the Properties.

• Colors: Select default colors from the pull-down menus 
for the various graph elements.

• Grid Lines: Click on your choice of none, horizontal, 
vertical or both.

• Grid in front of data/Display shadow: Select the check 
boxes to enable these options.

• Change ‘Average’ label for volume: Select this check box 
to report a total volume, deselect this box to report an 
average volume. 

• Date and Time Range: Select today, this week, this 
month, yesterday, last week, last month, or absolute Date 
and time.

• Graph Font Size: Click on small, medium or large. 
• Change Table Font: Opens the Change Font dialog box, 

where you can select a specific font, font style, and font 
size that will be used when displaying a table.
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• Timespan: Enter a number and select hours, days, weeks, 
months, or years.

• Summary Interval: The summary interval works with 
the statistical functions to recalculate the data to be 
displayed.

Miscellaneous 
Options

The Misc tab (Utilities>Options) contains settings for the Editor, 
Log File size, and the Database maintenance frequency.

Editor default timespan - This is the timespan displayed when 
editing a data set using the Item>Edit menu command (see page 
22). Both the graph and the table of readings use the default 
settings from this tab. To set the timespan:

1. Enter a value in the number-entry box.
2. Select a time unit from the pull-down list. The two fields 

will then read the new timespan.
3. Click OK at the bottom window.

Table Max No. of Rows - This sets the maximum number of 
rows that will appear in the editor window. The default is 1440, 
which is a day of readings at one-minute intervals. Up to 16,000 
readings can be displayed in the table. However a large number 
of displayed readings may affect your computer’s performance. 

Database maintenance - You can instruct Flowlink to perform 
database maintenance at regular intervals. The maintenance 
will help keep the structure of the database intact, and 
defragment the database to keep the file size as small as 
possible. If you perform database maintenance, Flowlink can also 
prevent the log file (Iscolog.txt) from growing too large.

• Perform every ____ days. Enter a value between 1 and 
1000. Entering a “0” will disable the database 
maintenance.

• Truncate log file at ____ bytes. Enter a value between 
10000 and 60000. Flowlink will delete the oldest entries 
in the log file as the maintenance is performed.

Diagnostics - Advanced Flowlink diagnostic displays can be 
enabled by checking the “Enable various diagnostic features” 
check box. When checked, Flowlink will ask for a Diagnostic 
Password, which you must obtain from Teledyne Isco.

Utilities>Flow 
Conversions

Selecting Utilities>Flow Conversions displays the Flow 
Conversion List window.

This window lists the flow conversion methods used by the 
instruments in the database. Flow conversions are used to 
convert level (or level and velocity) measurements into flow rate 
data.

Additional flow conversion methods may be added for: 

• use as a template to set up a flow measurement 
instrument.

• off-line flow conversion.
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Flow Conversion 
List

This window lists the flow rate conversion methods used by the 
instruments in the database.

Additional flow conversion methods may be added for: 

• use as a “template” to quickly set up an instrument
• off-line flow conversion. Off-line flow conversions can 

offer many advantages:
• Use less instrument memory - If the instrument 

does not store flow rate data, more partition space is 
available for other reading types.

• Shorter data retrieval times - If the instrument 
does not store flow rate readings, data retrieval is 
typically quicker.

• Better flow rate resolution - An instrument’s flow 
rate conversion is limited by its internal flow 
conversion table and the number of significant digits 
held. Off-line flow conversions have no such limits. 

Each line in the window shows the name, type, and whether the 
flow conversion is in use by an existing instrument. These are 
added to the flow conversion list as you connect to new 
instruments.

From this window you may:

• Add a flow conversion 
• Edit a flow conversion 
• Delete a flow conversion.

To delete a flow 
conversion:

1. Highlight the flow conversion to delete. You may not 
delete a flow conversion used by an existing instrument.

2. Press the Delete button. The flow conversion is then 
removed from the flow conversion list.

Flow Conversion 
Edit

This window adds or modifies a flow conversion that appears in 
the Flow Conversion List.

To edit or create a new flow conversion:

1. Select a flow conversion type and define its attributes.
• Weir - Select the Type and Size or Crest length from 

the pull-down lists.
• Flume - Select the Type and Size from the pull-down 

lists.
• Flow Metering Insert - Select the type and size of 

flow insert from the pull-down lists.
• Manning Formula - Select the Channel type from 

the pull-down list. Then enter the Slope, Roughness, 
and channel dimensions. 

• Area Velocity - Select a channel type from the pull-
down list, enter the channel dimensions, and enter 
the silt level.
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• Equation - Enter the flow equation coefficients and 
the units.

• Data points - The set is listed in the data point set 
box. If the selected set is unused, or if you wish to 
view/change the set, press the Edit… button.

2. If you wish to create a new flow conversion in the list, 
type a name in the Flow Conversion Name box. Flowlink 
will not accept invalid characters, which are \ / : * & ? " < 
> ¦.

3. Click OK to accept the changes.
Note: Although you can open an “existing instrument” flow 
conversion, you cannot modify it. Any changes made to the flow 
conversion must be saved under a different name.

Utilities>Merge Sites The Utilities>Merge Sites menu command opens the Merge Sites 
window, a utility that can merge the data from two sites into a 
single site.

Merge Sites This utility merges data sets from two sites. Merging the data 
sets will copy the information from the source site to the 
destination site. 

This can be accomplished either by holding down the Shift key 
and dragging one site on top of the other, or by opening the 
Merge Site Data window by selecting Utilities>Merge Sites… 
from the Flowlink menu.

To use the Merge Site Data Window:

1. Specify the source site. Type the full name of the site or 
click on the Select… button to locate and select the site.

2. Specify the destination site. Type the full name of the site 
or click on the Select… button to locate and select the 
site.

3. If you wish to delete the source data after the merge, 
check the “Delete data from source after transfer.”
Note: This option is not available when using the 
Shift + drag merge method.

4. Click the Merge button.
5. Flowlink then opens a Merge In Progress window where 

you can monitor the merge activity.
Notes:

Use the merge feature with caution. Flowlink will merge all of 
the data sets from the source to the destination. This action is 
not reversible.

If the source and destination data set properties match (see page 
22), Flowlink writes the data from the source’s site data set to 
the destination’s site data set. Be aware that if reading times 
overlap in the source and destination data sets, the source 
readings, from the beginning of data to the end, will overwrite 
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any readings of the same time period in the destination site’s data 
set.

If the data set properties do not match, a new data set will be 
added at the bottom of the destination site.

Utilities>View Log 
File

Selecting the Utilities>View Log File menu command displays a 
log of recorded events. In Flowlink 5.1, this command displays 
the Iscolog.txt file.

When Flowlink performs a scheduled operation, the date, time, 
task name, and result are recorded in the Log File.

Flowlink Pro can display the same Iscolog.txt file when using an 
.MDB database. When using a server database, Flowlink Pro will 
display the Server Logs. Server Logs report database changes 
and failed transactions. 

Viewing the Log - 
.MDB Database

This window displays the ISCOLOG.TXT file - a record of events 
for an .MBD database.

When Flowlink performs a scheduled operation, the date, time, 
task name, and result is recorded in the Log File.

Reviewing the contents of the Log File will assist you in resolving 
problems with scheduled operations. Unsuccessful operations 
include the word “Errors” at the end of the string. This line is 
followed by a brief description of the error. The Log file identifies 
successful operations with “Success” at the end of the text string.

To open the ISCOLOG.TXT file, select Utilities>View Log from 
the menu.

Viewing the Server 
Log - Flowlink Pro 
Database

This window displays the Server Logs - a record of events for a 
server database. Most database changes and failed transactions 
are recorded in the Server Logs.

To open the Server Logs, select Utilities>View Log from the 
menu.

Reviewing the contents of the Log File will assist you in resolving 
problems with Alarm, Schedule, Database, and Device 
Connection operations. Unsuccessful operations include the word 
“Errors” at the end of the string. 

Entries in the Server Logs can be removed. To do so, highlight 
the entry and click the Delete button. 

Click the Close button to close the window. After closing the 
window you will have the opportunity to save the Server Logs as 
a text file. If you click Yes you will be able to choose a location 
and name the file.

Utilities>License Selecting the Utilities>License menu command opens the 
Flowlink License Activation wizard. Use this wizard when you 
need to renew or upgrade your Flowlink license.
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The wizard will guide you through the steps to receive a license 
key that unlocks the software according to the version of 
Flowlink that was purchased.

A valid serial number is required to license Flowlink.

Utilities>Server 
Options

This menu command opens the Server Options window from 
which a Flowlink Pro Administrator can manage accounts. The 
Server Options window includes settings for user management 
and server alarms.

Flowlink Pro Managers and Field Crew members may use the 
Server options to change their user password.

Server Alarms The Server Alarms tab of the Server Options window is used to 
set up alarm notification if the Flowlink Server fails to receive 
pushed data from a site within a user-specified duration, or when 
a user-defined alarm condition is met. These server alarms are 
delivered as E-mail or SMS text messages.

You may specify one to ten alarm notification groups. To specify 
an alarm notification group:

1. In the Alarm Notification Groups box, select a number 
between 1 and 10 from the pull down list.

2. Enter a contact name, Email address, and Email address 
for SMS text messaging.

3. Click Add. The contact information appears in the 
window below, and the fields are cleared for your next 
entry.
Continue adding contacts in this manner until you have 
completed the contact list for this group number.

4. To set up another group, simply select another number 
from the pull down list and repeat steps 2 and 3 as 
before.

To set up alarm notification:

1. In the Alarm Generation box, select the time duration for 
“Alarm when a site has not reported in...”
Note that this alarm is generated only once.

2. Click the Select Site(s). In the dialogue that appears, 
select the sites to be monitored.
Only sites with Alarm type SVR selected for the alarm in 
the site window will send conditional alarms to the 
server.

3. Select a number between 1 and 10 from the pull down list 
for Alarm Notification Group.
Note: record this number for use in the 2100 Site 
window’s Alarm Notification box.

4. Click Save and Flowlink creates the Alarm notification.
Note: Changes to the server alarms are reported in the Server 
Logs.
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Site Selection Use the Select Sites window to choose sites. Click the check box 
for each site you wish to select. To quickly select all sites, choose 
the “Select All Sites” option.

Click OK to save your site selections.

User Management The User Management tab of the Server Options window is used 
by a Flowlink Pro Administrator to set up and manage user 
accounts.

To set up a user account:

1. Open the Flowlink Server database using an 
administrator account.

2. Click the Add button to start a new user account.
3. Enter a user name. Special characters and spaces are not 

allowed in this field. An underscore (_) may be used as a 
space.

4. Enter a password for the user. Please note: 
• You can enter a default password. The user will be 

able to choose a new password after logging into the 
database. 

• If a user forgets their password, an Administrator 
can enter a new password. 

5. Enter the user’s initials. These two characters are used 
in the Server Logs. 

6. Enter the Name of the user. Spaces are allowed in this 
field.

7. Choose a role for the user.
8. Enter an E-mail address for the user. This optional field 

is used for server alarm notifications.
9. Enter an E-mail for SMS address. This optional field is 

used for server alarm notifications. Cellular phone 
services often support SMS text messages. Contact your 
cellular telephone service provider for more information 
on sending E-mail as an SMS text message. 

10. The Flowlink Pro server database can display graphical 
Flowlink data via the Internet. This web interface can 
support multiple languages. Choose the preferred 
language from the drop-down list.

11. Click the Save button to save the user data and create 
the account.

Existing accounts can be modified by selecting the User Name 
and modifying the data. Click the Save button to update the user 
data in the database.

To delete a user account, select the User Name and click the 
Delete button. 

User Roles There are three types of User roles in Flowlink Pro: 

• Administrator - an administrator has full rights and 
can:
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• Manages users
• View, append, and overwrite data
• Configure server alarms
• Archive and Transfer data
• Delete data after archive or transfer
• Modify device configurations

• Manager - a manager has limited rights that allow:
• View, append, and overwrite data
• Configure server alarms
• Archive and Transfer data
• Delete data after archive or transfer
• Modify device configurations

• Field Crew - a field crew member has rights limited to:
• View and append data
• Modify device configurations
• Archive and transfer data

Change Password To change a Flowlink Pro user password:

1. Select the Utilities>Server Options menu command.
2. View the User Management tab of the Server Options 

window.
3. Click on the Change Password button.
4. Enter the old password.
5. Enter the new password and confirm it.
6. Click OK to save the new password.

Window Commands

Flowlink Main 
Window

Select an area for a quick tour of Flowlink’s main window or click 
the Help Topics button for Flowlink’s contents and index.

Title Bar - Supports standard Windows commands such as, move, minimize, maximize, close, etc.

Menu - The Flowlink 5 menu commands are listed here. Click on a menu item to view a list of options.

Toolbar - The toolbar contains buttons that simplify routine actions performed in Flowlink 5.

Workspace - The workspace graphically displays the contents of the database.

Desktop - The Flowlink 5 desktop holds the open windows and dialog boxes.

Status Bar - Displays messages regarding the activities that Flowlink 5 is currently performing. When idle, it normally displays For Help, press F1.
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Window>Cascade The Window>Cascade menu command arranges the windows 
open on the Flowlink desktop so that they cascade from the top-
left corner. When items on the desktop are arranged in this 
manner, the title bars of the windows are visible so that you can 
quickly locate a window to view, maximize, minimize, or close. 

Window>Tile The Window>Tile menu command sizes and arranges the 
windows open on the Flowlink desktop so that they are all 
visible.

Window>Arrange 
Icons

The Window>Arrange Icons menu command places the icons for 
all minimized windows at the lower edge of the desktop.

Window>Close All The Window>Close All menu command closes all open and 
minimized windows.

Window>Workspace If you are working within a graph or another function and want 
to return to the workspace without using a mouse, you can select 
Window>Workspace from the menu. The keyboard shortcut for 
this action is Alt+0 (zero). The Workspace will then become the 
active window on the Flowlink desktop. Use the View>Autohide 
Workspace menu command to enable or disable the autohide 
feature.

Help Commands The Help menu provides information, instructions, or tips about 
various features and functions within Flowlink. 

• Context Sensitive Help F1 - Selecting this menu option or 
pressing the F1 keyboard button displays help for the 
active item in Flowlink. For example, press F1 with the 
graph window open and Flowlink displays help topics 
that can assist you with graphs.

• Contents and Index - Selecting this menu option opens 
Flowlink’s Help so you can navigate through the contents 
for help topics of interest or search the index for 
keywords.

• What’s This? Shift+F1 - Selecting this menu option 
changes the cursor to the What’s This help cursor. In this 
mode, clicking on any window menu or toolbar will 
display help for the selected item. 

• Getting Started - Selecting this menu option provides a 
brief tutorial that introduces you to basic features in 
Flowlink. 

• View Readme File 
• About Teledyne Isco (see page 2)
• About Flowlink... (see page 2)

Help>View Readme 
File

Selecting this menu item opens the Flowlink Readme file. This 
file contains the latest release information for this version of 
Flowlink.
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Isco Flowlink 5.1® Software

Site Window - 2100

The Site window contains information that identifies the site and 
all of the tabs necessary to set up the operation of the 2100 series 
modules.

The top of the Site Window continuously shows three items:

• Site Name - displays the site name stored within the 
instrument. Enter or modify the site name from the Site 
Info tab.

• Jump to measurement tab>> button - a short cut used 
to view any measurement properties tab.

• Instrument Time and Connection Status - displays 
the instrument time, which is refreshed every 15 seconds, 
and the current status of the communications link to the 
instrument.

The tabs in the Site Window allow you to view and change many 
settings that control the operation of the instrument. The 
number of active tabs will depend on the type of instrument and 
its data storage capabilities. Tabs that appear in the Site 
Window are:

• Site Info (page 50)
• Devices (page 50)
• Measurements (page 52)
• Data (page 52)
• Measurement Properties (page 56)
• Sondes (2105), page 64
• TIENet

(2160 Laser Module only), page 65
• Alarms (modem modules only), page 66
• Analog Output Channels (2108 only), page 67
• Power Control

(2102, modem modules only), page 68
• Pulse Doppler Support (page 68)
• Modbus Input (page 68)
• Modem Setup (page 68)

The Measurement Properties tab is variable, meaning its label 
and content will change according to which module and 
measurement you have selected. Use this tab to view or change 
the settings of the measurement type.

The buttons at the bottom of the Site Window are:

• Connect/Disconnect - Starts or stops communications 
with the instrument.
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• Retrieve Data - transfers data from the instrument to 
the Flowlink database.

• DEFAULT Graph - graphs the data using the 
DEFAULT template.

• Apply - Saves the modifications to the Site Window and 
updates the program settings in the connected 
instrument.

• Cancel - clears any modifications that you have made in 
the current tab and reverts to previous instrument 
settings.

• Help

Site Info - 2100 The Site Info tab of the 2100 Site window allows you to view and 
change the site’s name, location, date/time, GPS information, and 
other site-specific information.

Site Name - displays the site name stored within the 
instrument. To change the site name, type in the new name and 
click the Apply button. Site names can be up to 37 characters 
long. Any character may be used in the site name except the 
following: \ / : * & ? " < > |

Date/Time Box - displays the instrument’s and your computer’s 
time. These two times can be synchronized by pressing the 
“Synchronize Instrument’s Time To Computer’s” button. Use the 
Synchronize button with caution. Changing the time may affect 
the readings stored in the instrument’s memory partitions. 
Changing the time may cause readings to be overwritten, or 
“gaps” in readings may occur. It is recommended that you 
retrieve data from the instrument before synchronizing 
the time and date.

GPS Information Box - Enter the Altitude, Latitude, and 
Longitude of the site location for system mapping and other 
geographical locating purposes.

Devices - 2100 The Devices tab of the Site window displays the modules at the 
site.

The box lists all of the attached modules at the site. Each module 
will report a:

• Module Name - Identifies the module at the site.
• Model Name - The type of module.
• Model Number - Isco model number.
• Software Version - Level of software installed.
• Hardware Version - Level of hardware.

You can name the individual modules with more meaningful 
labels. To do so, highlight the module and click the Change 
Module Name… button. Module names can be up to 37 
characters long. Any character may be used except the following: 
\ / : * & ? " < > |
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All of the information is read directly from the module. The 
Model Name, Model Number, and Hardware version cannot be 
modified - they are set at the factory. The software version can be 
upgraded with the “Update Software” application (opened 
separately from Flowlink) if a newer software release is 
available.

The “Identify” button can help you locate a particular module 
when the connected site is made up of several modules. To 
identify the module, highlight the Module Name, then click on 
the Identify button. The Module will turn on its front-panel light 
so that you can identify which module at the site corresponds 
with the highlighted Module Name.

Press the “Configure Like Another” button to configure the 
current module so it has the same settings as another module. 
After pressing the button, you will be prompted to select a 
module from the Select A Module dialog box. Select the 
appropriate module and click OK.

Connection Information Box - Displays the settings used to 
communicate with the instrument. When off-line you can modify:

• Type - Direct, Modem, Wireless, or TCP. Select the 
Direct option when connecting to the instrument with a 
communication cable attached to your computer’s serial 
port. Select the Modem option to connect to the 
instrument through a telephone modem. Select Wireless 
when using 2102 Wireless Communication Modules. 
Select TCP for remote serial communication with a 2100 
CDMA modem-equipped module, CDMA/GSM modem-
equipped 6712 sampler, or CDMA/GSM/ethernet modem-
equipped Signature flow meter, via a static IP or public 
domain address.

• COM port - (Direct and Wireless) Select the appropriate 
COM port setting from the pull-down menu. Refer to 
your computer’s documentation for more information on 
COM ports.

• Baud Rate - (Direct and Wireless) Select the baud rate 
from the pull-down menu. Select 38400 when direct 
connecting to 2100 instruments, 19200 for wireless 
communication.

• Modem - (Modem Modules only) Select an installed 
modem from the pull-down list. Flowlink will only list 
those modems installed in Windows. Flowlink will use 
the selected Modem and its Windows settings (COM port, 
baud, etc.) to make the connection. If you need to change 
the modem settings, open the Modem Control Panel 
(Windows Start>Settings>Control Panel>Phone and 
Modem Options). A baud rate of 38400 is recommended 
for 2100 instruments.
• Select Default from the list to use the modem 

specified in Utilities>Options for the appropriate 
device type. This automatically selects the modem 
used for a specific site, from any computer.
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• Phone number - (Modem Modules only) Enter the 
phone number assigned to the instrument. This number 
can include the following commands:

T (tone dial) 
, (comma - pause)
@ (wait for silence)
W (wait for dial tone)

• TCP Address - (2100 CDMA modem-equipped module, 
CDMA/GSM modem-equipped 6712 sampler, or CDMA/
GSM/ethernet modem-equipped Signature flow meter) 
Enter the correct static IP or public domain address.

To save changes to the communications settings, click Apply.

Measurements - 
2100

When connected, Flowlink continually polls the site for “real-
time” readings. This tab of the Site window displays the real-
time readings. The number of modules and active sensors at the 
site will determine which readings are displayed.

The Measurements tab displays the input voltage for the system. 
This information will aid you in determining when battery 
powered instruments require service.

To view the real-time readings highlight the module(s) and 
Flowlink displays the data on the Measurements tab.

To view or set the properties of a specific reading type, click on 
the data label. Flowlink will then display the Measurement 
Properties tab.

When Flowlink is disconnected from the site, the last valid 
measurement values are shown.

Data - 2100 View and manage data storage for 2100 series modules from the 
Data tab of the Site window.

The top list box shows the Data Storage Name of each module. 
Each module reports:

• Max Readings - The total number of readings that the 
module can store.

• Utilization - Displays the amount of memory in use as a 
percentage.

• Oldest Reading - The time stamp of the oldest reading 
held in the module’s memory.

• Data Storage Fields - Reports how many of the 
available storage fields are in use.

When you select (highlight) a Data Storage Name, Flowlink 
shows detailed data storage information in the lower half of this 
tab.

The bottom list box displays measurement-specific data storage 
information for the module highlighted in the upper box. Each 
measurement type that may be stored by the module is listed in 
this box. Each measurement reports:



Isco Flowlink 5.1® Software
Site Window - 2100

53

• Measurement - the name of the measurement data
• Primary - the primary data storage rate.
• Secondary - the secondary data storage rate.
• Recent reading - the time/date of the most recent 

reading stored in the module.
• Readings - the number of readings stored in the 

module’s memory.
• Quality - a percentage that represents the number of 

valid readings out of the total number of readings.
The Calculated Flow button opens a window that allows flow 
rates to be calculated after retrieving the data. This can conserve 
memory and reduce the amount of data that must be transferred 
between the instrument and Flowlink. 

To view the details of a particular measurement, highlight the 
measurement in the lower half of the window and click on the 
“Measurement Details” button. Flowlink will then display the 
properties of the selected measurement type.

To configure the data storage rate of a particular measurement, 
highlight the measurement of interest and click the “Set Up Data 
Storage…” button. Flowlink displays the “Data Storage Setup” 
window. 

The Delete All Data button is active when connected to a 2100 
Series site. Clicking this button will delete all of the highlighted 
measurement data from the module. This is useful when you 
want to clear all of the readings from an instrument. This action 
does not delete any data stored in the Flowlink database.

The Pushed Data button opens the Pushed Data configuration 
window. Pushed Data allows 2100 Series sites that include a 
Modem Module to send data to an enterprise database server. 

Notes:

• Flowlink must be connected to the site to view the 
current Data Storage information. If Flowlink is Not 
Connected, the information displayed on this tab is the 
“last known” values. 

• Modules report “Time” as one of the measurement types. 
It is not a configurable measurement; it is only reported 
to indicate the number of readings and the amount of 
memory used to store time stamps. The module records 
time stamps at the fastest data storage rate of the 
remaining measurements.

Calculated Flow The Calculated Flow window allows you to instruct Flowlink to 
automatically calculate a flow based on actual level or area-
velocity readings collected by the instrument. This window is 
opened by clicking the Calculated Flow button on the Data tab of 
the site window.

Use this window to add Calculated Flow data sets to the site.
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1. Click the Add button in the Calculated Flow window. 
This opens the Flow Conversion List.

2. Select a Flow Conversion from the list and click the OK 
button. 
2100 Series Only - Because 2100 Series sites may include 
several flow modules, you must specify which level and 
velocity readings to use for the calculated data set. Use 
the Select Level and Velocity window to choose the 
modules.

3. If desired, click the Add button to add more Calculated 
Flows data sets. Otherwise, click the Close button. The 
Calculated Flow data set will appear in the workspace. 
2100 Series Only - Calculate Flow appears as a data set 
under the first module in the workspace.

Calculated flows are performed locally, which means that it is not 
necessary to have the flow measurement instrument perform 
this conversion and store the data until it can be transferred. As 
a result, data retrieval times can be reduced by collecting only 
primary data and not derivative calculations. Also, this feature 
may free memory partitions and extend number of days readings 
can be stored in the instrument. 

Note: If you alter the primary device of an existing calculated 
flow data set, the flow data already calculated will NOT be 
altered. You must first remove this data set and recreate it 
allowing the system to completely regenerate the calculated flow 
with the new primary device.

Data Storage Setup - 
2100

Use this window to configure the data storage rates for the 
measurement.

Modules can store measurements at a Primary and Secondary 
rate. Primary rates are fixed intervals at which the module will 
store measurements. Secondary rates allow you to change the 
data storage rate if the measurements meet your defined 
conditions.

Secondary storage rates are advantageous when you wish to 
examine measurement data in greater detail when a significant 
event occurs. Until the event occurs, the module stores data at 
the primary storage rate to conserve memory space and power. 
When the event occurs, the module preempts the primary rate 
and stores the data at the secondary rate. The secondary rate 
continues until the condition is no longer met (with a hysteresis). 
The examples below illustrate a few ways that secondary rates 
can be used.

• Store data more frequently if the flow rate is greater 
than or equal to 100 gpm.

• Don’t store data (primary rate OFF) until level is greater 
than or equal to 1 ft.

• Store data less frequently if input voltage is less than 9 
volts.

To configure data storage rates: 
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1. Select a primary rate from the pull-down list. Note that 
selecting “Off” only disables the primary rate.

2. Select a secondary rate from the “Store data every” pull-
down list. Note that selecting “Off” disables the 
secondary rate.

3. Set an equation that defines “When” the data should be 
stored at the secondary rate. This equation defines the 
condition or multiple conditions that must be present to 
trigger the secondary rate.
Note: When using secondary rates, the selected 
measurements are compared to the equation whenever 
its measurement is taken, whether it is a Primary or 
Secondary data storage rate.

After setting up the Data Storage rates, click OK to accept the 
settings, and Apply (F9) the new settings to the module.

Pushed Data Use this window to configure the 2103 Modem Module, or the 
2105 or 2103 Cellular Modem Modules, to push data to a 
Flowlink Pro database server.

Modems can send measurement data at a Primary and 
Secondary rate. Primary rates are fixed intervals at which the 
module will send all measurement data to the database server. 
Secondary rates allow you to change the pushed data rate if the 
measurements meet your defined conditions.

Secondary rates are advantageous when you wish to examine 
measurement data in greater detail when a significant event 
occurs. Until the event occurs, the module pushes all site data at 
the primary rate to conserve power and modem usage. When the 
event occurs, the module preempts the primary rate and pushes 
data at the secondary rate. The secondary rate continues until 
the condition is no longer met (with hysteresis). The examples 
below illustrate two ways that secondary rates can be used.

• Push data more frequently if the flow rate is greater than 
or equal to 100 gpm.

• Don’t push data (primary rate OFF) until level is greater 
than or equal to 1 ft.

To configure pushed data: 

1. Select a primary rate from the pull-down list. Note that 
selecting “Off” only disables the primary rate.

2. Select a secondary rate from the “Push data every” pull-
down list. Note that selecting “Off” disables the 
secondary rate.

3. Set an equation that defines “When” the data should be 
pushed at the secondary rate. This equation defines the 
condition or multiple conditions that must be present to 
trigger the secondary rate.
Note: When using secondary rates, the selected 
measurements are compared to the equation whenever 
measurement is taken at the data storage rate, and at 
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the Parameter Measurement Interval on the Equation 
Builder window

4. Enter the Flowlink Pro Server Information. If using a 
2103 Telephone Modem, Select the Modem Listener 
Option, then enter the telephone number to dial into the 
Flowlink Pro Server. If using a 2103c or 2105c Cellular 
Modem, select the IP Listener option, then enter the 
Flowlink Pro Server IP address and Server Port Number.
Note: Contact your Server Administrator for the Modem 
and IP listener information.

After setting up the Pushed Data rates, click OK to accept the 
settings, and Apply (F9) the new settings to the module.

Pushing Data from 
4200 and 6700 
Series Instruments 
(2105 only)

The 2105 module can capture, log, and push data from 4200 
Series flow meters and 6700 Series samplers. The 2105 
interfaces with the instrument through a simulated Modbus 
connection. 4200/6700 data parameters must be entered as 
Modbus parameters.

For complete Modbus input information for 4200/6700 
instruments, see your 2105 instruction manual.

Measurements - 
2100

This tab of the Site window displays the settings for the selected 
measurement type. The module and its functions determine 
which settings are available. This tab is variable, meaning its 
label and content will change according to which Module and 
measurement type you have selected.

From this tab you may:

• View the Module and Measurement name.
• View the current reading.
• Modify the measurement settings and unit of measure (if 

user-configurable).
• Setup Data Storage…
• Diagnostics… - Clicking this button downloads and 

displays a text file from the module. This file reports the 
performance of the module and connected devices. The 
measurement type will determine which information is 
included in this report. If you are not connected to the 
module, it displays the last available diagnostic report. 

• Hide in Measurements check box - when left unchecked, 
the Measurements tab displays this reading. If selected, 
the Measurements tab does not display this reading.

If you have made any changes, click on the Apply button to 
update the settings in the module.

See also:

Level, Velocity, Flow Rate, Total Flow, Rainfall, Sampler, Sonde, 
and 360 Velocity tabs
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Note that the Measurements tab for the 2160 Laser Velocity 
Module will specify either “360” for the TIENet 360 LaserFlow 
Velocity Sensor, or “350” for the TIENet 350 Area Velocity Sensor.

Level - 2100 The Level tab of the Site window is used to view or change level 
measurement settings. Access this tab by clicking on the “Level” 
label on the Measurements tab.

Modules able to read liquid levels can display this tab. From this 
tab you may:

• View the Module and Measurement name.
• View the current level measurement.
• Set the measurement units by selecting an option from 

the pull-down list.
• View the date/time that the level was adjusted.
• Adjust (calibrate) the level sensor reading. To adjust the 

level, enter the current flow stream level and Apply the 
change. To synchronize the levels and apply the change 
to all the sensors at once, select the “Adjust ALL level 
values” check box.

• Set Up Data Storage… 
• Diagnostics… - Downloads and displays a text file from 

the module. This file reports the performance of the 
module and its sensor. 

• Hide in Measurements check box - when left unchecked, 
the Measurements tab displays this reading. If checked, 
the Measurements tab hides this reading.

If you have made any changes, click on the Apply button to 
update the settings in the module.

Level Diagnostics After downloading the diagnostics from the module, Flowlink 
displays the information in the Report window. This information 
can be useful when evaluating the sensor’s performance, or when 
troubleshooting a problem with the assistance of Teledyne Isco’s 
Technical Service Department. A brief outline on how to read a 
level diagnostics report appears below.

The first section identifies when the report was created and the 
type of report. 

The second section provides information about the attached level 
sensor. 

The third section lists the ten most recent measurements. Recent 
measurement data is listed in columns:

• Date and Time - the instrument’s date and time that 
the measurement was taken. 

• Level - The value of the measurement. The unit of 
measure is shown enclosed in parentheses. 

• Calibration and Offset - These values are associated 
with an analog to digital conversion process. Erratic or 
widely drifting numbers, when coupled with other 
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measurement problems may indicate a need to consult 
with Teledyne Isco’s Technical Service Department. 
“(None)” simply indicates that there are no units of 
measure associated with the Calibration and Offset 
values.

The fourth section lists Possible Measurement Problems in 
columns. These columns can be read just as the Recent 
Measurements except that an additional column identifies the 
type of measurement problem.

Velocity - 2100 The Velocity tab of the Site window is used to view or change 
velocity measurement settings. Access this tab by clicking on the 
“Velocity” label on the Measurements tab.

Modules able to read liquid velocities using continuous wave 
Doppler can display this tab. From this tab you can:

• View the Module and Measurement name.
• View the current Velocity measurement.
• Set the measurement units by selecting an option from 

the pull-down list.
• Enter a Zero level offset value.
• Control how flow readings are recorded if the module is 

unable to measure velocity. Check the “Set flow rate to 
zero if no velocity data” to record the flow rate as “0.000” 
when the module is unable to take a velocity reading. If 
the check box is left blank, a no data code will be 
recorded instead.

• Prevent interference from other velocity measurements. 
If the area velocity sensors of a multiple-module site are 
placed near each other, it is important that each sensor 
receives its own transmitted signal. Check this box when 
multiple area velocity sensors are located in the same 
channel so that the site will ensure only one velocity 
measurement is taken at a time. Leave this box 
unchecked for single-module sites or multiple module 
sites measuring velocities in separate channels.

• Positive Velocities Only check box. Select this box to log 
only positive velocities; negative velocities (reversed 
flows) are ignored. To log both positive and negative 
velocities leave this box blank. 

• Set Up Data Storage… 
• Diagnostics… - Downloads and displays a text file from 

the module. This file reports the performance of the 
module and its sensor. The measurement type will 
determine which information is included in this report.

• Hide in Measurements check box - when left unchecked, 
the Measurements tab displays this reading. If checked, 
the Measurements tab hides this reading.

If you have made any changes, click on the Apply button to 
update the settings in the module.
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360_Velocity - 2160 The 360 Velocity tab of the Site window is used to view or change 
laser velocity measurement settings. Access this tab by clicking 
on the “Velocity Corrected” label on the Measurements tab.

Modules able to read liquid velocities using Laser Doppler can 
display this tab. From this tab you can:

• View the Module and Measurement name.
• View the current Velocity measurement.
• Set the measurement units by selecting an option from 

the pull-down list.
• Choose to log only positive velocities, or both positive and 

negative velocities. In the Positive Velocities Only check 
box, select “true” to log only positive velocities; negative 
velocities (reversed flows) are ignored. To log both 
positive and negative velocities, select “false.” 

• Set Up Data Storage… 
• Diagnostics… - Downloads and displays a text file from 

the module. This file reports the performance of the 
module and its sensor.

• Hide in Measurements check box - when left unchecked, 
the Measurements tab displays this reading. If checked, 
the Measurements tab hides this reading.

2160 Setup To assist in positioning the LaserFlow sensor above the stream 
during installation, you can keep the laser beam constantly on by 
clicking the Laser on button. The laser beam will stay on for 10 
minutes, or until you click the Laser off button.

During initial setup, in the Multipoint box, check Select All (next 
to the Advanced button).

After about 5 minutes, a velocity reading will appear for each of 
the 15 points in the Multipoint box. This will help you to 
determine which points are necessary for your velocity 
measurement, and which ones can be deselected for operation. 
An algorithm constantly maintains the relationship between all 
points. You can set the 2160 to take measurements at 1 to 15 
points per reading; the more points that are used, the longer one 
reading will take to complete.

The velocity coefficients of the multipoint function are pre-
programmed into the 2160 module at the factory. However, if 
your application requires the addition of any correction factors, 
the Advanced button opens the Advanced settings window, where 
V = A (offset) + BV (slope) + CV2 (second-order parameter).

If you have made any changes, click on the Apply button to 
update the settings in the module.

Zero Level Offset Area Velocity sensors are sometimes mounted higher on the side 
of the channel to avoid silting.

• If the Area Velocity sensor is mounted on the side of the 
channel, enter the vertical distance from the bottom 
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center of the channel. Refer to the instrument’s 
instruction manual to calculate this distance.

• If the Area Velocity sensor is mounted at the bottom of 
the channel, simply set the Zero level offset to zero.

Velocity Diagnostics After downloading the diagnostics from the module, Flowlink 
displays the information in the Report window. This information 
can be useful when evaluating the sensor’s performance, or when 
troubleshooting a problem with the assistance of Teledyne Isco’s 
Technical Service Department. A brief outline on how to read a 
velocity diagnostics report appears below.

The first section identifies when the report was created and the 
type of report. 

The second section provides information about the attached 
velocity sensor. 

The third section lists the ten most recent measurements. Recent 
measurement data is listed in columns:

• Date and Time - the instrument’s date and time that 
the measurement was taken. 

• Signal% - the approximate strength of sensor’s return 
signal. Percentages below 10 indicate a weak signal. 
Percentages near 100 indicate a strong signal. Normal 
percentages are from 10 to 90.

• Spectrum% - Reports the amount of noise in the area 
velocity return signal. Percentages below 25 indicate a 
noisy return signal, while percentages near 100 indicate 
a clear signal. Percentages should never vary more than 
25% from one reading to the next. Wide variations 
indicate an unstable installation. Low percentages 
should not cause concern if the level and velocity 
readings are accurate and reliable. It is possible that low 
percentages are normal for your installation and the 
characteristics of the flow stream.

• Velocity - The value of the velocity measurement. The 
unit of measure is shown enclosed in parentheses.

• Level - The measured level at the time of the velocity 
measurement. The unit of measure is shown enclosed in 
parentheses.

The fourth section lists Possible Measurement Problems in 
columns. These columns can be read just as the Recent 
Measurements except that an additional column identifies the 
type of measurement problem.

Velocity diagnostics are most beneficial when monitored long-
term. A slow drop in percentages can indicate silt or debris 
building up near the sensor, while a sudden large change can 
indicate a failure at the site.

Flow Rate - 2100 The Flow Rate and Flow Rate 2 tabs of the Site window are used 
to view or change flow conversion settings. Access this tab by 
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clicking on the “Flow Rate” or “Flow Rate 2” label on the 
Measurements tab.

Modules able to calculate flow rates can display this tab. From 
this tab you may:

• View the Module and Measurement name.
• View the current flow rate measurement.
• Select a flow conversion method from a pull-down list.
• Specify the Conversion type.
• Enter the applicable parameters for the chosen 

conversion type.
• From the Flow rate measurement dropdown list, set 

measurement units by selecting an option from the pull-
down list.

• If more than one instrument is configured to measure 
level, select the desired instrument from the Level Input 
dropdown list.

• Set Up Data Storage… 
• Diagnostics… - Downloads and displays a text file from 

the module. This file reports the performance of the 
module.

• Hide in Measurements check box - when left unchecked, 
the Measurements tab displays this reading. If checked, 
the Measurements tab hides this reading.

If you have made changes to the settings on this tab, click on the 
Apply button to update the module.

Flow Rate 
Diagnostics

After downloading the diagnostics from the module, Flowlink 
displays the information in the Report window. This information 
can be useful when evaluating the module’s performance, or 
when troubleshooting a problem with the assistance of Teledyne 
Isco’s Technical Service Department. 

Flow Rate Diagnostics only presents limited information, 
typically:

• Date and Time - the instrument’s date and time that the 
report was generated. 

• A line indicating that the module’s internal flow 
conversion is valid

• The silt level, as entered on the Flow Conversion tab 
when using area velocity as the flow conversion method.

• The calculated silt area.

Total Flow - 2100 The Total Flow and Total Flow 2 tabs are used to view total flow 
settings for modules able to calculate total flows. Access this tab 
by clicking on the “Total Flow” labels on the Measurements tab.

From this tab you may:

• View the Module and Measurement name.
• View the total flow measurement.
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• Set the measurement units by selecting an option from 
the pull-down list.

• Zero the total flow. The “Zero Total Flow” button resets 
the cumulative flow.

• Set up the total flow calculation:
Input flow rate - select the flow rate to be used in the 
total flow calculation.
Totalizer - select the type of total flow calculation: 
Net, Positive, or Negative.
Resolution - shift the decimal point left or right to set 
the desired resolution.
Update total flow every - the interval between total 
flow calculations.

• Set Up Data Storage… 
• Diagnostics… - Downloads and displays a text file from 

the module. This file reports the performance of the 
module and its sensor. The measurement type will 
determine which information is included in this report.

• Hide in Measurements check box - when left unchecked, 
the Measurements tab displays this reading. If checked, 
the Measurements tab hides this reading.

If you have made any changes, click on the Apply button to 
update the settings in the module.

Zero Total Flow Cumulative flow reported will eventually reach a maximum 
value, depending on the flow conversion method and units 
selected. At this point, the total flow will roll over, just as a car’s 
odometer would.

The Zero Total Flow button allows you to reset the cumulative 
flow at known intervals so that more meaningful values can be 
represented by this field. It is also helpful to zero the total flow 
after moving the flow meter to a different site. 

Total Flow 
Diagnostics

After downloading the diagnostics from the module, Flowlink 
displays the information in the Report window. This information 
can be useful when evaluating the module’s performance, or 
when troubleshooting a problem with the assistance of Teledyne 
Isco’s Technical Service Department. 

Total Flow Diagnostics presents limited information, typically:

• Date and Time - the instrument’s date and time that the 
report was generated. 

• Any fault indication associated with the Total Flow 
Calculation.

Rainfall - 2100 
(2105)

The Rainfall tab of the Site window is used to view or change 
rainfall measurement settings. Access this tab by clicking the 
“Rainfall” label on the Measurements tab.
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The 2105 Interface Module can display this tab. From this tab 
you may:

• View the Module and Measurement name.
• View the total rainfall since midnight.
• Set the measurement units by selecting an option from 

the pull-down list.
• Set the rain volume per bucket tip.
• Set Up Data Storage...
• Diagnostics... - Downloads and displays a text file from 

the module. This file reports the performance of the 
module and rain gauge.

• Hide in Measurements check box - when left unchecked, 
the Measurements tab displays this reading. If checked, 
the Measurements tab does not display this reading.

If you have made any changes, click the Apply button to update 
the settings in the module.

Sampler Control - 
2100 (2105)

The Sampler tab of the Site window displays the settings used by 
a 2105 Interface Module to control a connected sampler. The 
2105 can control two sampler functions - sampler enable and 
sampler pacing.

The 2105 Interface Module can display this tab. From this tab 
you may:

• View the Module and Measurement name.
• View the sampler’s current Bottle Number and Enable 

Status.
• Set Sampler Enable conditions.
• Hide in Measurements check box - when left unchecked, 

the Measurements tab displays this reading. If checked, 
the Measurements tab does not display this reading.

If you have made any changes, click the Apply button to update 
the settings in the module.

Sampler Enable Set up the sampler enable by choosing one of the three options in 
the Sampler Enable box:

Always - the sampler remains enabled regardless of changing 
conditions.

Never - the sampler remains disabled.

On Trigger - The sampler is enabled when a user-defined 
condition is met. Select Latch to keep the sampler enabled after 
the condition is no longer true. The enabled state will continue 
until the Reset Latch button is pressed.

Sampler Pacing From the Sampler Pacing box, select either None or Flow Paced.

• None - The 2105 will not send flow pulses.
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• Flow Paced - paces the sampler at a rate proportional to 
the flow rate by using volume intervals. Use the Flow 
Pulse setting to set the interval.

Flow Pulse A flow pulse is a 50 millisecond voltage pulse used to pace a 
sampler. Select the flow rate for sampler pacing, and the units of 
flow volume, from the drop down lists. In the middle field, enter 
the desired flow volume interval.

It is important that this setting, and the sampler’s setting for 
pulses between sampling events, work together to produce the 
desired volume interval. For example, if the 2105 sends a flow 
pulse every 100 gallons, and the sampler takes a sample every 10 
flow pulses, the actual volume between samples is 1000 gallons.

Sampler 
Diagnostics

After downloading the diagnostics from the module, Flowlink 
displays the information in the Report window. This information 
can be useful when evaluating the module’s performance, or 
when troubleshooting a problem with the assistance of Teledyne 
Isco’s Technical Service Department.

The report contains current information about a running 
sampling program, including last bottle number, pulses sent, and 
enable state.

Sonde - 2100 (2105) The Sonde tab of the Site window is used to view or change 
Sonde parameter settings. To access this tab, click “Jump to 
measurement tab >>” and then “Sonde.”

The 2105 Interface Module can display this tab. From this tab 
you may:

• View the Module name and all active sondes
• Scan for available sondes and add them to the Active 

Sondes list
• Select and configure active sondes
• Remove sondes from the Active Sondes list
• Save parameter settings for each active sonde

A Measurements tab will be available from the Jump to 
Measurement menu for every parameter you have configured the 
sonde(s) to measure. Parameters may include any of the 
following: Flow Rate, Level, Rainfall, Conductivity, Dissolved 
Oxygen, Temperature, pH, Percent, Velocity, Volume, Total 
Dissolved Solids, Salinity, Phosphate, Ammonia, Nitrate, TOC, 
COD, Total Suspended Solids, Sludge Index, Sludge Volume, 
SAC, Tubidity, Load, Input Voltage, Wireless Signal, Rainfall 
Intensity, Specific Conductance, Chloride, Chlorophyll, ORP, 
Ammonium.

Activating and 
Configuring 
Available Sondes

To add available (connected) sondes and make them active in 
Flowlink, from the Sonde tab click the Scan button. Detected 
sondes will appear in the bottom Available Sondes field, with a 
number assigned to each in the Address column (following 
configuration, this corresponding number will appear on the 
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Measurements tab next to each parameter measured by that 
sonde). Highlight the desired sonde(s) in the bottom field, and 
click Add. The added sondes will then appear in the top field.

To configure each sonde for operation, highlight the sonde from 
the Active Sondes field and click Configure. At this point, your 
Isco-Ready sonde is ready for operation, with its configured 
parameters available for viewing from the Measurements tab.

To configure both Isco-Ready sondes and Non-Isco-Ready 
sondes with Flowlink, click Manual Configuration to open the 
Sonde Data window.

Defining Sonde 
Parameters

Select the sonde to configure from the Sonde: dropdown list.

In the Define New Parameter box, select the Data Type from the 
dropdown list, name the parameter, and edit the Units of 
Measure if necessary. (Tip: To quickly locate the desired 
parameter in the Data Type list, click the arrow and type the 
first one or two letters.)

If the desired data type is not in the dropdown list, you may 
select “User Defined.”

Assign each parameter the appropriate number between 1 and 
20 in the field next to the Add button. This number corresponds 
to the index position of the desired parameter in the SDI-12 data 
string, obtained previously by connecting directly to the sonde 
using the manufacturer’s software, or from the sonde’s user 
manual. (For example, the manufacturer’s software may display 
the parameters in tabular format; the number assigned to the 
parameter may correspond to its column number in the table. 
Contact the sonde’s manufacturer for detailed instructions.)

Click Add; the new parameter appears in the window above. To 
make changes to defined parameters, select the parameter, enter 
the changes, and click Edit.

Saved Settings for 
Manually 
Configured Sondes

When you have defined the parameters for the selected sonde, 
you can save these settings by clicking Save in the Sonde 
Template File box. Name the *.snd file and save it to the desired 
location.

Your saved *.snd files can then be retrieved from your directory 
and applied to a selected sonde at a later date, provided the 
sonde’s factory measurement setup and configuration is 
compatible with your template.

To apply a saved template, click Manual Configuration to open 
the Sonde Data screen and click Open. Locate and select the 
desired template file. Click Apply to save the settings from this 
file to your selected sonde.

TIENet - 2100 (2160) To add an available (connected) 360 LaserFlow or 350 AV sensor 
and make it active in Flowlink, from the TIENet tab highlight 
the 2160 module (if there are multiple modules) and click 
Configure...
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In the Add/Remove window, click Scan to detect any newly added 
360 or 350 devices. The will appear in the Available TIENet 
Devices window.

Highlight the desired device(s) and click Add to make them 
active. Active TIENet devices will appear in the Active TIENet 
Devices window. Click OK.

Alarms - 2100 
(modem modules)

The Alarms tab of the Site window supports Isco 2103 and 2105 
modem modules that have the factory-installed dialout alarm 
capability. When a user-defined alarm condition is met, the 
contacts are notified in sequence. 

Note that while you are connected to the module through the 
modem, it cannot report alarms.

To set up a dialout alarm, you need to enter phone numbers, 
pager IDs, and communications parameters to use when an 
alarm condition is met, and then you need to define the alarm 
condition. To do this, complete the following steps:

1. Connect to the instrument.
2. Select the Alarms tab.
3. From the Alarm type drop down list, select TAP or SMS, 

depending on the instrument type, or SVR for Flowlink 
Pro users setting up the server alarm function.

4. SVR: From the Notification Group pull down list, select 
the number of the notification group that you specified on 
the Server Alarms tab of the Utilities>Server Options 
window.

5. SMS: type the contact telephone numbers in the Phone 
Number list box.

6. TAP: Type the contact telephone numbers in the Phone 
Number list box. This must be a valid Telocator 
Alphanumeric Protocol (TAP) access number. You should 
consult with your pager service for TAP access line 
numbers and the communications parameter settings.
TAP/SMS: You must enter at least one number; you can 
enter as many as five numbers; you can enter the same 
number more than once.
TAP/SMS: When an alarm condition is triggered, the 
system will try dialing each phone number in the Phone 
Number List. Each telephone number string can contain 
up to thirteen characters. (Dashes can be used if there is 
room to include them within the thirteen characters.) You 
can include a comma ( , ) which is preset as a two second 
delay, and is needed by PBXs to connect to an outside 
line. You may also include the following commands:

@ (wait for silence)
W (wait for dial tone)
T  (tone dial)
P  (pulse dial)
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7. TAP: For each phone number entered, enter a Pager ID 
number. This can be eleven characters long. (The ID will 
come from your pager service.)

8. TAP: For each phone number entered, you have the 
option of entering a Password. The password can be six 
characters in length. (Not all pager services require the 
use of a password.)

9. TAP: In the Comm field, select between 7E1 and 8N1 for 
the communications control specification. (Your pager 
service will give you this information.)

10. TAP/SMS/SVR: You must enter a text message to be 
sent to the pager. The Message field can hold 32 
characters, although there may be limits to the 
characters supported by different pagers.

11. TAP/SMS/SVR: Click the Set Alarm button and define 
the alarm condition or multiple conditions using the 
Equation Builder window. 

After entering the phone number information and defining 
condition, click Apply or press F9 to update the settings in the 
module.

Server Alarms The Server Alarms tab of the Server Options window is used to 
set up alarm notification if the Flowlink Server fails to receive 
pushed data from a site within a user-specified duration, or when 
a user-defined alarm condition is met. These server alarms are 
delivered as E-mail or SMS text messages.

Analog Outputs If you are using Isco’s 2108 Analog Output module, the Channel 
tabs on the Site window let you set up information for the analog 
output channels.

Output Channel Name - Enter a name for the output channel. 
The output channel percentage and the measurement output 
value calculated by Flowlink will display below the channel 
name.

Modify the Measurement Input for This Channel - Use the 
drop down list to select the input you want to measure (such as 
level or velocity). Indicate a minimum and maximum input range 
(minimum = 0% on analog output; maximum = 100%).

Modify the Data Recording for This Channel - Use the 
Update Interval field to set how often the output channel is 
updated.

Manual Control - The Manual Control button is used to 
temporarily override the channel’s output and is used when you 
are calibrating equipment. When you click the button, the 
Manual Control dialog box will appear. Set the output channel 
percentage by selecting one of the percentages displayed, or by 
selecting Custom and entering a percentage amount. Click the 
Set Output Channel Percentage button. The output will change 
to the manual setting; the dialog box will remain until you click 
Cancel. Then the output will revert to your previous settings.
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Power Control This tab of the Site window controls the On/off times for a 2102 
Wireless Communication Module or 2103/5 Cellular Modem 
Module.

Set Wireless 
Schedule

Rather than have the 2102 Wireless Module continually enabled, 
you can specify a time period for when the module is powered up.

Type - Select the type of schedule you want: Specific, Weekly, 
Daily, or Mon-Fri. When you enter a Specific time period, the 
wireless will be activated only during that specified period. 
Weekly, Daily, or Mon-Fri time periods will be ongoing.

Start/Stop - The Start and Stop display will vary, depending on 
what you selected for Type. For Specific, you will enter a Start 
and Stop date and time. For Weekly, enter the Start and Stop day 
of week and time. For Daily, enter the Start and Stop time. For 
Mon-Fri, enter the Start and Stop time.

When you have made your selections, click OK.

Modem Power The “Power Modem When” allows you to control the On/Off time 
of a 2103/5 Cellular Modem through the use of equations. When 
the conditions of an equation are true, the site will turn the 2103/
5 Cellular Modem on. When false, the modem is not powered to 
conserve battery power.

Click the Set Equation button to build an equation.

Pulse Doppler 
Support - 2105

The ADFM tab of the Site window is used to communicate with 
Pulse Doppler devices attached to a 2105 Interface Module.

NOTE: Pulse Doppler input and Modbus input cannot be used 
simultaneously in the same system.

The 2105 Interface Module can display this tab. From this tab 
you may:

• enable Pulse Doppler device communication and data 
retrieval.

• select the optimal baud rate for communication with the 
device(s).

• enable pushed data from the device(s).
For detailed information about setting up the Pulse Doppler 
device(s) and 2105-Pulse Doppler interfacing, see the user 
manuals for the 2105 module and the Pulse Doppler 
instrument(s).

Modbus Input - 2105 The Modbus tab of the Site window is used to configure data 
input to the 2105 module using Modbus ASCII or RTU protocol. 
The 2105 Interface Module can display this tab. You must set up 
and configure your monitoring/control system and Modbus 
device(s) before adding and configuring the 2105 module.

Note: Modbus and Pulse Doppler input cannot be used 
simultaneously in the same system.
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From the Modbus tab you may:

• Specify the device name and address
• Specify data and measured parameter(s)
• Add or remove devices

For complete information about configuring Modbus input, refer 
to the Modbus Input section of your 2105 user manual.

Modem Before setting up the site connection information, you must 
configure the module’s modem for operation on the Modem tab.

The digital cellular modem provides a choice of two different 
connection methods: Serial Over IP (IP) or Circuit-Switched Data 
(CSD). The default Contact Connection Mode is IP; this mode of 
communication is much faster, and does not require analog 
infrastructure.

For complete modem setup and text messaging details, refer to 
your cellular modem module’s instruction manual.

Connection Information for the site is set up on the Devices tab. 
Click the Disconnect button to activate the fields.

Equation Builder The Equation Builder window is used to create equations from 
various site conditions that can be used to generate alarms, log 
or push measurement data at secondary rates, and conserve 
power by turning on equipment only when needed. 

Multiple equations can be built for each module at the 2100 site. 
Conditions can also be combined using Boolean logic for even 
greater control.

Equations are built using conditions — a set of user-defined 
parameters that may be present at the site.

To build an equation:

1. Select the Module Name that the Equation will affect. 
2. Choose an equation from the drop-down Equation list. If 

none, click the Add button.
The Add button opens the Equation Name dialog. Use 
this to give your new equation a descriptive name. 

3. Select a Condition from the lower half of the Equation 
Builder window.
If no conditions are defined, click the Edit Condition 
button. This opens the Condition Builder window from 
which you can define a new condition or modify an 
existing one.
To select a condition, highlight it and click the Select 
Condition button. This starts an equation (Equation A) in 
the top half of the Equation Builder window. 

4. Select a Parameter Measurement Interval. As a 
minimum interval, Flowlink will test the equation 
condition(s) at the selected primary data storage rate. To 
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test the equation more frequently, choose the new 
interval from the drop-down list.
At this point you have created a simple equation.

5. Click the Save button to save the equation to the 
Equation List for the module.

6. Click the OK button to set the equation and apply the 
new settings to the site.

Repeat steps 1 through 6 to set additional equations for the same 
module, or to build equations for other modules at the site. If 
adding another equation to the Equation list for a module, note 
that only one equation can be selected and active at any time.

An equation can be built that tests many conditions. For 
example, you can combine a time table condition and a level 
measurement condition such as “stream levels three feet or 
greater between the hours of 7:00 am and 12:00 noon.” 

To build an equation that combines multiple conditions, follow 
steps 1 through 3 above. Next, define additional conditions. Then 
select the first condition, adding it to the Equation in the top half 
of the Equation Builder window. Click on a Boolean logic 
operator and select the second condition. To add even more 
conditions, insert logic operators and subsequent conditions.

Continuing with the example, you would define two conditions —
“(2150 Area Velocity : Level <2.999 ft)” and “(Time Table).” You 
would then select the level condition, click the AND operator, 
then select the time table condition. The AND logical operator 
ensures that the both conditions must be present, or TRUE, for 
the equation to be satisfied.

See also:

• Logical operators in equations on page 101
• Parentheses and order of execution on page 99

Condition Builder Use the Condition Builder window to define conditions for 
equations. 

To define a condition, choose the type of condition from the 
options in the top half of the window. Then, specify the 
parameters for that condition. Click OK to save the condition and 
return to the Equation Builder window. 

There several types of conditions:

• Threshold 
• Sensor Error 
• Rate of Change 
• Time Table 
• Range
• Rain Event

Note: To remove a previously defined condition, choose “None” as 
the condition type. 
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Threshold 
Condition

Threshold conditions are TRUE when a measured reading 
reaches or exceeds your defined set point. 

An example of a threshold condition would read “When 2150 
Area Velocity::Level is greater than or equal to 3.0 feet.”

To define the threshold condition:

1. Select a measured data type from the “When” drop-down 
list.

2. Select a comparison operator. 
• < (less than)
• > (greater than)
• <= (less than or equal to)
• >= (greater than or equal to)

3. Enter the threshold point. The units of measure were 
automatically assigned when the data type was chosen.

4. Enter a hysteresis and time duration.
Combined, the hysteresis and time duration prevent 
occurrences of the condition repeatedly toggling between 
TRUE and FALSE if the measured parameter hovers 
near the threshold. Likewise, the duration can prevent 
the condition from changing states due to a single 
anomalous measurement.
A hysteresis is a tolerance for variances in the measured 
data. For example, if a level condition is set for three feet 
or greater and the level measurements vary slightly 
between 2.99 and 3.01 ft, the state of the condition would 
change each time this narrow range of readings crosses 
the threshold point. Adding a hysteresis of 0.1 would 
mean that once the condition is true at 3.0 feet, the level 
must fall to 2.9 feet before the condition would be false. 
The duration setting requires all of the readings for the 
time duration to reach or exceed the threshold before the 
condition is met. 

5. Click OK. The threshold condition is defined and ready 
for use in an equation.

Sensor Error Sensor Error conditions are TRUE when a sensor error exists for 
a specified duration. 

An example of a Sensor Error condition would read “When 2150 
Area Velocity::Velocity is in error for 30 minutes.”

To define the Sensor Error condition:

1. Select a measured data type from the “When” drop-down 
list.

2. Select a duration from the “is in error for” drop-down list. 
3. Click OK. The Sensor Error condition is defined and 

ready for use in an equation.
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Rate of Change Rate of Change conditions are TRUE when a measured 
parameter changes by a specified degree over a duration of time. 

An example of a Rate of Change condition would read “When 
2150 Area Velocity::Velocity decreases more than 2 f/s in a 
15 minute period.”

To define the Rate of Change condition:

1. Select a measured data type from the “When” drop-down 
list.

2. Select increases or decreases from the drop-down list. 
3. Type a value in the “more than” box. The units of 

measure were automatically assigned when the data type 
was chosen.

4. Select a time period from the drop-down list. 
5. Enter a Hysteresis value.

The hysteresis prevents the condition state repeatedly 
toggling between TRUE and FALSE if the rate of change 
hovers near the set values.

Time Table 
Conditions

Time table conditions are TRUE when the instrument’s internal 
clock is within the defined duration of time.

An example of a Daily Time table condition would read “starting 
Daily at 08:00:00, stopping Daily at 17:00:00.”

To define the time table:

1. Select the type of time table. The options are:
• Specific – Start/stop dates and times for one-time 

use.
• Weekly – Start/stop days of week and times, 

recurring weekly.
• Daily – Start/stop times, recurring daily.
• Mon-Fri – Start/stop times, recurring each day of the 

workweek.
2. Complete the Start and Stop fields. The resulting 

duration will be displayed in the text box below the entry 
fields.

3. Click OK. The time table is defined and ready for use in 
an equation.

Range Range conditions are TRUE when a measured parameter value 
is inside or outside specified upper and lower limits. 

To define the Range condition:

1. Select a measured data type from the “Parameter name” 
drop-down list.

2. Enter the Upper and Lower limits. The units of measure 
were automatically assigned when the data type was 
chosen.
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3. Choose the Inside or Outside range option. 
4. Enter a hysteresis and duration.

Combined, the hysteresis and time duration prevent 
occurrences of the condition repeatedly toggling between 
TRUE and FALSE if the measured parameter hovers 
near a limit. Likewise, the duration can prevent the 
condition from changing states due to a single anomalous 
measurement.
A hysteresis is a tolerance for variances in the measured 
data. For example, if an upper limit is set for 3.0 feet and 
the level measurements vary slightly between 2.99 and 
3.01 ft, the state of the condition would change each time 
a reading crosses the limit. Adding a hysteresis of 0.1 
would mean that once the condition is true at 3.0 feet, the 
level must fall to 2.9 feet before the condition would be 
false.
The duration setting requires all of the readings for the 
time duration to be inside (or outside) the range before 
the condition is met.

Rain Event (2105) Rain Event conditions are TRUE when rainfall increases 
at a specified rate.
An example of a rain event condition would be to use 
measured rainfall to enable a sampler for a rain event. 
You may want to collect samples only if you received 0.25 
inches of rain in a one-hour time span, and only if rainfall 
has been less than 0.25 inches for a week.
That is, the sampler would stay disabled until a 
significant rainfall event occurred. This Rain Event 
condition would read “When 2105 Interface 
Module:Rainfall is greater than or equal to 0.25 inches 
in a 60 minute period following a ‘dry’ period of 1 Week.”
To define the Rain Event condition:

1. Select a 2105 Rainfall measurement from the pull down 
list.

2. Enter the threshold amount of rainfall and units of 
measure from the pull down list.

3. Enter a time duration in minutes to define the rate of 
increased rainfall.

4. Define the “dry” period (period when rate of rainfall is 
below the threshold).

NOTE: To specify a Rain Event for any time rainfall is at or 
above the threshold, enter a “dry” period of zero.

Report This window displays text reports downloaded from the 
instrument or a list of alarm events from an attached 2103 or 
2105 modem module. Refer to the instrument’s instruction 
manual for more information on reading the individual reports.

For instrument reports, this window has a 50,000 character limit 
and may cause very large reports or histories to appear 
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incomplete. To view complete text reports exceeding this limit, or 
to print the report, click the Save To File button. Then, open the 
file in a text editor such as Notepad, or your word processing 
application.

For alarm-event lists, there is a 20 line alarm-event limitation. 
After the 20 alarm-event limit is reached, the latest alarm event 
will be posted and the oldest alarm event will be removed from 
the list.

Network Resolution 
- 2100

The Network Resolution screen will appear when a 2100 module 
has been replaced or a 2100 module has been added to the 
network. You need to indicate what action should be taken to 
resolve the situation.

Connected Modules - The physical module(s) that were found 
at the site are listed on the left side of the screen. If you click the 
ID button to the left of a listed module, the module will be 
identified by illuminating its LED or performing an identifying 
action (such as a beep from the Field Wizard).

Database Site Definitions - The modules that Flowlink knows 
were previously at the site are listed on the right side of the 
screen. Where possible, these will be matched with the connected 
modules listed on the left side of the screen. 

If you click the ! button to the right of module, a window will be 
displayed that contains information about the connected module 
and selected module from the database. This information 
includes the Site Name, Module Name, Module Type, Module 
Address and Neuron ID. (The last two items are for diagnostic 
purposes.)

Action - Possible actions are listed in the center of the screen. 
Where a match has been made between a connected module and 
one in the database, the word MATCH will be displayed. Where 
an action needs to be taken, a drop down list will be displayed; 
use this list to select an appropriate action. 

To preview the results of an action, click the ? button to the right 
of a module listed in the Database Site Definitions column. After 
you have selected the actions you want to take, click OK at the 
bottom of the screen.

• <= Clone Module Like Database <= will configure the 
module to match the configuration of the selected module 
under Available Database Definitions. Use this when 
replacing a module at a site.

• => Write Module Config to Database => will update 
the Flowlink database with the physical module’s 
configuration. Use this when the module has been 
replaced and you are using a different database when 
you connect.

• Add New Module will configure and add the module to 
the existing site.
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Connect to This Site - Depending on how you initiated the 
connection, the Connect to This Site field will show one or more 
site names. The data from the selected site will be used in the 
Database Site Definitions section.

Create New Site - Select this check box to create a new site 
from the connected physical modules. Enter a site name in the 
New Site Name field.
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Site Window - 4100/4200/6700

The Site window contains information that identifies the site and 
all of the tabs necessary to set up the operation of the 
instrument.

The top of the Site Window continuously shows three fields:

• Site Name - displays the site name stored within the 
instrument. Enter or modify the site name from the front 
panel of the instrument, or from the Site Setup tab.

• Model - from the connected instrument. The model 
number is set at the factory and cannot be modified.

• Connection Status - displays the current status of the 
communications link to the instrument.

The tabs in the Site Window allow you to view and change many 
parameters that control the operation of the instrument. The 
number of active tabs will depend on the type of instrument and 
its data storage capabilities. Tabs that appear in the Site 
Window are:

• Site Info (page 78)
• Devices (page 78)
• Measurements (page 79)
• Device Setup (page 80)
• Data Storage (page 83)
• Flow Conversion (page 86)
• Sampler Control (page 92)
• Units (page 94)
• Alarms (page 94)

The buttons at the bottom of the Site Window are:

• Connect/Disconnect - Starts or stops communications 
with the instrument.

• Retrieve Data - transfers data from the instrument to 
the Flowlink database.

• DEFAULT Graph - graphs the data using the 
DEFAULT template.

• Apply - Saves the modifications to the Site Window and 
updates the program settings in the connected 
instrument.

• Cancel - clears any modifications made in the current 
tab and reverts to previous instrument settings.

• Help 
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Site Info - 4100/
4200/6700

The Site Info tab of the Site window window allows you to view 
and change the site’s name, location, date/time, GPS information, 
and other site-specific information.

Site Name - displays the site name stored within the 
instrument. To change the site name, type in the new name and 
click the Apply button. Site names can be up to 37 characters 
long. Any character may be used in the site name except the 
following: \ / : * & ? " < > |

Date/Time Box - displays the instrument’s and your computer’s 
time. These two times can be synchronized by pressing the 
“Synchronize Instrument’s Time To Computer’s” button. Use the 
Synchronize button with caution. Changing the time may affect 
the readings stored in the instrument’s memory partitions. 
Changing the time may cause readings to be overwritten, or 
“gaps” in readings may occur. It is recommended that you 
retrieve data from the instrument before synchronizing 
the time and date.

GPS Information Box - Enter the Altitude, Latitude, and 
Longitude of the site location for system mapping and other 
geographical locating purposes.

Devices - 4100-4200-
6700

This tab within the Site window displays general information 
about the instrument, input power, and Flowlink connection.

General 
Information Box

Displays “real-time” information while Flowlink is connected to 
the instrument. When Flowlink is not communicating with the 
instrument, this box displays the last available information 
about the site. This box typically displays:

• Sensor Type - reports the sensor recognized by the 
instrument.

• Flow Conversion - lists the flow conversion method.
• Software Revision - reports the level of software in the 

instrument.
• Instrument ID - reports the ID from the connected 

instrument. The ID is a unique nine-digit number 
assigned at the factory that cannot be modified.

• Instrument Time - displays the time and date from the 
connected instrument. This field is only active while 
Flowlink is connected to the instrument.

Power Box The Power box displays known information about the 
instrument’s power source. This information will aid you in 
determining when battery-powered instruments require service. 
This field is only active while Flowlink is connected to the 
instrument. Many Isco instruments will report the type of power, 
a voltage reading, and the percent remaining. Refer to the 
instrument’s instruction manual for further explanation of this 
feature.
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Connection Settings 
Box

Displays the settings used to communicate with the instrument. 
When off-line, this box will also allow you to make changes to the 
settings. From this box you can modify:

• Type - Direct, Modem, or Wireless. Select the Direct 
option when connecting to the instrument through an 
interrogator cable or short haul modem attached to your 
computer’s serial port. Select the Modem option to 
connect the instrument through a telephone modem. 
Select the Wireless option to connect to the instrument 
using a 2102 Wireless Communication module.

• COM port - (Direct and Wireless) Select the appropriate 
COM port setting from the pull-down menu. Refer to 
your computer’s documentation for more information on 
COM ports.

• Baud Rate - (Direct and Wireless) Select the baud rate 
from the pull-down menu. The 9600 baud rate setting 
will allow the fastest possible direct connections and data 
retrievals.

• Modem - (Modem connection types only) Select an 
installed modem from the pull-down list. Flowlink will 
only list those modems installed in Windows. Flowlink 
will use the selected Modem and its Windows settings 
(Com port, baud, etc.) to make the connection. If you need 
to change the modem settings, open the Modem Control 
Panel. (Windows Start>Settings>Control Panel.) A baud 
rate of 9600 is recommended for 4100/4200/6700 
instruments.
• Select Default from the list to use the modem 

specified in Utilities>Options for the appropriate 
device type. This automatically selects the modem 
used for a specific site, from any computer.

• Phone number - (Modems only) Enter the phone 
number assigned to the instrument. This number can 
include the following commands:

T (tone dial) 
, (comma - pause)
@ (wait for silence)
W (wait for dial tone)

TCP Address - (6712 w/ CDMA or GSM modem) Enter the 
correct static IP or public domain address.

To save changes to the communications settings, click Apply.

Measurements - 
4100/4200/6700

When connected, Flowlink continually polls the instrument for 
“real-time” readings. This tab of the Site window displays the 
real-time readings. The instrument’s configuration will 
determine which readings are available. A flow measurement 
instrument will display the current level in a number-entry box. 
Certain Isco instruments allow you to use this box to set 
(calibrate) the measured liquid level.
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Diagnostics Box Some Isco instruments report self-diagnostics on their front 
panel display and through Flowlink. Additionally, Isco 
instruments can report error messages such as “PAPER OUT” or 
“DISTRIBUTOR JAMMED.” These diagnostic and error 
messages are displayed in the Diagnostics Box.

Diagnostics are useful when troubleshooting faulty readings 
from an area velocity or ultrasonic flow measurement 
instrument. The displayed values can help determine if the 
sensor is installed and working correctly. Signal and spectrum 
strength values are reported as a percentage. Zero percent 
indicates that the sensor is either not connected, not operating, 
or not receiving a signal.

Signal Strength Area velocity instruments will display the approximate strength 
of sensor’s return signal. Percentages below 10 indicate a weak 
signal. Percentages near 100 indicate a strong signal. Normal 
percentages are from 10 to 90; typical readings in sewers range 
from 50 to 90%. Ultrasonic instruments will display the 
approximate strength of the ultrasonic return echo. Typical 
readings range from 30 to 100%.

Spectrum Strength Reports the amount of noise in the area velocity return signal. 
Percentages below 25 indicate a noisy return signal, percentages 
near 100 indicate a clear signal. The typical range in most 
installations is 40 to 100%. Ultrasonic instruments do not report 
the spectrum strength. 

• Percentages should never vary more than 25% from one 
reading to the next. Wide variations indicate an unstable 
installation. 

• Low percentages should not cause concern if the level 
and velocity readings are accurate and reliable. It is 
possible that low percentages are normal for your 
installation and the characteristics of the flow stream. 

The diagnostics are most beneficial when monitored long-term. A 
slow drop in percentages can indicate silt or debris building up 
near the sensor, while a sudden large change can indicate a 
failure at the site.

Device Setup - 4100/
4200/6700

The Device Setup tab of the Site window allows you to view and 
change instrument settings. The instrument settings on this tab 
are not active until you connect to the instrument.

The availability of the following items will depend on the type of 
instrument. Refer to the instrument’s instruction manual for 
more information on its functions and features.

Adjustments Box - displays adjustments to flow measurement 
instruments.

• Zero level offset is only applicable to area velocity 
instruments. Enter the measured Zero level offset.
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• Variable Blanking is only applicable to Ultrasonic 
instruments. Enter the variable blanking distance.

Minimum depth for velocity Box - displays Minimum depth 
for velocity. This setting is only applicable for area velocity 
instruments with a standard or extended range sensor.

Set flow rate to zero if no velocity data Check box - controls 
what an area velocity flow meter stores as flow rate readings 
when it is unable to measure velocity.

View last Box - Contains three buttons, Report, History, and 
Program. These buttons are active if a text file was downloaded 
during the last data retrieval. This communication option must 
first be enabled.

Password Box - Reports the current status of the instrument’s 
password protection and provides buttons to change and remove 
the password.

Totalizers Box - Contains two buttons to reset the totalizers to 
zero.

• Zero Total Flow button resets the cumulative flow 
reported in the Measurements tab of the Site Window.

• Zero Sampler Enable Total Flow button resets the 
sampler enable flow count to zero.

Press the Configure Like Another button to configure the 
current site so it has the same settings as another. (The site 
name will not be changed.) After pressing the button, you will be 
prompted to select a site from the Select A Site dialog box. Select 
the appropriate site and click OK.

Variable Blanking Ultrasonic instruments can vary the blanking to avoid erroneous 
level readings. Proper selection of a value will ensure that the 
flow meter accepts only valid echoes from the surface of the 
liquid, while disregarding invalid returns from the walls, sides of 
the channel, manhole rungs, or other obstructions.

Enter this value as the distance from the face of the ultrasonic 
level sensor to the maximum expected liquid level. Refer to the 
instrument’s instruction manual to calculate this distance. The 
flow meter will then ignore any echo reflected from this distance 
or less. Keep in mind that if the liquid level rises into the 
variable blanking distance, the flow meter will ignore the return 
from the liquid surface.

Minimum depth for 
velocity

For area velocity instruments with a standard or extended range 
sensor, this sets the minimum depth for measured velocity 
readings. Below this level, the flow meter approximates the 
velocity using earlier readings, and will not be able to detect the 
direction of flow. Refer to the instrument’s instruction manual to 
determine the correct setting.

Area velocity flow meters using a low-profile sensor do not 
require a minimum depth setting. Low profile sensors always use 
one inch (25 mm).
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Set flow rate to zero 
if no velocity data

Occasionally velocity readings are lost because either a flow 
stream does not contain enough reflective particles, or the sensor 
is covered with silt. These lost readings are logged as “No Data 
Code 248,” and the flow meter is unable to calculate the flow rate. 
This check box selects how flow rates are reported during this 
condition. 

Checked, the flow meter stores the flow rate as 0.0 under this 
condition.

Unchecked, the flow meter uses the current level reading and 
repeats the last valid velocity reading to calculate the flow rate.

Password If used, a numeric password is stored in the instrument’s 
memory and a copy is stored in the Flowlink site. While 
connecting to the instrument, the passwords are compared. A 
match will allow you to make changes to the instrument’s 
program settings.

If the passwords do not match, you will still be able to retrieve 
data from the instrument. However, program settings cannot be 
unlocked until the instrument is accessed by the correct site, or 
until the password is entered.

Passwords protect the program settings Flowlink sends to flow 
meters. The password prevents you or others from accidentally 
using the wrong site to connect with the flow meter, and it 
protects the settings from being changed by an unauthorized 
party.

The Change Password button on the Site Setup tab opens the 
Change Password window. From this window you can enable 
password protection and change an existing password.

To enable password protection:

1. Enter a numerical password in the “new password” field.
2. Confirm your password by retyping it in the verify field.
3. Press the OK button. Flowlink writes the password to the 

instrument and enables password protection.
To change an existing password:

1. Enter the existing password in the “old password” field.
2. Enter the new password in the “new password” field.
3. Confirm your new password by retyping it in the verify 

field.
4. Press the OK button. Flowlink writes the new password 

to the instrument. The instrument will remain enabled.
The Remove Password button on the Site Setup tab opens the 
Remove Password window. 

To remove password protection:

1. Enter the password in the “old password” field.
2. Press the OK button. Flowlink clears the password from 

the instrument and disables password protection.
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Note: If the password is lost or forgotten, contact Isco for 
assistance.

Sampler Enable 
Flow Count

Isco 4200 Series Flow Meters can report the cumulative flow 
while the sampler is enabled and since the Zero Sampler Enable 
Total Flow was last reset. The sampler enable flow count does 
not increment the volume while the sampler is disabled. 

Typically this value can represent the cumulative flow that was 
sampled by the sampler, as long as the count is reset (Zero 
Sampler Enable Total Flow button) each time the sample bottles 
are replaced.

Data Storage - 4100/
4200/6700

View and manage memory partitions in Isco instruments from 
the Data Storage tab of the Site window. 

Tip - If the instrument is not connected, this tab displays 
memory settings read from the instrument at the last 
time it was connected.

At the top of the tab, general information about the instrument’s 
memory is displayed.

• Total memory - displays the total memory in bytes that 
may be used to store readings.

• Free memory - displays the amount of available memory 
in both bytes and a percentage of the total memory. This 
line also indicates how many partitions are free.

Partition List Box - lists all of the partitions in the instrument. 
Highlighting an item on this list will reveal the Partition Setup 
Information in the fields to the right.

Partition Setup Information - displays the information about 
the partition highlighted in the partition list box. This includes:

• Partition Name - Up to eight characters to label the 
memory partition.

• Reading type - displays the type of readings stored such 
as Level, Flow Rate, Sample Event, etc.

• Reading Interval - the rate at which the readings are 
stored in the instrument’s memory.

• Time Span - displays the total time span of readings held 
in the instrument. The instrument will adjust this value 
to fill a block of memory.

• Number of samples - (Sample Event partitions only) 
displays the number of samples to store. The instrument 
will adjust this value to fill a block of memory.

• Recording Mode - Identifies how the instrument saves 
the readings.

• Time Partition Created - the creation date and time of 
the partition.

• Time of Last Reading - displays the last reading date and 
time stored in the instrument. 
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• Time of Last Data Retrieval- The date and time of the 
most recent retrieval.

• Time trigger enabled - the date and time the trigger 
equation became true.

• Trigger - This box displays the trigger equation when a 
triggered slate partition is used.

Partition Operation Buttons - change the instrument’s 
memory partitions. 

• Create a new partition - adds a partition to the end of the 
Partition List Box. 

• Delete last partition - Removes the last partition in the 
Partition List Box.

• Clear all partitions - clears all of the stored data held in 
all partitions. The partitions remain set up for use.

• Delete all partitions - deletes all of the partitions and 
stored data.

• Reset Slate - allows new readings to be saved in full 
slate-type partitions. For triggered slate partitions, this 
also resets the trigger. Retrieving data from the 
instrument before resetting a slate is recommended.

• Setup trigger - opens the Equation Builder to enter the 
parameters that activate a triggered slate partition.

The Calculated Flow button opens a window that allows flow 
rates to be calculated after retrieving the data. This can conserve 
memory and reduce the amount of data that must be transferred 
between the instrument and Flowlink. 

Notes:

• You cannot change a partition. Instead, you must delete 
the partition (and all partitions “below” it) and create a 
new one to replace it.

• Retrieve data from the instrument before deleting a 
partition. 

• Deleting a partition also clears the stored readings.

Memory Partitions 4100/4200/6700 store data in partitions. A partition is a section 
of memory that you set aside for a particular reading type. When 
setting aside a section of memory, you specify the reading type 
(e.g. Level or Flow Rate), the reading interval, and the recording 
mode. 

For more information see Instrument Partition Sizes.

Instrument 
Partition Sizes

The size of a data partition can be calculated if the time span, 
reading interval, and readings per block are known. The time 
span and reading interval information is displayed on the Data 
Storage Tab when the 4100/4200/6700 instrument is connected to 
Flowlink. 

The total memory in Isco instruments is divided into blocks of 
memory. The 4100 Series Flow Loggers have 235,520 bytes of 
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memory divided into 1840 blocks; 4200 Series Flow Meters have 
81,792 bytes of memory divided into 639 blocks. Each block 
contains 128 bytes. When a partition is created, it is divided into 
whole-block units. That is, a partition could use one or two 
blocks, but never 1.5 blocks.

The reading type will determine how many readings can be 
stored in a block of memory. Refer to the chart below. As you can 
see, some reading types require more bytes to store a single 
reading.

* Conductivity includes reading types reported as specific 
conductance, salinity, total dissolved solids, and conductivity.

Calculating the partition size - apply the Time Span in Days, 
Time Span in Hours, Reading Interval in minutes, and Readings/
block to the equation below.

Where:

D = Time Span Days
H = Time Span Hours
R = Reading Interval in minutes
B = Readings/block
P = Partition Size

The following example applies typical partition settings to the 
equation.

Example: A level partition stores readings at 5 minute intervals 
over a time span of 9 days, 1 hour. 

Therefore, this partition uses 5376 bytes.

Reading type Readings/Block

Rainfall 124

PH 124

Dissolved Oxygen 124

Level  62

Velocity  62

Temperature  62

Conductivity*  62

4-20 percent  62

Flow Rates  31



Isco Flowlink 5.1® Software
Site Window - 4100/4200/6700

86

Calculating the size of a Sample Event Partition - Multiply the 
number of samples by four to calculate the partition size in bytes. 

Note: A sample event partition does not use reading intervals 
and time spans. It simply stores sample events as they happen. 
When you set up a sample event partition, set the “number of 
samples” to the maximum number of expected samples. When 
the instrument creates the partition, the number of samples is 
rounded up to fill a complete block of memory. Each block of 
memory holds 32 sample events. 

Flow Conversion - 
4100/4200/6700

Use the Flow Conversion tab of the Site window to set up how an 
Isco instrument will convert level and velocity readings to flow 
rates.

To set the flow conversion method:

1. Choose a flow conversion method radio button.
2. Enter the maximum level.

The instrument uses the flow conversion method and the 
maximum level to build a conversion table. This 
maximum level should be somewhat above the highest 
expected liquid level in the channel at the measurement 
point. 

3. Define its attributes (type, size, etc.).
4. Click the Apply button.

You can also set the flow conversion method by recalling 
previously entered settings.

1. Press the Select Flow Conversion… button to open the 
Flow Conversion List.

2. Choose a flow conversion from the list and select OK. If 
the list does not show the desired flow conversion 
method, create a new one by clicking Add.

3. Enter the maximum level.
4. Apply the changes.

Flow Conversion 
Methods

Isco flow meters, flow loggers, and flow modules can use a 
number of methods to convert measured readings to a flow rate. 
The method you select will depend on the type of instrument and 
installation site. Refer to the instruction manual for your 
instrument for more details about the possible flow conversion 
methods and installation options.

Flowlink supports the following flow conversion methods:

• Weir 
• Flume 
• Flow Metering Inserts 
• Manning formula 
• Area Velocity 
• Equation 
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• Data Points 

Weir To set up a weir as the method of flow conversion:

1. Select the Type and Size or Crest length from the pull-
down lists. 

2. Apply the settings.
Maximum level is a required entry when flow rates or areas are 
calculated in the instrument and held as a table.

Refer to the Isco Open Channel Flow Measurement Handbook for 
more information.

Weir defined A weir is essentially a dam built across an open channel over 
which the liquid flows, usually through some type of an opening 
or notch. Weirs are normally classified by the shape. Each type of 
weir has an associated equation for determining the flow rate 
over the weir.

Flume To set up a flume as the method of flow conversion:

1. Select the Type from the pull-down list.
2. Select the Size from the pull-down list.
3. Apply the settings.

Maximum level is a required entry when flow rates or areas are 
calculated in the instrument and held as a table.

Refer to the Isco Open Channel Flow Measurement Handbook for 
more information.

Flume defined A flume is a specially shaped open channel flow section with an 
area and/or slope that is different from that of the channel. This 
results in an increased velocity and change in the level of the 
liquid flowing through the flume. A flume normally consists of a 
converging section, a throat section, and a diverging section. The 
flow rate through the flume is a function of the liquid level at 
some point or points in the flume.

Flow Metering 
Inserts

To set up a Flow Metering Insert:

1. Select the type from the pull-down list.
2. Select the size from the pull-down list.
3. Apply the settings.

Refer to the Isco Open Channel Flow Measurement Handbook for 
more information.

Manning Formula To set up a Manning formula as the method of flow conversion:

1. Select the Channel type from the pull-down list.
2. Enter the Slope, Roughness, and Channel dimensions.
3. Apply the settings.

Maximum level is a required entry when flow rates or areas are 
calculated in the instrument and held as a table.
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Refer to the Isco Open Channel Flow Measurement Handbook for 
more information.

Slope When used in a Manning formula, slope is entered as a 
dimensionless quantity, delta Y/ delta X, not as percent slope. Or, 
as otherwise expressed:

Roughness The roughness coefficient is an index of frictional resistance to 
the flow offered by the conduit. This coefficient is one of the 
required values when using a Manning formula for flow 
conversion. Selecting a value is essentially estimating the 
resistance to flow. The table below provides a list of roughness 
coefficients for various channel materials and conditions. Three 
values, minimum, normal, and maximum, are provided. Your 
selection will depend on the estimated resistance to flow.

Description of channel Min Norm Max

I. Closed conduit - partly full 

A. Metal

1. Steel

a. Lockbar and welded 0.010 0.012 0.014

b. Riveted and spiral 0.013 0.016 0.017

2. Cast Iron

a. Coated 0.010 0.013 0.014

b. Uncoated 0.011 0.014 0.016

3. Wrought Iron

a. Black 0.012 0.014 0.015

b. Galvanized 0.013 0.016 0.017

4. Corrugated

a. Subdrain 0.017 0.019 0.021

b. Storm Drain 0.021 0.024 0.030

B. NonMetal

1. Acrylic 0.008 0.009 0.010

2. Glass 0.009 0.010 0.013

3. Wood

a. Stave 0.010 0.012 0.014

b. Laminated, treated 0.015 0.017 0.020
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4. Clay

a. Common drainage tile 0.011 0.013 0.017

b. Vitrified sewer 0.011 0.014 0.017

c. Vitrified sewer with 
manholes, inlets, etc.

0.013 0.015 0.017

5. Brick

a. Glazed 0.011 0.013 0.015

b. Lined with cement 0.012 0.015 0.017

6. Concrete

a. Culvert, straight and free 
of debris

0.010 0.011 0.013

b. Culvert with bends, 
connections and some 
debris

0.011 0.013 0.014

c. Sewer with manholes, 
inlet, etc., straight

0.013 0.015 0.017

d. Unfinished, steel form 0.012 0.013 0.014

e. Unfinished, smooth wood 
form

0.012 0.014 0.016

f. Unfinished, rough wood 
form

0.015 0.017 0.020

7. Sanitary sewers coated with 
sewage slimes

0.012 0.013 0.016

8. Paved invert, sewer, smooth 
bottom

0.016 0.019 0.020

9. Rubble masonry, cemented 0.018 0.025 0.030

II. Lined or built-up channels 

A. Metal

1. Smooth steel surface

a. Painted 0.011 0.012 0.014

b. Unpainted 0.012 0.013 0.017

2. Corrugated 0.021 0.025 0.030

B. NonMetal

1. Cement

a. Neat surface 0.010 0.011 0.013

b. Mortar 0.011 0.013 0.015

2. Concrete
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Area Velocity Flow 
Conversion

To set up Area Velocity flow conversion:

1. Select a channel type from the pull-down list.
2. (2100 Series Modules Only) Select a Velocity Input. 

For multiple-module sites, this input allows Area Velocity 
flow conversion using level measurements from the 
current module and velocity measurements from any 
module at the site. For example, level measurements 
from a 2110 Ultrasonic module may be combined with 

a. Trowel finish 0.011 0.013 0.015

b. Float finish 0.013 0.015 0.016

c. Finished, with gravel on 
bottom

0.015 0.017 0.020

d. Unfinished 0.014 0.017 0.020

3. Wood

a. Planed, untreated 0.010 0.012 0.014

b. Planed, creosoted 0.011 0.012 0.015

c. Unplaned 0.011 0.013 0.015

d. Plank with battens 0.012 0.015 0.018

4. Brick

a. Glazed 0.011 0.013 0.015

b. In cement mortar 0.012 0.015 0.018

5. Masonry

a. Cemented rubble 0.017 0.025 0.030

b. Dry rubble 0.023 0.032 0.035

6. Asphalt

a. Smooth 0.013 0.013 --------

b. Rough 0.016 0.016 --------

7. Vegetal lining 0.030 -------- 0.500

III. Excavated or dredged 

A. Earth, straight and uniform 0.016 0.022 0.035

B. Earth, winding and sluggish 0.023 0.030 0.040

C. Rock cuts 0.030 0.040 0.050

D. Unmaintained channels 0.040 0.070 0.140

IV. Natural channels 

A. Fairly regular section 0.030 0.050 0.070

B. Irregular section with pools 0.040 0.070 0.100
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the velocity measurements from a 2150 Area Velocity 
module to calculate the flow rate. 

3. Enter the channel dimensions.
4. If the connected instrument supports silt level 

compensation, enter the Silt level. 
5. Apply the settings.

Maximum level is a required entry when flow rates or areas are 
calculated in the instrument and held as a table.

Refer to the Isco Open Channel Flow Measurement Handbook for 
more information.

Silt Level Area velocity flow conversions can compensate for a buildup of 
silt in the channel. The silt level value and the channel 
dimensions are used to calculate a cross-sectional area of the 
channel in which the flow is obstructed. This area is subtracted 
from the total channel cross section used to calculate the flow 
rate. 

To determine the value entered for the silt level, measure the 
depth of the silt in the bottom-center of the channel.

Equation Flow 
Conversion

To set up a User Equation as the flow conversion method:

1. Enter the flow equation coefficients and powers. As you 
enter the values, the displayed flow equation is updated.

2. Select a Head unit of measure.
3. Select a Flow unit of measure.
4. Apply the settings.

Maximum level is a required entry when flow rates or areas are 
calculated in the instrument and held as a table.

Refer to the Isco Open Channel Flow Measurement Handbook for 
more information.

Data Point Flow 
Conversion

A data point set is a table of correlating level-to-flow rate or 
level-to-area data points. The instrument can interpolate flow 
rates or areas for all levels using this data set.

To set up data point flow conversion:

1. Select an active data point set from the list.
2. If the selected set is unused, or if you wish to view/change 

the set, click the Edit… button.
3. Apply the settings.

Maximum level is a required entry when flow rates or areas are 
calculated in the instrument and held as a table.

Data Point Editing To edit a data point set:

1. Choose the Data point set type - Level to flow or Level to 
area.

2. Select the units of measure from the pull-down list(s).
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3. Enter at least four data points in the table. The table can 
hold a maximum of 50 data points. If you have copied 
data points from another table or spreadsheet, select the 
top-left cell and press Control-V on your keyboard to 
paste the data from the clipboard.
Each data point requires two values:
• Level to flow requires a flow stream level and the 

flow rate that corresponds to that measured level. 
• Level to area requires a flow stream level and the 

cross-sectional area of the channel at that level.
4. Select OK when the set is complete.

Note: The conversion accuracy between points increases with 
the number of points entered. Keep in mind that you are defining 
the entire channel shape mathematically; select points that best 
represent any curves or variations. Compound shapes will need 
many data points.

Maximum level Isco instruments that build an internal flow conversion table to 
convert readings to flow rates require a Maximum Level. For 
most standard primary devices, this is information available 
from the manufacturer. 

However, you should not arbitrarily enter a value such as the 
largest value from a primary device specification sheet. Instead, 
use a value that is somewhat above the highest expected level for 
your actual situation, even if that level is less than the published 
maximum for a given primary device. This will improve the 
resolution of the conversion table. For example, if the channel is 
six feet deep, but the stream level rarely exceeds four feet, 
resolution can be improved if the points within the table were 
scaled over four feet instead of six.

Caution: If the actual depth exceeds the entered maximum 
level, flow rates will not be calculated for those levels above the 
entered maximum level. The indicated flow rate will peak when 
depth reaches the maximum level and remain there until actual 
depth drops below the entered maximum head.

Sampler Control - 
4100/4200

This tab of the Site window displays the settings that flow 
measurement instruments use to control a connected sampler. 
These flow measurement instruments can control two sampler 
functions - sampler enable and sampler pacing.

Sampler Enable Set up the sampler enable by choosing one of the three options in 
the When to Enable box.

• Always - sets the sampler inhibit line to always enable 
the sampler.

• Never - sets the sampler inhibit line to always disable the 
sampler.

• On trigger - controls the sampler inhibit line with a user-
defined condition.
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The On trigger setting requires a trigger to be set up. 
Pressing the Change Enable button opens the Equation 
Builder to set up the trigger conditions. Once this has 
been entered, the trigger is displayed in the “Enable 
sampler when:” box. 

Latch sampler enable - If this box is unchecked, the inhibit 
line will continue to toggle between enabled and disabled as the 
conditions change. When this box is checked, the inhibit line will 
keep the sampler enabled once triggered, even if the condition no 
longer exists. This state will not change until the Reset Latch 
button is pressed.

Disable plotter when not sampling - When this box is 
checked, the instrument’s plotter will only run when the sampler 
is enabled.

Block access to front panel - When this box is checked, front 
panel sampler enable changes are not possible and the flow 
meter displays a message stating that the access has been 
blocked.

Sampler Pacing Control the sampler pacing by choosing one of the pacing options.

• No sampler pacing - The flow logger or flow meter will 
not send flow pulses.

• Flow paced - paces the sampler at a rate proportional to 
the flow rate by using volume intervals. Use the Change 
Pacing button to set the interval.

• Trigger paced - paces the sampler at a time interval that 
can change according to a triggered condition.

To set up trigger paced sampling:

1. Select the Trigger paced radio button. The Time paced 
interval box becomes active.

2. Enter the When trigger is true interval in minutes. This 
is the pacing interval while the trigger condition is met.

3. Enter the When trigger is false interval in minutes. This 
is the pacing interval while the trigger condition has not 
been met.

4. Set the trigger by pressing the Change Pacing button. 
Build the trigger in the Equation Builder.

5. Press the Apply button.

Flow Pulse Use this window to set the flow pulse interval. A flow pulse is a 
50 millisecond pulse used to pace a sampler. Enter a value within 
the minimum and maximum range listed.

It is important that this setting and the sampler’s pulses 
between sampling events setting work together to produce the 
desired volume interval. For example, if the flow meter sends a 
flow pulse every 100 gallons, and the sampler takes a sample 
every 10 flow pulses, the actual volume between samples is 1000 
gallons.
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Units - 4100/4200/
6700

From the Units tab of the Site window, you may select the units 
of measure for the data types reported by your Isco instrument.

Active data types have a pull-down list. Select one of the 
available units of measure, and click Apply to save the change.

Note: After readings are stored in the Flowlink database, they 
can be converted to other units of measure in a graph or table. 

Alarms - 4100/4200/
6700

The Alarms tab of the Site window supports Isco instruments 
that have the factory-installed telephone modem with voice 
messaging. When a user-defined alarm condition is met, 
Flowlink notifies the contacts in sequence until an 
acknowledgment is received. 

To setup a dialout alarm:

1. Connect to the instrument.
2. Select the Alarms tab.
3. In the Phone number list box, type the contact telephone 

numbers.
You must enter at least one number; you can enter as 
many as five numbers; you can enter the same number 
more than once. 
Each telephone number string can contain up to eighteen 
characters. You can use dashes or leave them out. You 
can include the pause (“,” or comma) Hayes AT command 
in the number. The pause is preset as a two second delay.
You can also use the following commands:

@ (wait for silence)
W (wait for dial tone)
T  (tone dial)
P  (pulse dial)

4. In the Site ID text box, type an easily remembered 
number that you can associate with the flow meter. The 
modem uses this number in its alarm message. 
When the ID box first appears, Flowlink automatically 
fills it with the last three digits of the Instrument ID 
number; you can use this number or enter another. (This 
number is used to acknowledge the alarm call using a 
touch-tone telephone. Press *(star) and the ID number 
and the instrument will respond with “Acknowledged.”)

5. Type the time between calls in the Delay Between Calls 
text box.
The delay can be as long as 127 minutes. Remember that 
the modem calls the next contact number only when the 
previous call is unacknowledged.

6. To use the call-back feature, check the Enable Call Back 
check box. Pagers are convenient to list in the contact 
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phone number list, but they usually cannot acknowledge 
the alarm in the manner above. When the call back 
feature is enabled, the instrument will accept any 
incoming call as an acknowledgment. 

7. To define the alarm condition, press the Set Alarm 
button.
When you’ve completed the trigger equation, it appears 
in the Trigger alarm when box.

8. Click Apply to save the changes.

Site Matching As Flowlink connects to a 4100/4200/6700 site, it compares the 
instrument’s Site Name, Model number, and the Instrument ID 
with the information stored in the database. If any of these three 
items do not match, Flowlink displays the Site Does Not Match 
window.

If you wish to continue with the connection, Flowlink needs 
instructions on how to handle the discrepancy. Choose one of the 
following options and click OK.

• Cancel this operation (either select another site before 
connecting or use Quick Connect). This cancels the 
connection and neither the database nor the instrument 
information will be changed. Using the recommended 
Quick Connect will automatically connect to the 
instrument and select the correct database site for you. If 
the database does not have a matching site, the Quick 
Connect method will create a new site in the workspace.

• Create a new site in the database for this 
instrument. The instrument will appear as a new site in 
the Flowlink workspace.

• Write the database’s configuration into the 
instrument, overwriting what’s currently in the 
instrument. Flowlink writes the database’s site name 
and partition in the instrument. Use this option with 
caution - readings currently stored in the instrument are 
erased as the new partitions are set up in the 
instrument.

• Write the instrument’s configuration information 
into the database, overwriting what’s in the 
database.
If you select either of the last two options above, check 
the following before continuing:
• Verify that you have initiated the connection from 

the correct site.
• Verify that Flowlink is connected to the desired 

instrument.
• Configure this instrument like another, similar 

instrument. When you select this option, it will enable 
the Select Instrument button. Click that button and 
select a similar type of instrument to apply settings from.
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How does Flowlink 
match an 
instrument to a site 
in the database?

During the connect process, the Flowlink retrieves the site name, 
model number, and instrument ID. The site name can be changed 
from Flowlink or from the instrument’s front panel. Flowlink 
does not allow duplicate site names. The model number and 
instrument ID are permanently set at the factory. Flowlink 
compares the instrument’s site name, model number, and 
instrument ID with the database for the site you selected.

• If all three match, Flowlink has then verified that it is 
using the correct database site for the connected 
instrument. Flowlink updates the database with the 
instrument information and you may continue with data 
retrieval, program changes, etc.

• If the site name and model number match but the 
instrument IDs do not, you will be notified of the 
mismatch and given five options. Select the most 
appropriate response for your situation.

• If the site name matches but the model number does not, 
Flowlink will be unable to connect to the site. If you in 
fact have changed the model used at a site, create a new 
site by using the Quick Connect, and then merge the 
original site data with the new.

• If the site name does not match but the model number 
does, you will be given five options to choose from. Select 
the most appropriate response for your situation.

When a mismatch occurs during a scheduled task, Flowlink does 
not cancel the operation. Flowlink creates a unique site name, 
adds it to the workspace, and continues with the scheduled task. 
View the log (Utilities>View Log File) to determine which 
connection was attempted and which site was created to 
complete the task. Use the Merge feature to add the data to the 
correct site.

Equation Builder Use the Equation Builder to create a “trigger condition.” A 
trigger modifies the flow meter’s operation when measured 
readings satisfy an equation. Triggers can be used to:

• Enable or Disable a sampler
• Activate a triggered slate partition
• Change the sampling pulse rate for trigger paced 

sampling
• Start calling the dialout alarm contact telephone 

numbers
When a reading is taken, the instrument compares it to a set 
point specified by the condition. If all of the conditions are met in 
the equation, the equation is said to be “TRUE,” or satisfied. 
True equations trigger the programmed action.

To set up a trigger:

1. Define at least one condition, or as many as four.
2. Build the logic equation.
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3. Click OK to accept the equation and close the Equation 
Builder window.

Equation View This box within the Equation Builder window displays the 
trigger equation. To trigger a function in the instrument, an 
equation must be entered in this box.

Build the equation using the defined conditions and the 
operators AND, OR, and NOT. Triggers must use at least one 
condition, or as many as four conditions. Each condition may be 
used more than once. You may also use the parentheses to group 
conditions, and add a duration.

Building a simple 
equation:

1. Define a single condition. These are listed as A through 
D. For example, highlight Condition A and set it up as a 
threshold condition when level is greater than or equal to 
three feet. Click Accept to use this as Condition A.

2. Display the Equation view box by selecting the 
“Equation” line at the top of the Equation Builder 
window.

3. Select the condition by clicking on condition button A, B, 
C, or D. For the example, this would be button A. 
Flowlink adds the condition to the Equation view box. 
You may also press the A button on the keyboard.

4. Click OK in the Equation Builder window. The window 
closes and the equation is then displayed in the Trigger 
box.

5. Click Apply to send the equation to the connected 
instrument.

Building a 
compound 
equation:

1. To build a compound equation, define additional 
conditions and add them with the condition buttons. 
Between each condition, or group of conditions when 
using parentheses, you must insert an operator. A single 
duration can be added at any level of the equation.

2. The equation can be edited by placing the text cursor in 
the Equation view box. To insert an item in the equation, 
place the cursor where it belongs and use the buttons to 
add the item. To delete an item, first select it by double-
clicking it or by placing the text cursor directly before it. 
Then, click the Delete button.

See Also:

• Logical Operators in Equations, page 101 
• Duration Modifier, page 101 
• Parentheses and Order of Execution, page 99 
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Defining a 
Condition

To define a condition:

1. From the equation view box at the top of the Equation 
Builder window, select a condition (A, B, C, or D) to 
define. The lower portion of the window will list the 
conditions that can be selected to build the equation.

2. Select one of the four Condition types, Threshold, Rate of 
Change, Time Table, or Rain Event, and complete the 
remaining entries at the bottom of the window. Note: The 
“None” option defines the condition as “not used.”

3. Click Accept. The condition is defined and ready for use 
in an equation.

Threshold Condition Threshold conditions are satisfied when a measured reading 
reaches or exceeds your defined set point. Threshold conditions 
require three entries - a data type, a comparison operator, and a 
set point. An example of a threshold condition would read “When 
Level is greater than or equal to 3.0 feet.”

To define the threshold:

1. Select a data type from the pull-down list. 
2. Select either the <= (less than or equal to) or the >= 

(greater than or equal to) comparison operator.
3. Enter the set point. The units of measure were 

automatically assigned when the data type was chosen.
4. Click Accept. The threshold is defined and ready for use 

in an equation.

Rate of Change 
Conditions

Rate-of-change conditions are satisfied when a range of readings 
exceeds a point within a specified duration. A rate of change 
allows you to trigger functions based on significant or sudden 
events while ignoring subtle changes in reading values.

Rate of Change conditions require three entries - a data type, an 
amount of change, and duration.

A good example of a rate of change condition would be to use 
measured rainfall to enable a sampler for a rain event. You may 
want to collect samples only if you received 0.25 inches of rain in 
a one-hour time span. That is, the sampler would stay disabled 
until a significant rainfall event occurred. This type of condition 
would read “When Rainfall changes by 0.25 inches or more for 1 
hour.”

To define the rate of change:

1. Select a data type from the pull-down list.
2. Enter the amount of change. The units of measure were 

automatically assigned when the data type was chosen.
3. Select a period of time from the pull-down list.
4. Click Accept. The rate is defined and ready for use in an 

equation.
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Time Table 
Conditions

Time table conditions are satisfied when the instrument’s 
internal clock is within the defined duration of time. An example 
of a Daily Time table condition would read “starting Daily at 
08:00:00, stopping Daily at 17:00:00.”

As many as four times can be entered, using any combination of 
time table types. For example, to enable a function every Monday, 
Wednesday, and Friday, three weekly start/stop times would be 
defined in the time table. The three lines would possibly read 
“Starting Monday at 08:00:00, Stopping at Monday 17:00:00; 
Starting Wednesday at 08:00:00, Stopping Wednesday at 
17:00:00; and Starting Friday at 08:00:00, Stopping Friday at 
17:00:00.”

To define the time table

1. Select the type of time table. The options are:
• Specific – Start/stop dates and times for one-time 

use.
• Weekly – Start/stop days of week and times, 

recurring weekly.
• Daily – Start/stop times, recurring daily.
• Mon-Fri – Start/stop times, recurring each day of the 

workweek.
2. Complete the Start and Stop fields. The resulting 

duration will be displayed in the text box below the entry 
fields.

3. To define additional start/stop times, click Add and 
repeat the steps above.
Note: Start/stop times can be deleted by highlighting the 
line in the text box and clicking Remove.

4. Click Accept. The time table is defined and ready for use 
in an equation.

Parentheses and 
Order of Execution

Flowlink provides parentheses so that you can group conditions 
or even combine groups with logical operators. Parentheses also 
let you control the order in which the flow meter evaluates the 
conditions in an equation. The instrument will use an algebraic 
order of execution when evaluating a trigger equation. The order 
of execution is the order in which the instrument tests conditions 
and can be summarized as: “from left to right, and from inside, 
out.” “From left to right” means that the flow meter tests 
conditions in the same order that you read them in an equation: 
from left to right. 

When evaluating an equation containing two conditions, the 
instrument first checks the condition on the left, then the 
condition on the right, and finally evaluates the conditions with 
regard to the logical operators used to combine them. If the 
equation is true, the instrument triggers the designated action. 

Equations using three or more conditions are also evaluated from 
left to right. Consider the two equations that follow. Both 
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equations comprise three conditions, designated here as A, B, 
and C for simplicity.

A AND B AND C. This equation is true when all three 
conditions are satisfied. When evaluating the equations, the 
instrument tests A first. If A is true, the instrument then checks 
B to see if it is true. Next, the instrument checks the operator 
AND that relates A and B to each other. If both A and B are true, 
the result of A AND B is true. Finally, if the result of A AND B is 
true, the instrument tests C and compares it to the result of A 
AND B. If C is also true, the equation is satisfied. 

A AND B OR C. This equation is true when either the result of 
A AND B is true or when C is true. 

Order of Execution “From inside out” means that the instrument tests the conditions 
grouped within parentheses first to get a result before testing 
conditions outside of the parentheses.

The equation A AND B OR C is logically equivalent to the 
following equation, (A AND B) OR C which uses parentheses to 
group A and B together. They are equivalent because the 
instrument evaluates the first two conditions, A AND B, before 
the third condition even though the first two conditions are not 
grouped with parentheses. 

However, when the parentheses are moved so that the equation 
becomes A AND (B OR C), the equation’s result could be entirely 
different. The instrument evaluates the conditions within the 
parentheses first (B OR C), comparing the result with the first 
condition, A. Thus, this equation is true when both A and the 
result of B OR C is true. 

Equations with nested parentheses (nested means parentheses 
within parentheses) are a little more complicated, but the “from 
inside out” rule still applies. Consider the examples below: 

• (A AND (B OR C)) AND D. The instrument evaluates 
(B OR C) first, then compares the result to A, to get a 
second result. Finally, it compares the second result to D. 

• A AND ((B OR C) AND D). The instrument evaluates B 
OR C first, then compares the result to D, obtaining a 
second result. Next, it compares the second result to A. 

To add parentheses to an equation:

1. While viewing the Equation view box, place the text 
cursor before the first item in the group.

2. Click on the Open Parenthesis button - “(.”
3. Move the text cursor after the last item in the group.
4. Click on the Close Parenthesis button - “).”
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Duration Modifier Normally, a condition is satisfied as soon as a reading passes the 
set point. By adding a duration modifier to the condition, or a 
group of conditions enclosed by parentheses, the condition must 
then be satisfied for a minimum period of time. Adding this 
modifier can be useful if you want to disregard temporary peaks 
in the measured readings.

For example, adding a 15 minute duration applied to a threshold 
condition using level readings taken at one-minute intervals, the 
trigger equation would only be true after 15 consecutive readings 
have exceeded the threshold. If the level drops below the 
threshold before the fifteenth reading, the condition remains 
false and the count must start over again.

Keep in mind that the duration modifier must follow the 
condition (or group) it is modifying. Only one duration modifier 
may be used in an equation.

To add a Duration Modifier:

1. Place the text cursor after the condition to be modified. If 
you are modifying a group of conditions, first ensure they 
are enclosed with parentheses.

2. Select a time period from the Duration pull-down list.
3. Click the Duration button. Flowlink adds the modifier to 

the equation.

Logical Operators in 
Equations

You can combine conditions in a compound equation so an 
instrument can monitor two or more conditions at once. To 
combine conditions, Flowlink provides two logical operators - 
AND and OR.

• The AND operator combines two or more conditions that 
both must be true at the same time to satisfy the 
equation. For example, an equation that uses level 
greater than one foot AND rainfall of at least 0.25 inches 
in one hour would require both conditions to be met 
before triggering any action.

• The OR operator combines two or more conditions, where 
either one or both must be true to satisfy the condition.

Flowlink includes a third logical operator, NOT, that is used to 
exclude a condition. To exclude a condition, place the NOT 
operator before the condition.

When using a NOT operator with more than one condition, 
remember that this operator doesn’t combine conditions. To 
combine conditions that include a NOT operator, you must also 
use the AND or OR operator. Refer to the examples below:

• Correct — Level > 2.0 ft AND NOT Velocity < 0.5 fps.
• Correct — NOT Velocity < 0.5 fps AND Level > 2.0 ft.
• Incorrect — Level > 2.0 ft NOT Velocity < 0.5 fps. (The 

combining operator is missing.)
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Note: Flowlink sometimes abbreviates logical operators in 
equation displays:

AND = &
OR = |
NOT = ! or ^
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Site Window - Pulse Doppler

The Site window contains information that identifies the site and 
all of the tabs necessary to set up the operation of the Pulse 
Doppler series flow meters, including the ADFM, HotTap, 
accQmin/accQpro, and H-ADFM flow meters.

The top of the Site Window continuously shows three items:

• Site Name - displays the site name stored within the 
instrument. Enter or modify the site name from the Site 
Info tab.

• Model - Identifies the device type connected.
• Instrument Connection Status - displays the current 

status of the communications link to the instrument.
The tabs in the Site Window allow you to view and change many 
settings that control the operation of the instrument. Tabs that 
appear in the Site Window are:

• Site Info (page 104)
• Devices (page 104)
• Measurements (page 105)
• Flow Rate (page 106)
• Data (page 106)

The buttons at the bottom of the Site Window are:

• Connect/Disconnect - Starts or stops communications 
with the instrument.

• Retrieve Data - transfers data from the instrument to 
the Flowlink database.

• DEFAULT Graph - graphs the data using the 
DEFAULT template.

• Apply - Saves the modifications to the Site Window and 
updates the program settings in the connected 
instrument.

• Cancel - clears any modifications that you have made in 
the current tab and reverts to previous instrument 
settings.

• Help
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Site Info - Pulse 
Doppler

The Site Info tab of the Pulse Doppler Site window allows you to 
view and change the site’s name, and date/time.

Site Name - displays the site name stored within the 
instrument. To change the site name, type in the new name and 
click the Apply button. Site names must be alphanumeric 
characters only, and can be up to 37 characters long.

Date/Time Box - displays the instrument’s and your computer’s 
time. These two times can be synchronized by pressing the 
“Synchronize Instrument’s Time To Computer’s” button. Use the 
Synchronize button with caution. Changing the time may affect 
the readings stored in the instrument’s memory partitions. 
Changing the time may cause readings to be overwritten, or 
“gaps” in readings may occur. It is recommended that you 
retrieve data from the instrument before synchronizing 
the time and date.

GPS Information Box - Enter the Altitude, Latitude, and 
Longitude of the site location for system mapping and other 
geographical locating purposes.

Devices - Pulse 
Doppler

The Devices tab of the Site window displays general information 
about the instrument, secondary depth sensor and battery (if 
applicable), and connection information.

• Site ID - Identifies the instrument at the site.
• Firmware Version - Level of firmware installed.
• System Voltage - Power status of the system.

To give the device a different name, click the Site Info tab, 
highlight the name in the Site Name field, and type in the new 
name. Site names can be up to 37 characters long. Any character 
may be used except the following: \ / : * & ? " < > |

All of the information is read directly from the flow meter. The 
Model Name and Firmware Version cannot be modified - they are 
set at the factory.

Secondary Depth Sensor Box - If you are using a secondary 
depth sensor, specify its type, span, and zero level offset (if 
needed).

Connection Information Box - Displays the settings used to 
communicate with the instrument. When off-line you can modify:

• Type - Direct or Modem. Select the Direct option when 
connecting to the instrument with a communication 
cable attached to your computer’s serial port. Select the 
Modem option to connect to the instrument through a 
telephone modem.

• COM port - (Direct) Select the appropriate COM port 
setting from the pull-down menu. Refer to your 
computer’s documentation for more information on COM 
ports.

• Baud Rate - (Direct) Select the baud rate of 38400 from 
the pull-down menu.
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• Modem - Select an installed modem from the pull-down 
list. Flowlink will only list those modems installed in 
Windows. Flowlink will use the selected Modem and its 
Windows settings (COM port, baud, etc.) to make the 
connection. If you need to change the modem settings, 
open the Modem Control Panel (Windows 
Start>Settings>Control Panel). A baud rate of 38400 is 
recommended for ADFM instruments.
• Select Default from the list to use the modem 

specified in Utilities>Options for the appropriate 
device type. This automatically selects the modem 
used for a specific site, from any computer.

• Phone number - (Modem) Enter the phone number 
assigned to the instrument. This number can include the 
following commands:

T (tone dial) 
, (comma - pause)
@ (wait for silence)
W (wait for dial tone)

• Pass-Through - (Interface Device or Service) From the 
pull down list, select the entity you are using to connect 
with the flow system.

Battery Type and Projected Life - Select None if using an 
external power source, or Internal if using batteries.

To save changes to the communications settings, click Apply.

Measurements - 
Pulse Doppler

When connected, Flowlink continually polls the site for “real-
time” readings. This tab of the Site window displays the real-
time readings, as well as test data, in the Output window.

Program and Restart - writes your selected program settings 
to the instrument and starts the program.

Erase Recorder - deletes all saved data from the internal 
recorder.

Bench Test - The Bench Test function is for diagnostic purposes 
and is not required for routine operation. If for any reason the 
Bench Test is performed, regardless of the time interval between 
tests, first retrieve and save all recorded data before it is 
performed again. Prior to redeployment, select "Erase Recorder" 
and then "Restart."

Field Test - This system performance evaluation is for use at the 
monitoring site with the sensor installed and in the stream.

Quick Data - refreshes the Output window with the current 
data readings, and creates a graphical display to verify beam 
configuration, ensuring proper performance of the flow meter.

Restart - restarts the instrument using the programmed 
parameters currently stored in its memory.
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Sleep - puts the instrument to sleep; it will not wake up or take a 
reading at the specified sample time. It will only begin operation 
again when awakened with the Connect button.

Adjust Level - lets you edit the current measured value for 
Level 1 (primary) and/or Level 2 (secondary sensor, if attached). 
Offset values are automatically adjusted.

Advanced Commands - used to override one or more 
programmed parameters. Contact Teledyne Isco before using.

Flow Rate - Pulse 
Doppler

Use the Flow Rate tab to specify the appropriate channel 
geometry and dimensions. The instrument and its functions 
determine which settings are available.

From this tab you may:

• Select the channel type
• Enter channel dimensions
• Enter sensor mounting information

If you have made any changes, click Apply to update the settings 
in the instrument.

Data - Pulse Doppler The flow meter’s recorder must be cleared following data 
retrieval. Save all downloaded data and, prior to redeployment, 
erase the recorder and restart the ADFM.

View and manage data storage for Pulse Doppler series 
instruments from the Data tab of the Site window:

Data Storage or Sample Interval - shows the data storage 
interval, selectable in minutes, the number of individual 
measurements (samples) per reading, and the estimated velocity 
precision as a percentage of maximum expected velocity.

Secondary Rate (accQmin/accQpro only) - allows you to 
increase the measurement interval during higher flow 
conditions. To program this secondary interval, select the Enable 
Burst Sampling check box.

Data Format (all except H-ADFM) - For more manageable file 
size, Reduced format is recommended.
Standard format is selected for recording additional raw data 
such as Velocity, Amplitude, Percent Good, and Correlation, with 
a selectable interval (Full Data Interval).
All data may be stored on the instrument’s internal recorder in 
slate or wrap mode, as well as output via serial port.

Velocity Model (H-ADFM only) - The Velocity Model type is 
referred to as the Linear Regression model. This model 
calculates the average velocity V at time t. A, B, and C are site-
specific regression coefficients. These will have been determined 
by the installer using independent calibration data when the
H-ADFM was installed and configured. Vi is the index velocity, 
computed as an average of the velocity bins specified in the index 
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range. (See your H-ADFM user manual for more information 
about configuring the instrument.)

Forced Depth (H-ADFM only) - Enter a Forced Depth value 
for installations requiring a constant depth of flow for area and 
flow calculations.

Profiling (H-ADFM only) - Select the proper frequency (300, 
600, or 1200 KHz) for your application, the desired update 
interval (Sample), and desired balance between precision and 
resolution (Profiling Mode).

Click Apply (F9) to write the new settings to the instrument.
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Signature Flow Meter

The Signature site window contains information that identifies 
the Signature site and instrument, and enables remote 
communication through the Signature flow meter’s own web 
browser interface

In this window are three tabs:

• Site Info
• Devices
• Program

At the bottom of all three tabs is a Connect/Disconnect button, 
which toggles between the two states. The site window browser is 
only available while Flowlink is connected to the flow meter.

The flow meter is configured using its own firmware, rather than 
with Flowlink. For setup and programming instructions, refer to 
the flow meter’s instruction manual.

Flowlink can be used, however, to download and save Signature 
site data.

Site Info - Signature The Site Info tab of the Signature site window allows you to view 
and change the site’s location, date/time, GPS information, and 
other site-specific information.

The Site Name: field is populated by whatever site name has 
been programmed into the flow meter itself through either the 
front panel keypad or through the flow meter’s browser window.

Devices - Signature The Devices tab of the Signature site window displays 
information about the individual flow meter, including its model, 
serial number, software revision, and other information.

Program - Signature The Program tab provides remote access to the flow meter 
through the flow meter’s browser, which emulates the actual 
4300 display and controls. This is where actual setup and 
programming can be done remotely.

Softkeys
The three buttons that appear across the bottom of the screen 
are softkeys that will change in function and appearance, 
depending on what screen you are on, and what you have entered 
previously.
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Viewing Signature 
Data

To retrieve data from the flow meter and save it to the database, 
click the Interrogate button at the bottom of the Program 
window. The browser will display all available data that can be 
retrieved. Check the box(es) next to the desired data and click 
Next.

When the download is ready, the browser will display the 
message “The data has been successfully dumped.” Click the 
Download Data button. When the data has been downloaded, a 
message will say, “Download complete.”

Event Viewer - 
Signature

Unique to the Signature Series flow meter are four event data 
types that can be recorded to ensure that data integrity is not 
compromised. This event data cannot be altered.

The four event data types are:

• Program Report
-Tracks configuration changes to the flow meter

• Summary Report A, B
-Tracks measurement summaries (e.g. Min/Max/Avg)

• Diagnostic Report
Tracks the occurrence of and results from last 23 
diagnostic tests

• History Report
Tracks last 55 user events

When double-clicked or dragged from the site tree, these four 
events open by default in tabular format, in the Event Viewer.

To view a specific range of data, use the drop down menus in the 
Range box to select the appropriate calendar days, and check the 
box next to “Lock to current date.”

In the Event Viewer, each data type will appear in a single table 
row. To view complete information about an event, double-click 
on it, and the report will appear in a small window.

Events will be displayed chronologically by descending Event 
Time. To reverse the display order, click on the Event Time 
column header. To sort the list alphabetically, click the Event 
Summary column header.

Data Integrity
Flowlink’s integrity check program will verify that the data is 
original and unaltered. If the data is authentic, a green check 
mark will appear in the title bar of the Event Viewer. If the data 
cannot be verified as original or unaltered, a red circle and slash 
will appear instead.

Exporting Data
Event data can be exported, along with their respective 
authentication markers, in the form of a text (.txt) report, to a 
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destination of your choice. Simply select a report and click the 
Export button, or right-click a report and select Export.

Graphing
The four event types can also be viewed in graphical format by 
clicking the graph icon in the tool bar, or right-clicking the item 
in the site tree and selecting Quick Graph. The event data will 
appear in the standard graph window, like any other data type, 
and can be viewed alongside other data types.

Enter a percentage of the Y-axis height to specify the position of 
the Event symbols in the pane.
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Site Window - Field Wizard

The Site Window contains information that identifies the site 
and all of the tabs necessary to set up the operation of the Field 
Wizard module.

The top of the Site Window continuously shows two items:

• Site Name - displays the site name stored within the 
instrument. Enter or modify the site name from the Site 
Info tab.

• Connection Status - displays the current status of the 
communications link to the instrument.

The tabs in the Site Window allow you to view information about 
the site and the modules that have been interrogated. There are 
two tabs that appear in the Field Wizard Site Window:

• Site Info 
• Interrogated Sites 

The buttons at the bottom of the Site Window are:

• Connect/Disconnect - Starts or stop communication 
with the instrument.

• Retrieve Data - Transfers data from the instrument to 
the Flowlink database.

• Apply - Saves the modifications to the Site Window and 
updates the program settings in the connected 
instrument.

• Cancel - Clears any modifications that you have made in 
the current tab and reverts to the previous instrument 
settings.

• Help - Displays the Help topic for the Site Window.

Site Info - Field 
Wizard

The Site Info tab of the Field Wizard Site Window lets you view 
and change the site name, module name, date/time, and 
connection information.

Site Name - displays the site name stored within the 
instrument. To change the site name, type in the new name and 
click the Apply button. Site names can be up to 37 characters 
long. Any character may be used in the site name except the 
following: \ / : * & ? " < > |

Module Name - displays the name for the Field Wizard module. 
To change the module name, type in the new name and click the 
Apply button. Module names can be up to 37 characters long. 
Any character may be used in the module name except the 
following: \ / : * & ? " < > |
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Date/Time Box - displays the instrument’s and your computer’s 
time. These two times can be synchronized by pressing the 
“Synchronize Instrument’s Time To Computer’s” button. Use the 
Synchronize button with caution. Changing the time may affect 
the readings stored in the instrument’s memory partitions. 
Changing the time may cause readings to be overwritten, or 
“gaps” in readings may occur. It is recommended that you 
retrieve data from the instrument before synchronizing the time 
and date.

If the Field Wizard is not in standalone mode, and is connected to 
Flowlink while part of a 2100 Series stack, the Instrument’s 
Time field will not be active.

Connection 
Information Box

This box displays the settings used to communicate with the 
Field Wizard. When off-line you can modify:

• Type - You should select the Direct option when 
connecting to the Field Wizard module.

• COM port - Select the appropriate COM port setting 
from the pull-down menu. Refer to your computer’s 
documentation for more information on COM ports.

• Baud Rate - Select the baud rate from the pull-down 
menu. Select 38400 when connecting to the Field Wizard.

• Modem - (not used for the Field Wizard)
• Phone number - (not used for the Field Wizard)

To save changes to the communications settings, click Apply.

Interrogated Sites - 
Field Wizard

The Interrogated Sites tab of the Field Wizard Site Window lists 
the sites that the Field Wizard interrogated and the modules 
that comprise each site.

The top section of the display lists the interrogated site’s name, 
the date and time it was last interrogated, and whether the files 
are in a saved state.

When you select a site name, the bottom section of the display 
will list the modules that exist at that site. When you select a 
module and click the Details button, it will display more details 
about that module.

Field Wizard The 2101 Field Wizard is a portable data retrieval module 
designed to collect data from, or “interrogate” Isco 2100 Series 
flow modules. It then is able to transfer that data to Flowlink.

The Field Wizard may also serve as a local display and keypad 
for a 2100 Series site.

Use the Quick Connect window to begin communications 
between Flowlink and the Field Wizard.
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Graph Window

The Graph window displays data in various formats to assist 
reporting and analysis. Flowlink 5.1 can present up to eight 
different series of data (displayed in a maximum of four panes) in 
the layouts listed below. 

Layout - Graph The top-center of the Graph window shows the main- and sub-
titles. Directly below the titles is the legend. The legend shows a 
label and a color bar for each series of data. The Y-axis displays 
the units of measure and the X-axis displays the time and date. 
The bottom line in the graph window displays the timespan 
shown on the graph. All displayed times are referenced to the 
first data set of the first series. Quick Graphs will round the start 
time to the nearest hour or to the nearest fifteen-minute interval 
when the timespan is less than ten hours.

If the Display Summary check box is selected (see page 124), the 
legend will also show the sum of all data in the timespan for 
Total Flow, Flow Rate, and Rainfall; other reading types will 
display the average value. 

Layout - Table The graph window can also display the data as a table. The 
main- and sub-titles appear at the top of the table. Column 
headings are shown below the titles to indicate the series label, 
and units. The first column is the date and time, which is always 
referenced to the first data set of the first series. The columns to 
the right of the time/date column list the readings in each series 
of data. 

When Statistical Functions are used (see page 129), the column 
headings will include the function applied. 

If the Display Summary check box is selected (see page 124), the 
bottom of the column will show the sum of all data in the column 
for Total Flow, Flow Rate, and Rainfall; other reading types will 
display the average value.

Layout - Scatter Plot The graph window can also be displayed as a scatter plot. The 
main- and sub-titles appear at the top of the scatter plot. No 
legends appear with a scatter plot, and many of the features for 
each series are disabled, as they have no relevance when a 
scatter plot is rendered. Scatter plots can be displayed with a 
Best Fit Curve. 

In a scatter plot, only the first 2 series specified on the Series tab 
of the Graph Properties window are used, and there must be at 
least 2 series specified in order to see a non-blank scatter plot. 
The first series specified is always specified on the y-axis, and the 
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next series specified is always on the x-axis. The (x, y) points 
actually displayed for a scatter plot will always have similar time 
values, so you can see how the y-axis data relates to the x-axis 
data over the timespan specified at the bottom of the scatter plot.

More topics: • Creating a Graph or Table (page 116)
• Navigating (page 118)
• Modifying Graphs and Tables (page 119)
• Flow Profiling for Pulse Doppler(page 134)
• Saving (page 135)
• Printing (page 135)
• Exporting Data (page 136)

Creating a Graph or 
Table

There are a number of methods for creating a graph or table in 
Flowlink - Quick Graph a data set, Quick Graph a site, New 
Graph, DEFAULT Graph, or Open All Graphs. Any of these 
methods will open a Graph window.

Quick Graph a data 
set

This graphs a data set using the default graph properties.

To Quick Graph a data set you can double-click on it, or:

1. Highlight a data set in the workspace.

2. Click the  Quick Graph button.
The default properties will typically allow Flowlink to present a 
graph displaying the latest readings in the data set. 

From this point you can modify several items, such as the titles, 
to customize your graph.

Tip: You can quickly add more data sets to a graph. From the 
workspace, click and drag a data set to the open Graph window 
and release. Flowlink displays the data set in a new pane.

Quick Graph a site This graphs a site using a template. A template is any existing 
graph in the open database. When you quick graph a site, the 
original graph’s data is substituted by the data of the desired 
site, while all of the graph properties remain unchanged. For 
your convenience, the Flowlink database can be pre-loaded with 
graph and table templates during installation. The templates, 
which are located in the Templates sub-directory of the Flowlink 
5.1 program folder, support many of the common needs of 
Flowlink users. For easy reference, each template is identified by 
a descriptive name. To make a template active in Flowlink, 
simply open the .IGD file.

The easiest way to Quick Graph a site using a template is to drag 
and drop the desired data set(s) on the desired graph. Or, you 
can:

1. Right-click a site in the workspace.
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2. Select Quick Graph, or from the menu select Item>Quick 
Graph. 

3. Flowlink will open a window to select the graph to be 
used as a template. Highlight the graph and click OK. 
Flowlink substitutes the new site data in the existing 
graph properties and then displays the graph.

Notes: 

• When using existing graphs as quick graph templates, 
the site that is to be substituted is defined on the General 
Properties tab.

• Graph templates can be imported into a database using 
the File>Import menu command.

New Graph or Table This opens a blank Graph window. To create a new graph:

1. Click the  New button, or select File>New (Ctrl-N) 
from the menu. Flowlink displays the New window.

2. Select Graph or Table from the list and click OK. 
Flowlink opens a blank Graph window using the default 
graph properties. 

3. Add data to the graph. This can be done by clicking and 
dragging a data set from the workspace onto the graph. 
Data may also be added to the graph from the Graph 
Properties window. 

DEFAULT Graph When you click the DEFAULT Graph button on the Site window, 
you can quickly display a graph of the site data, using the 
DEFAULT graph/table template. A common use of this feature 
would be to quickly graph the site data before disconnecting, so 
you can view the data at a glance to check site conditions.

The Quick Graph with DEFAULT option also appears when you 
right-click on a site in the workspace.

Flowlink provides several templates to choose from that can be 
imported and saved as the default. To set a Flowlink template as 
the default:

1. Select File>Import.
2. In the “Select files for import” window, go to

C:\Program Files\Flowlink 5.1\Templates.
3. Locate the template subfolder with the data interval and 

type(s) you wish to graph.
(From Files of Type, select *.igd.)

4. Select the IGD template and Open.
5. When Import Progress is complete, click Done.
6. The imported template now appears in the workspace, 

identified by file name. To set it as the default, right-click 
the template and select Copy to DEFAULT.
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The DEFAULT is now ready to use. The default will 
always be the last imported template for which you have 
selected Copy to DEFAULT.
The DEFAULT template can be further customized and 
formatted by right-clicking on the graph when it is 
displayed, and selecting Properties. 

Open All Graphs To view all graph templates in the local or global directory 
simultaneously, right-click the desired folder and select *Open 
All Graphs.

Graph - Navigating You can move through a Graph or a Table with either the mouse 
or the keyboard.

With the Mouse - • Navigating - Navigating is easiest when using the 
graph toolbar. Select View>Graph Toolbar from the menu 
and it will appear next to the Flowlink menu bar. You can 
drag it to any position that is convenient. The buttons on 
the toolbar help you move through the display. Buttons 
on the toolbar allow you to move (jog) 25% back or 
forward, to display the previous or next timespan, to 
advance to the beginning or end of data, to maximize the 
graph, to go to a particular date or time, or to zoom out 
(Unzoom).

• Select a point - (Graphs Only) Hold your cursor over a 
point on the graph and left-click. The top-left corner of 
the graph window displays the time and value of the 
selected point. Note that the time and date is always 
referenced to the first data set of the first series.

• Zoom - (Graphs Only) You can zoom in on a graph by 
left-clicking and dragging the cursor across the area of 
interest. You can zoom horizontally or vertically. Right-
click on the graph and select a zoom option from the pop-
up menu. Unzoom by clicking the Unzoom button on the 
Graph Toolbar, or select Unzoom from the Graph’s 
Actions menu.

• Magnify/Unmagnify - These buttons on the Graph 
Toolbar increase or decrease the time scale in fixed steps. 
The steps are 1 hour, 4 hours, 12 hours, 1 day, 2 days, 3 
days, 1 week, 2 weeks, 1 month, 1 quarter, and 1 year.

• Display the Properties - Double-click anywhere in the 
Graph window or click the Graph Properties button on 
the Graph Toolbar.

From the keyboard - • Navigating - Press Alt-A, G (Actions>Go To) to navigate 
using menu commands, or use the following keys:

Home - beginning of data
End - end of data
Page Up - previous timespan
Page Down - next timespan
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Ctrl-Page Up - jog left (25% of timespan)
Ctrl-Page Down - jog right

• Selecting a point - (Graphs Only) Arrow keys. The left 
and right arrow keys will move the cursor horizontally 
through the series. The up and down arrow keys move 
the cursor from pane to pane. As you move the cursor, 
note that the top-left corner of the graph window displays 
the time and value of the selected point. The time and 
date is always referenced to the first data set of the first 
series. 

• Magnify/Unmagnify - Press Alt-A, A 
(Actions>Magnify) to increase or Press Alt-A, N 
(Actions>Unmagnify) to decrease the time scale in fixed 
steps. The steps are 1 hour, 4 hours, 12 hours, 1 day, 2 
days, 3 days, 1 week, 2 weeks, 1 month, 1 quarter, and 1 
year.

• Display the Properties - Press Alt-Enter.

Graph - Modifying The appearance of the Graph or Table can be changed with the 
Properties window. To display the Properties window a graph 
window must be active on the Flowlink desktop. There are three 
ways to open the Properties window: double-click on the graph, 
click the Graph Properties button on the Graph Toolbar, or press 
Alt-Enter.

The Properties window groups the settings on three tabs.

• General Tab - contains the settings for the basic 
appearance of the graph. Use this tab to specify the titles, 
the type - graph or table, orientation, background colors, 
and font sizes.

• Time Scale Tab - contains the time settings used for the 
horizontal (X-axis) display. Use this tab to set start times 
and timespans.

• Series Tab - contains the settings that apply to the data 
displayed on the vertical (Y-axis). Use this tab to add 
data sets, control the appearance of the data, perform 
statistical operations, etc.

• Scatterplots Tab - use this tab to select the X and Y data 
sets for a scatterplot graph, as well as settings for basic 
appearance and smoothing.

Note:
Graphs and tables can only display data sets from the open 
(working) database. To include readings from more than one 
database, you first must Transfer the data to a single database.

Graph Properties - 
General

The General Tab in the Properties window contains the settings 
that control the basic appearance of the graph. Use this tab to 
specify the titles, the type - graph or table, orientation, 
background colors, font sizes, and a template site.

Follow the yellow numbered steps to enter the General settings.
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1. Enter a Main title and Subtitle for the graph. Type 
descriptive names in the text entry boxes. This text will 
appear at the top of the graph or table. 
Macros may be used to automatically fill in the field. 
• %SITE% - automatically lists the site name of the 

graphed data set.
• %FLOWCON% - lists the flow conversion method 

used.
• %FLOWCONDETAILS% - lists the details of the 

flow conversion.
Note that macros can only list the first occurrence of each 
if there are multiple sites or flow conversions displayed. 
You can combine text with macros, e.g. “Weekly Flow 
Rate - %SITE%” or “%FLOWCON% : 
%FLOWCONDETAILS%”.

2. For type output desired, select Time Series, Scatter(plot), 
or Table. Your can select more than one output type. For 
Pulse Doppler sites, select from the options listed under 
Pulse Doppler Graphs.
Note— Select Scatter to generate a scatterplot graph 
using the first two series specified on the Series tab. 
Formatting preferences for Scatterplots, including data 
point size and best fit curve, are located on the
Scatterplots tab.

3. For orientation for printing, select Portrait or Landscape.
4. General formatting preferences include the following 

options:
• Background Color - Choose a background color 

from the pull-down list. (Graphs Only)
• Grid Lines - Select one of the grid line options. 

(Graphs Only) 
• Graph Font size - Select from Small, Medium, or 

Large.
• Change Table Font - Opens the Change Font dialog 

box, where you can select a specific font, font style, 
and font size that will be used when displaying a 
table.

• Grid in front of data - Check this box to draw the 
grid lines over the plotted data. Leave this boxed 
unchecked to draw the plotted data over the grid 
lines. (Graphs Only)

• Display grid lines for minor ticks - Check this 
box to draw minor grid lines over the plotted data. 
(Graphs Only)

• Display Shadow - Check this box to draw a shadow 
behind the graph. (Graphs Only)

• Change 'Average' Label for Volume - When this 
box is deselected, an Average Volume is used in the 
label; when it is selected, a Total Volume is used.
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5. The “site substituted for when templating the graph” 
refers to a site selected from the data set list for use as a 
graph template (optional). Type the name of the site or 
click the Select… button to choose a site. The default 
template site is always the first site that appears in the 
data set list. This function is useful when the graph 
displays data from multiple sites. The new site and its 
data will replace the data from the original site specified 
in this field.

Graph Properties - 
Time Scale

The Time Scale Tab in the Properties window contains the time 
settings. Use the Time settings to control the start time and 
timespan displayed on a graph’s X-axis (horizontal), or the start 
time and number of rows in a table.

Follow the yellow numbered steps to enter the Time Scale 
settings.

1. Choose the starting date and time…. There are eight 
choices that can define the left-most point on the graph’s 
X-axis, or the first row of data in a table. The first seven 
options are always relative to today’s date. That is, if the 
graph is opened on a later day, Flowlink redraws the 
graph relative to the new date. Flowlink assumes that 
your computer’s time and date are set correctly. To verify 
that your settings are correct you can review the 
“Current time range and duration” block on this tab.
• Today - Starts the data from today’s date at the time 

you specify.
• This week - Starts the data at the day of week and 

time you specify.
• This month - Starts the data from the first day of 

the month at the time you specify.
• Yesterday - Start the data with yesterday’s date at 

the time you enter.
• Last week - Starts the data from the entered day of 

week and time from last week.
• Last month - Starts from the first day of the last 

calendar month at the time you specify.
• Relative - Use this option for those times that 

cannot be defined with the choices above. Fill in the 
entries to specify the starting point relative to the 
current time and date.

• Absolute - Enter the exact time and date to appear 
at the beginning of the graph or the first reading in a 
table.

When Printing, repeat this timespan a total of __ times - As 
a default, Flowlink will print one full timespan. Increasing this 
number allows you to print multiple time spans. For example, if a 
graph displays a one day timespan but you need seven pages to 
cover the full week, enter “7”.



Isco Flowlink 5.1® Software
Graph Window

122

2. Then enter the desired timespan and summary interval. 
Since the starting date and time sets the left-most point 
on the graph’s X-axis, the Timespan setting defines the 
Right-most point, or the last row of data in a table.
• Enter the Timespan by typing a number and 

selecting a value from the pull-down list.
• Enter the Summary interval by typing a number and 

selecting a value from the pull-down list. The 
Summary interval is used with statistical operations 
found on the Series tab of the Graph Properties 
window.

• Display times at Beginning or End. This applies to 
statistical operations. Applying statistical functions 
to readings over a summary interval will yield a 
single value for the interval. Select whether the time 
stamp for the value should be at the beginning or the 
end of the summary interval. Use the “Beginning” 
setting when the series must start at the left-most 
point on the X-axis.

See Understanding Summary Intervals on page 126

Graph Properties - 
Series

The Series Tab of the Properties window contains the settings 
that apply to the data displayed on the Y-axis (vertical). Use this 
tab to add lines to the graph or columns to a table, perform 
statistical operations, control the appearance of the series, etc.

A series is a single line plotted on a graph, or a column in a table. 
A valid graph must have at least one defined series, or as many 
as eight. Within a series, you can apply mathematical operations 
to data sets anywhere in the list or to a previously defined series.

A data set can be any data set listed in the workspace of the open 
database. (The open database is listed on the General tab of the 
Properties window.) At least one data set must be defined. As 
many as eight data sets may be entered. You can perform 
statistical operations on a data set, such as averaging readings 
over a summary interval.

Follow the yellow numbered steps to enter the Series tab 
settings.

1. Highlight a series or data set. Note that highlighting one 
of these in the top part of the window changes the 
associated properties in the lower half. Highlighting one 
of these allows you to modify that line, or add another 
series or data set below it. At this point, you can proceed 
with either step 2 or 3.

2. Then click a button. There are three buttons:
• New series - Adds a blank new series to the end of 

the list. You must then define the series in the lower 
half of the window (step 3).

• New Data Set - Adds a new data set below the 
highlighted item. You must then define the data set 
in the lower half of the window (step 3).
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• Delete Series or Data set - Removes the item from 
the list. If the item was used in a series operation, be 
sure to update the operation.

3. Or set associated properties. This area on the window 
varies according to the item highlighted in the list above.

See Defining a Series (below) and Defining a Data 
Set (on page 129) 

Additional Series 
Settings

The Series tab includes settings that control the general 
appearance of the series. These controls are located in the 
Format and Scaling sections of the tab. The Format settings 
allow you to select the line color, type, and symbol from the pull 
down lists. These format settings override the default settings 
specified in the Utilities>Options settings (page 39), and only 
apply to the current graph. The Scaling often works best when 
the Automatic check boxes are selected. However, you may wish 
to manually control the scaling. To do so, deselect the Automatic 
check boxes and enter Manual scaling values. The values entered 
will use the units specified in the Series definition box.

Signature Series 
Settings

For the Signature event data types Program, ReportA/B, History, 
and Diagnostic, enter a percentage of the Y-axis height to specify 
the position of the Event symbols in the pane.

Graph Properties - 
Defining a Series

To define the series, complete all of the fields in the Series 
definition box.

Appearance settings • Label - Type in the label. The label appears in the legend 
on a graph, or as a column heading in a table.

• Type - (Graph only) Select a Line, Bar, or Point Graph 
from the pull-down list. Bar graphs require that the Y-
axis to be put on the left side. 

• Units - Defines the units of measure. You will be unable 
to choose the units until a data set is defined for this 
series, or until an operation is chosen from the pull-down 
list. Default units of measure can be set using the 
Utilities>Options settings (page 39).

• Put in pane number -(Graph only) Flowlink can 
display up to four panes. Choose a pane number from the 
pull-down list.

• Relative height - (Graph only) Allows you to change the 
proportions of the panes.

• Put Y-axis on - (Graph only) Select an option from the 
pull down list. The far-left and far-right can be useful 
when displaying more than two lines in a pane.

• Invert Y Axis - Checking this box inverts the display in 
the pane. Note that if more than one series is displayed 
in the pane, each must have the Invert Y Axis option 
selected before the pane’s Y-axis is inverted. 
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• Default Resolution - When this box is checked, tables 
will display the default resolution for figures within a 
series. When you deselect the box, you are given the 
option of specifying how figures are rounded off, and how 
many significant digits are displayed. (For example, a 
flow rate of 551.14 gpm would display as 551.1 with a 
resolution of 0.1 and 550 with a resolution of 10.)

Operation Use the operation pull-down list to apply mathematical 
operations to one or more data sets that appear on the list. You 
can choose from:

• None - No operations will be applied to the series.
• Series Formula - Add, subtract, multiply, and divide data 

sets, and/or raise quantities to a power (exponentiation).
• Flow conversion - Convert level, or level and velocity data 

sets to a flow rate off-line.
• Volume Conversion - Convert flow rate readings to a total 

volume.
Only one operation can be performed in a series; more operations 
will require you to add a series for each operation. Flowlink 
processes the operations in order (S1, S2, S3…). If the result of 
one operation is required in another, it must precede the 
dependent operation.

Miscellaneous 
check boxes

• Display summary - If this box is checked, Flowlink will 
calculate and display a summary value for the series. If 
the series contains Total Flow or Rain data, Flowlink 
calculates the sum of all points in the timespan. If this 
box is checked for data other than Total Flow or Rain, 
Flowlink calculates the average of all points in the 
timespan. Graphs display the summary in the legend 
above the graph; tables display the summary at the 
bottom of the column. If the series displays Flow Rate 
data, it is possible to change the units.

• Display min/max times - (Tables only) Check this box 
to include the time of the minimum or maximum value 
generated by a series statistical function.

• Display samples - Check this box to display events that 
accompany the readings in the site record. When 
displaying events across multiple panes, manual scaling 
may be necessary to control the placement of the events 
across each pane.

• Visible - This box must be checked to plot the series on 
the graph. This does not affect tables.

• Sample Event Position in Y-axis - If the selected 
series contains sample event data and the “Visible” box is 
checked, enter a percentage of the Y-axis height to specify 
the position of the sample event symbols in the pane.

• Total Flow - If the selected series contains flow rate 
data, select this option to display the total flow for the 
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displayed time span above the graph. Total flow will be 
reported on the graph using the units selected in the drop 
down list below this check box.

• Avg Flow - If the selected series contains flow rate data, 
select this option to display the average flow rate for the 
displayed time span above the graph.

Graph Properties - 
Series Formulas

Series formulas can apply mathematical operations to data sets. 
With formulas, you can add, subtract, multiply, divide, and/or use 
exponentiation, absolute values, and negative integers. 
Operations can be grouped with parentheses to control the order 
of execution.

Example. Use a series formula to plot the average level recorded 
at two sites.

(The example assumes that a blank New graph was created 
using the File>New menu option. The following steps start with 
the Series tab of the Graph Properties window, although the 
General and Time Scale settings should also be defined.)

1. The List of Series and Data Sets box shows S1 and 1A 
undefined. Highlight data set 1A.

2. Identify the source of data. Click the Select… button and 
locate the level data set for the first site.

3. Click the New Data Set button. Flowlink adds data set 
1B, highlighted, but undefined.

4. Identify the source of data. Click the Select… button and 
locate the level data set for the second site.

5. Highlight series S1.
6. Select Series Formula from the Operation pull-down list. 

Flowlink displays the Formula entry box.
7. Type the formula in the box using the variables assigned 

in the List of Series and Data Sets. For the example, type 
(1A+1B)/2.

The following symbols may be used:

+ addition operator
- can be used as a:

subtraction operator, e.g. “1A - 1B”
binary minus symbol, e.g. “1A * (-1)”
unary negation operator, e.g. “(-(1A + 1B))”

* multiplication operator
/ division operator
^ exponentiation operator
| enclose absolute values, e.g. “(|1A * 2^2| * 8)”
( ) parentheses group operations and control the order of 
execution. 
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Notes: 

• For best results, always recalculate the data sets using 
the averaging statistical function. (Select the AVG button 
in the data set properties.) Set the summary interval to 
the desired interval for displaying the results on a graph 
or a table.

• The operations are executed from left to right, starting 
from within enclosed parentheses. Flowlink executes the 
exponentiation operations first, followed by 
multiplication and division operations, and it then 
proceeds with addition and subtraction, working its way 
outside of the parentheses.

• Use care to ensure that the data sets are from the same 
reading types. The units of measure are assigned by the 
first data set.

• Valid formulas will yield the result when you click the 
OK button. If Flowlink recognizes a formula error, it 
provides a Details>> button to explain the error.

See Also: Calculate Data Sets, page 25. 

Graph Properties - 
Scatterplots

The Scatterplots Tab in the Properties window contains the 
settings for a scatterplot graph. In order to generate a scatterplot 
graph, first select the Scatter option on the General Tab in the 

Properties window, or click the  button in the Graph Toolbar.

The scatterplot graph uses two series defined in the Series tab of 
the Graph Properties window. The first series data is plotted 
against the Y-axis, the second series data against the X-axis.

By default, the scatterplot graph uses the first two data series 
defined in the Series tab of the Graph Properties window. To 
select the data to be graphed, highlight “New XY Series” in the 
box. Select a data series for X and a data series for Y from the 
dropdown lists, and click the Add Plot button.

The settings for appearance and best fit curve appear for 
whatever plot is selected in the box:

• Data Point Size - select small, medium, or large.
• Data Point Symbol - select a shape from the dropdown 

list
• Data Point Color - select a color from the dropdown list.
• Best Fit Curve - apply a smooth curve to your data by 

selecting the Generate Best Fit Curve checkbox.

Understanding 
Summary Intervals

Summary intervals provide powerful statistical functions when 
manipulating data. The summary interval, when used with the 
average, minimum, maximum, or sum functions, will recalculate 
the data to the specified interval. When using summary 
intervals, Flowlink can recalculate the data for any reading 
interval, from one minute to a number of years. The 
recommended summary interval will depend on the output 
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requirements. When selecting a summary interval, you should 
consider how often a reading is necessary to produce a 
representative plot on a graph, or how often a reading should be 
listed in a table.

Since summary intervals re-sample the data to the interval you 
specify, it can serve a number of purposes:

• Generating a table to report hourly average flow rate 
summaries (Avg)

• Generating a table to report hourly or daily rainfall 
totals (Sum)

• Smoothing the appearance of data in a graph (Avg)
• Generating a table to report the peak daily flow rate and 

the time it occurred (Max)
• Generating a table to report the minimum recorded pH 

value and the time it occurred (Min)
• Preparing data for additional operations, such as Series 

Formulas or Volume Conversions (Avg) 
Recalculating the data to summary intervals is a simple process. 
For example, suppose a flow rate data set contains readings at 
five-minute intervals. Applying an Average statistical function 
over a one-hour summary interval would calculate the average 
value from the twelve readings recorded each hour. This 
recalculated data set could then be plotted on the graph, reported 
in a table, or be used in additional operations.

You should keep in mind that this recalculated data must still 
include a time stamp. Flowlink uses the “Display times at 
Beginning or end of interval” to specify where the time stamp is 
placed. Continuing with the above example, let’s look at a single 
summary interval from 8:00 to 9:00 am. Flowlink averages the 
readings starting with 8:05, 8:10, 8:15, through 9:00 am. With 
Beginning selected, the time stamp is 8:00 am. With End 
selected, the time stamp is 9:00. If your summary interval is one 
day, “Beginning” is typically used.

For additional consideration, Isco instruments always place the 
time stamp at the end. Isco instruments can take readings quite 
often, depending on their configuration and current state. If the 
instrument takes a reading every 5 seconds (to keep the LCD 
readout current), but only records the readings in a memory 
partition at 10-minute intervals, it records the average of 120 
readings (12 per minute for 10 minutes) and time-stamps the 
average with the current (end) time.

When the “Accumulate with reset” statistical function is selected, 
summary intervals are used only to reset the count to zero to 
begin the next interval. Summary Intervals are ignored when the 
“Accumulate without reset” statistical function is selected. 

Graph Properties - 
Flow Conversion

Flow Conversion operations can perform off-line flow conversion 
with level, or level and velocity data sets.
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To calculate a flow rate off-line, the List of Series and Data Sets 
should contain at least one series and one level data set for a 
level-to-flow conversion. Area velocity flow conversions should 
contain at least one series, and two data sets - level and velocity.

Steps: (assuming the list contains the required series and data 
sets already defined.)

1. Highlight the series in the List of Series and Data Sets 
box. 

2. Select Flow Conversion from the Operation pull-down 
list. The window displays additional entry fields.

3. Enter a Conversion method. You can type in the name of 
a flow conversion method listed on the Flow Conversion 
List, or click the Choose... button to select from the list.

4. Enter the variable assigned to the level data set in the 
Level field. The variable is displayed in front of data sets 
in the List of Series and Data Sets box. For example, type 
1A.

5. If you selected an area velocity Flow conversion method, 
enter the variable for the velocity data set in the Vel: 
field. For example, type 1B.

Notes: 

• For best results, always recalculate the level and velocity 
data using the averaging statistical function. (Select the 
AVG button in the data set properties.) Set the summary 
interval to the desired interval for displaying the flow 
rate on a graph or a table.

• Valid formulas will yield a flow conversion when you click 
the OK button. If Flowlink recognizes a formula error, it 
provides a Details>> button to explain the error.

Graph Properties - 
Volume Conversion

Volume Conversions calculate volumes from a flow rate. Volume 
conversions can be performed with or without summary 
intervals. Without summary intervals, Flowlink integrates the 
volume between each flow rate reading. With an averaging 
summary interval, Flowlink integrates the volume over the 
interval.

Example. Using a flow rate data set, report hourly volumes and a 
daily total volume in a table.

(The example assumes that a blank, New graph was created 
using the File>New menu option. The following steps start with 
the General tab of the Graph Properties window and explain only 
the minimum required settings.)

1. On the General tab, set the Type to Table.
2. View the Time Scale tab.
3. Choose the starting date and set the time to start at 

00:00 (or 12:00 AM) by clicking on the  Midnight 
button.
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4. Set the Timespan to 1 Day. 
5. Set the Summary interval to 1 Hour.
6. Select the Display times at End of interval option.
7. View the Series tab and highlight Data set 1A in the List 

of Series and Data Sets box.
8. Select the Avg Statistical function.
9. Specify the Source of data. Click the Select… button and 

locate the Flow Rate data set to convert.
10. Highlight Series S1 in the List of Series and Data Sets 

box.
11. Select Volume Conversion from the Operation pull-down 

list.
12. Ensure that the Flow: field directly below the Operation 

pull-down list reads 1A.
13. Check the Display Summary check box at the bottom of 

the tab.
14. Click OK. Flowlink displays the table.

Graph Properties - 
Defining a Data set

Defining a data set is step 3 of the Graph Properties Series tab. 
To define the data set, complete all of the fields in the lower half 
of the tab.

Statistical function You can use statistical functions to modify the readings in a data 
set. The functions are applied in conjunction with the summary 
interval defined on the Time Scale tab. There are several options:

• None - Disables the functions. Any setting in the 
summary interval is ignored.

• Avg - (Average) Recalculates the data to produce an 
average value for the summary interval. For example, 
recalculating flow rate readings taken at five-minute 
intervals over a one-hour summary interval will produce 
an hourly average flow rate. The graph or table will 
display one data point every hour.

• Min - (Minimum) Reports the lowest-valued reading that 
occurs during each summary interval. For example, to 
report the lowest pH reading of every hour, set the 
summary time interval to one hour and select the Min 
button. The graph will plot the lowest pH reading of each 
hour. A table will also report the lowest reading of the 
hour. However, a table can also report in a separate 
column the time the reading occurred if the Display min/
max times check box is selected for the corresponding 
series.

• Max - Reports the highest-valued reading that occurs 
during each summary interval. It reports the data in the 
same manner as the Min function described above.

• Sum - Adds the values of all the readings during the 
summary interval and reports the sum at the end of each 
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interval. Sum is typically used for reporting totals at a 
specified interval, such as daily rainfall.

• Accumulate without reset - Adds the value of each 
reading to the sum of the previous readings. This 
accumulation ignores the summary interval and 
continues for the displayed timespan. 

• Accumulate with reset - Adds the value of each 
reading to the sum of the previous readings. This 
accumulation continues for only the duration of the 
summary interval. The accumulation resets at the start 
of each summary interval. The graph displays the 
accumulated value for each interval if there are seven or 
fewer summary intervals for the timespan. 
The Accumulate statistical functions display a data point 
for each reading, This differs from the other statistical 
functions, which only display one point for each summary 
interval. 
When using the Accumulate functions, deselecting the 
Display summary check box is recommended. Otherwise 
the Display summary will report the total of all 
accumulated readings. 
Note that accumulating a flow rate does not produce a 
total volume for the timespan or summary interval. To 
accumulate volumes from a flow rate, first apply a 
volume conversion, then calculate a data set containing 
the volume data. Then, add the volume data set and 
apply the accumulate function.

Data Set Displays the site name and data set used as the source. You can 
change the source by typing in the name of another site and data 
set, or click the Select… button to browse for a source. 

Data Type The data type buttons allow you to select edited readings or 
original values from the database. When the Zero error data 
option is selected, the graph will go to zero when an error is 
encountered, rather than drawing a straight line from the last 
valid reading to the next valid reading.

Time definition This box contains three options:

• Standard time - The graph will show the data and its 
time stamp as it is stored in the database.

• Shift time - The graph will shift the time stamp of the 
data forward or backward by the amount entered.

• Absolute - Translates the time stamp of the data to an 
absolute time and date. The readings in the data set, 
beginning with the Start Time entered on the Time Scale 
tab, will be moved to the absolute date and time 
specified.
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Generate Scatter 
Plot

When a graph or table is active on the Flowlink desktop, clicking 

the  button will generate a scatter plot using the first two 
series defined in the Series tab of the Graph Properties window. 
The first series data is plotted against the Y-axis, the second 
series data against the X-axis. Only data points visible in the 
current time span of the graph or table window are scatter 
plotted. You can move to the next or previous time span by using 
the Actions>Go To options or the Graph Toolbar buttons. To 
return to the normal graph or table view from a scatter plot view, 
click the scatter plot button again. 

This view requires two series of data to be defined. If there are 
additional series defined on the Graph Properties window they 
will be ignored in the scatter plot view. 

The scatter plot view may also be defined as a graph property by 
checking the Generate scatter plot check box on the General tab 
of the Graph Properties window. The graph property window also 
allows you to add a best fit curve to the scatter plot. 

The scatter plot includes display elements that help you read the 
data. Like normal graphs, the scatter plot includes the title and 
subtitle at the top of the display and a time span below the plot 
area. Information about the selected data point is reported in the 
top-right corner above the plot area. The top-most numbers 
reports the X and Y coordinates of the selected point. The 
Number of Points identifies how many points have the same X 
and Y coordinates. When several points have the same 
coordinates, the Time Stamp reports the latest highlighted data 
point. 

Reference Curve Reference Curves allow you to create a data set that can be used 
as a weekly “standard” or “baseline” to test or compare other 
data sets of the same measurement type. 

For example, flow rate data representing a dry weather flow 
pattern can be established as a reference curve. The reference 
curve can then be compared to flow rates experienced during wet 
weather. As a data series, this normal, dry weather flow rate can 
also be subtracted from the wet weather flow rate using a series 
formula to report the difference. 

To establish a reference curve:

1. Graph the data to be used as a reference. 
Tip - Because reference curve data repeats weekly, 
setting the time scale to one week may be helpful. 

2. Locate a suitable week and note the start date.
3. Right-click on the graph and select the Reference Curve 

menu option.
4. Enter the Start Date.
5. Select the Destination of the Reference Curve data set. 
6. Click OK. Flowlink creates a new data set in the selected 

destination. 
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Using Reference 
Curves

After creating a reference curve, it can be added to a graph. 
When adding a reference curve to a graph containing other data 
sets, the reference curve synchronizes to the day of week and 
time of the other data sets. The reference curve remains 
synchronized and repeats when the displayed time span is 
changed. 

Note: Reference curve data can be edited. 

Annotating Graphs Flowlink provides several tools to annotate graphs before 
printing or exporting. You can add horizontal and vertical lines, 
and text to the graphs.

Flowlink can add Best Fit Curves to a scatter plot.

Horizontal Lines Two horizontal lines can be added to each pane in a graph to 
temporarily annotate data for display and printing. To add 
horizontal lines:

1. In an open graph, select a data point in the pane to which 
the line should be added. 

2. Right-click on the graph and select the Horizontal Line 
option. This opens a window to specify where the lines 
will be added. 

3. Check the 1st Value check box, then enter the Y-axis 
value that the horizontal line will intersect. 

4. If a second line is desired, check the 2nd Value box and 
specify the Y-axis value. 

5. Click OK.
Repeat for other panes as needed. 

Note: Horizontal lines are active as long as the graph is open. 
The lines will display for all viewed time spans. However, 
horizontal lines are not saved with the Graph (.IGD) file. 

Vertical Lines A vertical line can be added to a graph to temporarily annotate 
data for display and printing. The vertical line extends through 
all panes in the graph. To add a vertical line:

1. In an open graph, select a data point in the pane to which 
the line should be added. 

2. Right-click and select the Vertical Line option. A vertical 
line appears at the selected point in the time span. 

This option toggles the vertical line on and off. As long as this 
option is on, the vertical line appears at the selected data point in 
a graph. Therefore, the line can be moved by clicking on a new 
point in the graph, or by moving the selected point using the left 
and right arrow keys. If the time span is changed, the selected 
point is the first (left-most) point in the first pane of the graph. 

Text Boxes Text can be added to graphs to annotate data. To add text:

1. Select a data point on a graph.
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2. Right-click and select TextBox from the menu. The Add 
Text Box window opens. 

3. Type the text.
The text box allows up to 40 characters.

4. Click OK. The text appears next to the data point on the 
graph.

Notes:

• The Cancel button closes the Add Text window without 
placing an annotation on the graph. 

• To delete a text annotation from the graph, select the 
data point for the annotation. Then right-click and select 
the TextBox option from the popup menu which opens 
the Add Text Box window. Click the Delete button and 
Flowlink removes the annotation.

• There is a limit of 15 text boxes to a time span, although 
more text boxes can be added elsewhere in the graph. 
Note that if the time span is increased and the number of 
text boxes exceeds the limit, the text boxes are hidden 
from the display.

• Text boxes are saved with the Graph (.IGD) file, not as 
part of the site data. Be aware that if the graph is used as 
a template, the text boxes are retained when the 
substituted data is displayed.

Best Fit Curves To aid the analysis of data represented in a scatter plot, the Best 
Fit Curves feature can apply a smooth curve to your data. This 
can help you determine if the data fits within an expected model. 
Additionally, best fit curves may be used when editing data in a 
scatter plot.

To display a best fit curve on a scatter plot, open the graph 
properties window and select the “Generate best fit curve” check 
box on the General Properties tab.

You can select from two types of best fit curves. A third degree 
polynomial curve can be applied using any data in series one and 
two. A Manning formula curve can also be applied to plot the 
level with a calculated velocity based on the pipe diameter, 
roughness coefficient and slope. The Manning formula option 
requires that series one use Level data for the Y-Axis and series 
two use Velocity data for the X-Axis. Select the check box for the 
desired option. If the Manning formula is selected, a window 
appears to enter coefficients for the formula.

The best fit curve will be displayed with limits. Enter the limit 
value and specify the limit type. Limit type options are:

• Percent of Best Fit Curve - Flowlink calculates upper 
and lower limit lines using the limit value as a 
percentage of each best fit curve data point. 

• Offset of Best Fit Curve - Flowlink calculates upper 
and lower limits using the limit value as a fixed offset for 
each best fit curve data point.
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• Percent of Maximum Value - Flowlink identifies the 
maximum value in the best fit curve and determines an 
offset value using the limit value as a percentage. Each 
best fit curve data point is offset by this offset value to 
calculate the upper and lower limits. 

Manning 
Coefficients

When adding a best fit curve using a Manning formula, Flowlink 
opens a dialog box so you can add the Manning coefficients. 
Enter values for the following:

• Diameter - Enter the pipe diameter.
• Slope - Enter the slope as a dimensionless quantity, 

delta Y/ delta X, not as percent slope.
• Roughness - Enter the roughness coefficient for the pipe 

(see page 88).

Flow Profiles (Pulse 
Doppler only)

When graphing flow data from Pulse Doppler instruments, there 
are five additional options for viewing the data. From either the 
toolbar or Graphs>Flow Profile, you may select any combination 
of the following views:

The Profile Cross-Section window shows a hydrograph and a 
color contour plot of the flow profile. This flow profile is 
developed from the raw beam velocity profiling information. This 
raw velocity data is entered into an algorithm that produces a 
mathematical description of velocity as a function of position 
within the pipe or channel. The Y axis represents channel height, 
and the X axis represents channel width. Velocity is represented 
by different colors.

Velocity and Velocity Vector plots indicate the quality of the 
sensor installation and alignment. In a perfect installation, 
Beams 1 & 3 will be equal in amplitude and opposite in sign. 
Beams 2 & 4 will also be equal in amplitude and opposite in sign, 
but will have a greater amplitude than 1 & 3 by approximately 
50%. Even in a perfect installation, however, hydraulic 
conditions may still produce asymmetrical beam profiles.

A Pulse Doppler instrument operates by emitting a sound pulse 
and then receiving the echoes backscattered by material 
suspended in the flow. Amplitude is a measure of the strength of 
this return signal.

Correlation is a measure of the quality of the processed velocity 
information. Lower Correlation values (e.g., below 100) are an 
indication of poor quality velocity data. Higher Correlation 
values (e.g., above 150) may indicate external interference (noise) 
or the presence of a “hard” acoustic barrier.

The Play/Pause Graph button on the toolbar shows the data 
sequence in a continuous loop until Play/Pause Graph is pressed 
again.
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Saving Graphs and 
Tables

Once you have created a graph or a table, you can save it for later 
use, or to be used as an object in another application. Flowlink 
supports Object Linking and Embedding (OLE 2.1).

To save a graph or table:

1. With the Graph window active on the Flowlink desktop, 

click the  Save button on the toolbar or select 
File>Save from the menu.

2. Name the graph in the Graph name box. A filename can 
contain up to 251 characters, including spaces. Do not 
use any of the following characters: \ / : * & ? " < > |

3. Click OK. The graph name appears in the workspace.
The graph also appears as a file in the working directory of the 
current database. You can locate this file with the Windows 
Explorer under the same name that appears in the workspace. If 
Windows Explorer is enabled to show extensions, you may also 
note that Flowlink adds an IGD (Isco Graph Document) 
extension to the filename.

Printing a Graph or 
Table

Print Preview After creating the graph or table, you can check to see how it will 
look on paper. 

To preview the printed output, click on the  Print Preview 
button on the toolbar, or select File>Print Preview from the 
menu. The graph or table will open in the Print Preview window. 
The print preview will display the current timespan. 

The Print Preview window contains several buttons across the 
top of the window:

• Print - Opens the Windows Print Dialog box to send the 
graph or table to the printer.

• Next Page and Prev Page - Steps through multiple 
pages of a table.

• Two Page/One Page - Displays one or two pages of a 
table at a time.

• Zoom In/Zoom Out - Changes the scale of the preview 
image.

• Close - Closes the Preview window and returns to the 
Graph window.

Printing 1. (Optional) Review/change the Print setup. Select 
File>Print Setup...

2. Click the  Print button on the toolbar, or select 
File>Print from the menu.
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Export Data When a graph, table, or scatter plot is active on the Flowlink 
desktop (see How do I Create a Graph), selecting File>Export 
will export the series data shown on the graph, table, or plot. 
Several export formats are available:

• CSV (“Comma Separated Values”, also known as comma-
delimited), without summary. 
Most spreadsheet applications can open or read .CSV 
formats, and as an ASCII text file, the .CSV file can be 
opened with any text editor. Flowlink exports CSV files 
with a Data Definition Header.

• CSV, with summary. For tables, the summary 
information appears in the last line of the file.

• PDF (Portable Document Format), for sharing and 
viewing data using Adobe Acrobat family of products, 
including the free Adobe Reader.

• HTML (HyperText Markup Language), for sharing and 
viewing data using an Internet browser. 

How to export data:

1. From the Flowlink menu, select File>Export.
2. Type the path and file name, or browse for the new 

location by clicking the Select… button.
3. Select the export format from the Save As Type box and 

click OK.
4. Click Export.

Flowlink displays its progress on the bar in the status box.

http://www.adobe.com/products/acrobat/readstep2.html
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Editor Window

The Editor window is used to view or modify the readings in a 
data set. Any raw site data in the database can be edited with 
the exception of sample events. Note that series data produced 
for graphs (such as series formulas, flow conversions, volume 
conversions, and statistical functions) are not raw data, thus 
cannot be edited.

To activate the Editor window, right-click in the active graph or 
table and select Edit.

The Editor window displays the data in two views: as a graph 
and as a table of readings. Both the graph and the table can be 
used to view and select the readings for editing. The graph view 
may include up to eight data series, however only one may be 
edited at a time. Once a reading or range of readings has been 
selected (highlighted), you can change the data with the Editor 
toolbar above the Flowlink desktop.

Data may also be edited in a Scatter plot view (see page 145).

After editing the readings, you can save the changes in the 
database by clicking the Save button. Flowlink saves both the 
edited readings and the original data in the database.

If you have made changes but do not wish to save them, click the 
Undo All button. Flowlink undoes the editing and restores the 
data and the display to the last saved version.

To change the displayed units of measure, select a new value 
from the Data Units pull-down list.

Related Topics:

• Viewing and selecting readings (see page 138)
• Making adjustments: 

Constant Value (page 143)
Fixed Offset (page 143)
Proportional (page 143)
Time (page 144)
Multiply by Constant Value (page 144)
Auto Correct (page 144)
Restore Original Readings (page 145)



Isco Flowlink 5.1® Software
Editor Window

138

Editor - Viewing and 
Selecting

The editor window displays the data in two views: as a graph and 
as a table of readings. There are several ways to move through 
these readings and to select them for editing. 

With the Mouse -

• Navigating - Navigating is easiest when using the 
graph toolbar. Select View>Graph Toolbar from the menu 
and it will appear next to the Flowlink menu bar. You can 
drag it to any position that is convenient. The buttons on 
the toolbar help you navigate through the data. Buttons 
on the toolbar allow you to move (jog) 25% back or 
forward, to display the previous or next timespan, to 
advance to the beginning or end of data, to maximize the 
graph, to go to a particular date or time, or to zoom out 
(Unzoom).

• Select a point - Hold your cursor over a point on the 
graph and left-click. Note that the table on the right will 
highlight the time, date and value of that one data point. 
Conversely, left-click on a line in the table and the graph 
will indicate that point.

• Selecting a range of points - Left-click and drag across 
the graph to select a block of readings. Note that it is 
possible to select non-consecutive points. This method is 
ideal when there is a need to adjust only the highest or 
lowest points, excluding the normal readings. Non-
consecutive selected points will prevent you from copying 
or cutting the readings. 
On the table, you can also shift-click, or you can left-click 
and drag the cursor over the readings. Control-click to 
select non-consecutive points. 

• Display the Editor menu options - right-click 
anywhere in the Editor window.

From the keyboard, you will find it easiest to work within the 
table.

• Navigating - Press Alt-A, G (Actions>Go To) to navigate 
using menu commands, or use the following keys:

Home - beginning of data
End - end of data
Page Up - previous timespan
Page Down - next timespan
Ctrl-Page Up - jog left (25% of timespan)
Ctrl-Page Down - jog right

• Selecting a point - Up and down arrow keys.
• Selecting a range of points - Use the Up or Down 

arrow key to select the first point. Hold down the shift 
key while pressing the Up or down arrow keys to select 
the remaining points.
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Notes: 

• The graph will always adjust its display to show all of the 
readings over the timespan. However, the table may not 
always be able to do so. The table is limited to the 
number of readings specified by the Utilities>Options 
setting. When the table cannot display all of the readings 
over the full timespan visible in the graph, the table can 
be advanced to the next page of data by selecting the first 
or last row of table data. 

• It is possible for the graph to contain many more selected 
points than the table can show. However the Editor will 
still apply adjustments to all selected data. 

• The graph displays the original and edited readings 
graphed as different colors. The table lists edited and 
original values for each point. 

Editor - Specific 
Date/Time...

To open the Enter Display Date/Time, select Actions>Go 
To>Specific Date/Time... from the Flowlink menu while the 
Editor window is open. 

Use this window to jump to a time/date. The entries you make in 
this window will be applied to the Editor window that is 
currently active.

Steps:

1. Enter the Start Date. Type the date (for example, “3/1/
05”), or click on the pull-down arrow to select the date 
from a calendar.

2. Enter the Start Time. Type in the hour, minute, and “A” 
(AM) or “P” (PM). Or, highlight the value to change and 
click on the Up or Down arrows.

The graph and the table of readings in the Editor window will 
jump to the Start Date and Time. The graph and table will 
display all the readings that occur during the timespan.

Editor - Making 
Adjustments

Reading adjustments may be needed for several reasons. Some 
examples are:

• To correct erroneous readings caused by mis-calibrated 
sensors

• To fill in gaps caused by power outages, signal loss, etc.
• Clock changes
• Memory partition changes

To adjust the data:

1. Open the data set for editing. There are two ways to do 
this:
• Highlight the data set in the workspace and click the 

 Edit Data set button (or the Item>Edit menu 
command). The Editor window will display the 
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default timespan specified by the Utilities>Options 
settings.

• Graph the data. Then right-click on the graph and 
select the Edit option to enable the Editor. 

Alternatively, you can click the  Edit/View 
toolbar button to enable the editor. The Editor 
window displays the timespan specified by the graph 
properties. 

2. Locate the incorrect data and highlight it. Using default 
settings, Flowlink can edit up to 1439 readings (a day of 
readings at one-minute intervals) at a time. The number 
of readings can be increased or decreased as needed from 
the Utilities>Options window. 

3. Using the Type pull-down list on the Editor toolbar, 
Determine the type of reading adjustment that will be 
necessary. 
• Constant value - changes all of the highlighted 

readings to a single value.
• Fixed offset - increases or decreases the highlighted 

readings by a fixed amount.
• Proportional - distributes an adjustment 

proportionately over selected readings.
• Multiply by Constant Value - multiplies the readings 

by a specified constant value. Specify a value greater 
than 1 to increase the readings; less than 1 to 
decrease the readings.

• Auto Correct - When selected, Flowlink will adjust 
the highlighted readings to fit adjacent readings. 
Because the amount is calculated by Flowlink, the 
Amount value is not needed.

• Time (minutes) - shifts the highlighted times forward 
or backward a fixed amount.

• Restore to Original - removes any corrections made to 
the readings to restore it to the original data.

4. Enter the Amount.
5. Click Adjust. Flowlink changes the data according to the 

Type and Amount. The new readings are displayed on 
the table. The graph shows both the original and the new 
readings. Default line colors can be specified on the 
Utilities>Options window. 

6. Click Save Changes.
Sometimes you may find that a combination of adjustment types 
may work best to produce the desired results. Repeat the steps 
above to apply additional adjustments.
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Other Adjustment 
Methods

• Copy and Paste - Highlight correct readings and Copy 
(Ctrl-C) them. This places the readings on the clipboard. 
Highlight the incorrect data and Paste (Ctrl-V). Flowlink 
replaces the readings with those on the clipboard. You 
can also copy and paste using the buttons on the toolbar 
or using the menu options displayed when you right-click 
in the editor window.

• Cut - Highlight the readings to remove and Cut (Ctrl-X) 
them. This places them on the clipboard. They will be 
available for pasting elsewhere until they are replaced by 
another Copy or Cut. Cut can be used to remove 
unwanted readings or No Data codes from the data set. 
You can also cut readings with the Cut button on the 
toolbar.

• Insert - Highlight the beginning point where you wish to 
insert readings. Then, right click and select 
Insert>Before or Insert>After. The editor then inserts 
data from the clipboard (from the last Copy or Cut). 
Insert may be used to fill gaps, or to add readings at the 
beginning or end of the data. It cannot overwrite valid 
readings.

• Click and drag - Single readings can be moved on the 
graph by clicking and dragging the point to a new value. 

Notes: 

• It is possible to insert readings that will not appear in 
the timespan currently viewed on the graph and the 
table. It may be necessary to move to the previous or next 
time span to see the adjustments.

• When Flowlink combines sites to form a line of data on a 
graph or report, it will not combine error codes with 
readings. Instead, it will report no data. 

• New values that you can store in the database are only 
limited to the resolution and significant digits for the 
data set. Viewing the Data set Properties (Highlight a 
data set in the workspace and press Ctrl+F2) will reveal 
this information.

• When editing, Flowlink saves both the original and the 
edited data. If necessary, the original values can be 
restored.

Copy To copy readings displayed in the Editor window, first highlight 
the data to copy. Then, do one of the following:

• click the Copy button on the toolbar 
• right-click and select Copy from the popup menu
• press Ctrl-C on the keyboard. 

When you copy data, the data will be stored on a clipboard so 
that you can paste it elsewhere, including another data set (of 
the same measurement type) or application.



Isco Flowlink 5.1® Software
Editor Window

142

Cut To cut readings displayed in the Editor window, first highlight 
the data to remove. Then, do one of the following:

• click the Cut button on the toolbar
• right-click and select Cut from the popup menu
• press Ctrl-X on the keyboard. 

When you cut data, the data will be stored on a clipboard so that 
you can paste it elsewhere, including another data set (of the 
same measurement type) or application.

Insert To insert data readings - perhaps to fill in gaps in data caused by 
a power failure, etc. - you will use the Insert Readings function. 
This function will also appear if you have previously cut or copied 
data and want to insert it into a graph. 

1. In the Editor window, copy or cut data to place it in your 
computer’s clipboard. This data can be from elsewhere in 
the same data set or from a different site, as long as the 
data properties match. 

2. Go to the Date/time where the readings should be 
inserted.

3. Right-click and select the Insert>Before or Insert>After 
option. 
Flowlink adds data from the clipboard to the displayed 
graph and table. If valid data exists in the range, 
clipboard data is dropped wherever readings overlap. 
This prevents valid data from being overwritten and 
Flowlink advises you that only part of the data was 
inserted. If you want to overwrite the data, use the Paste 
command instead. 

Note: Only similar readings can be inserted into a data set. For 
example, only level readings can be pasted into a level data set. 

Paste Paste places readings stored on the clipboard into the data set. 
(Copy or cut the readings to store them on the clipboard.)

To paste readings from the clipboard:

1. Select the reading to be replaced. If more than one 
reading is on the clipboard, select the starting point for 
the new readings.

2. Click the Paste button from the toolbar or right-click and 
select Paste (Ctrl-V). The new reading(s) will appear.

If there are multiple readings on the clipboard, Paste will 
transfer all to the selected location. If the block of readings on the 
clipboard overlaps existing readings, Paste overwrites the 
existing readings. If you are trying to fill in gaps of data while 
preserving valid readings, use the Insert command instead.

Note: Only similar readings can be pasted into a data set. For 
example, only level readings can be pasted into a level data set. 
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Editor - Constant 
Value Adjustment

A constant value adjustment changes all selected readings to a 
constant reading. For example, you can change all level readings 
recorded between 12:00 noon and 13:20 to 1.2 feet. 

Constant adjustments are also useful when you want to change 
No Data Codes to simulated readings. For example, if a partition 
contains No Data Codes caused by loss of power, use the constant 
adjustments to replace the codes with realistic values.

Steps:

1. Highlight the readings to edit.
2. Select the Constant value adjustment from the Type pull-

down list on the Editor toolbar.
3. Enter the Amount.
4. Click Adjust.

Editor - Fixed Offset 
Adjustment

A fixed offset adjustment increases or decreases all selected 
readings by the same amount. When you apply a fixed offset 
adjustment, the adjustment is added to or subtracted from each 
of the selected readings. 

Example: Increase level readings by 0.5 feet.

Although fixed adjustments have many applications, they are 
most frequently used to correct calibration errors.

Steps

1. Highlight the readings to edit.
2. Select the Fixed Offset adjustment from the Type pull-

down list on the Editor toolbar.
3. Enter the Amount. This value can be positive or negative.
4. Click Adjust.

Editor - Proportional 
Adjustment

A proportional reading adjustment distributes an adjustment 
proportionately over selected readings. Flowlink determines the 
total adjustment applied to each reading by dividing the 
adjustment by the number of selected readings. As Flowlink goes 
through the list of selected readings, each selected reading 
receives a larger proportion of the adjustment.

Example: A proportional level adjustment of 1 foot over three 
readings would adjust the first reading by 0.33 feet, the second 
by 0.67 feet, and the third by 1.0 feet. A reading of 1 foot 
distributed over five readings would adjust the first reading by 
0.2 foot, the second by 0.4 foot, the third by 0.6 foot, etc.

Proportional adjustments can be positive or negative to increase 
or decrease readings. You can use proportional adjustments to 
edit readings generated by a constant adjustment. 

Example: After you have adjusted No Data Codes to constant 
values with a constant adjustment, enter a proportional 
adjustment to smooth the transition between the readings that 
preceded and followed the No Data Codes.
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Steps:

1. Highlight the readings to edit.
2. Select the Proportional adjustment from the Type pull-

down list on the Editor toolbar.
3. Enter the Amount. This value can be positive or negative, 

and will be divided among the total number of readings 
highlighted.

4. Click Adjust.

Editor - Time 
Adjustments

Time adjustments offset the times of the selected readings by a 
fixed amount. A common use for time adjustments is to correct 
readings recorded by an instrument set for the wrong time.

Steps

1. Highlight the readings to edit.
2. Select the Time (minutes) adjustment from the Type 

pull-down list on the Editor toolbar.
3. Enter the Amount in minutes. This value can be positive 

or negative. For example, enter 2 hours as 120 minutes.
4. Click Adjust.

Note: 

It is possible to make time adjustments that will not appear in 
the timespan currently viewed on the graph and the table. It may 
be necessary to move to the previous or next time span to see the 
adjustments.

Editor - Multiply by 
Constant Value

A Multiply by Constant Value adjustment multiplies all selected 
readings by a constant. 

Example: Multiply selected readings by “1.2.”

Reading 1, original value = 2.0; edited value = 2.4
Reading 2, original value = 2.1; edited value = 2.52
etc.

Steps

1. Highlight the readings to edit.
2. Select the Multiply by Constant Value adjustment from 

the Type pull-down list on the Editor toolbar.
3. Enter the Amount. This value can be positive or negative.
4. Click Adjust.

Editor - Auto Correct An Auto Correct adjustment redraws the selected data points to 
connect the data points immediately before and after the selected 
data. When you apply an auto correct adjustment, the editor 
calculates the data points so that a straight line connects the 
adjacent points. 

Example: Select “spikes” or gaps of missing data and redraw data 
points to connect known good values.
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Steps

1. Highlight the readings to edit.
2. Select the Auto Correct adjustment from the Type pull-

down list on the Editor toolbar.
3. Click Adjust.

Editor - Restore to 
Original

Flowlink saves the edited and the original values in the 
database. It is possible to restore the readings in a data set to 
their original values by clearing the edited values. 

To restore the original data:

1. Highlight the readings in the table or graph view that 
you wish to restore.

2. Select the Restore to Original adjustment from the Type 
pull-down list on the Editor toolbar.

3. Click Adjust.
Notes: 

• Restore Original Data differs from the “Undo All Editing” 
button, which simply reverts to the last saved data. 

• Restore Original Data can be used at any time to remove 
modifications.

Editor - Undo All Undo All cancels any changes that you have made to the data. 
The reading and time values revert to the last-saved values. 

See also: Restore to Original 

Editor - Scatter Plots Data sets displayed in a scatter plot layout may be edited. To 
enable editing when viewing a scatter plot, right-click on the plot 
and select the Edit menu option. Flowlink then displays an 
editing toolbar. However, unlike editing data in a normal graph 
view, a table view is not available while editing a scatter plot. 

There are a few ways to edit data in a scatter plot. To adjust a 
single point, it is easiest to click and drag the point:

1. Identify a single point that requires editing and 
determine which direction it should be adjusted. Select 
the Horizontal or Vertical option from the Direction box 
on the editing toolbar. 
Note: Selecting “Vertical” edits data in the data set 
labeled on the Y-axis. The data set labeled on the X-axis 
will not be adjusted. Conversely, selecting “Horizontal” 
adjusts data in the data set labeled on the X-axis.

2. Click and drag the point to adjust it along the selected 
axis. This step can be repeated for other points. 

3. Click the Save button on the editing toolbar to save the 
changes. 
To cancel the adjustments, click the Undo All button. All 
adjusted points return to the last-saved coordinates.
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Best fit curves can assist with the data editing, especially when 
many points need to be adjusted. With best fit curves and limits 
displayed in a scatter plot, you can:

• Adjust a single point, moving it to the nearest limit or to 
the best fit curve. To do so, click on the point to highlight 
it. Set the Direction. Then, choose the Correct...“To limit” 
or “To Best Fit Curve” option. Click the Adjust button. 

• Adjust a block of points, moving them to the nearest limit 
or to the best fit curve. To do so, click and drag the cursor 
across a block of points. The editor displays a box to show 
which points are selected. Then, use the editing toolbar 
to adjust the selected points. 

• Adjust all outliers, moving them to the nearest limit or to 
the best fit curve. To do so, select the Direction. Then, 
choose the Correct... “All Outliers To Limit” or “All 
Outliers To Best Fit Curve.” Click the Adjust button. 

To exit the editor, right-click on the scatter plot and deselect the 
Edit menu option. 

No Data Codes When an Isco instrument fails to obtain a reading, it stores one of 
several No Data Codes instead of a reading. These codes are 
listed below.

The Editor window may be used to correct the errors.

Code No Data Type Explanation

255 Power failed/clock 
changed

An Isco instrument uses this code to 
indicate it experienced a power 
failure that prevented it from taking a 
reading, or its clock was altered to 
an extent that it must write at least 
one new record with a No Data 
Code.

254 Power Fail A power failure has prevented the 
readings from being stored.

253 Input not available Used when the level sensor is 
disconnected, defective, or is giving 
false readings.

252 Record Deleted Used in 3200 Series Flow Meters 
only. This code indicates a record 
has been deleted because the flow 
meter’s clock has been set back to 
such an extent that existing records 
must be erased.
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251 Gap Record Used by DATAMAN, a Flowlink 2 
module, to indicate a gap in time 
between two merged data sets. This 
value appears only in readings 
imported from an edited Flowlink 2 
data set.

250 Data Overflow The number of rainfall counts 
produced by the rain gauge 
exceeded the capacity of the 
memory location.

248 Low Signal Strength Area velocity instruments use this 
No Data Code to indicate the flow 
stream does not contain enough 
reflective particles for the sensor to 
produce a velocity reading or that 
the sensor is covered with silt or 
sludge.

247 Velocity Level Too 
Low

Area velocity instruments use this 
No Data Code to indicate that the 
water level in the flow stream is 
below the minimum depth and the 
“set flow rate to zero if no velocity 
data” option is selected.
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Schedules

This feature allows you to accomplish a variety of tasks without 
being present at the computer. Schedules can automatically 
interrogate remote instruments, print graphs or tables, update 
documents in your word processing application, etc. Schedules let 
you control the workflow and save both time and money. For 
example, you can interrogate instruments at night or on 
weekends when telephone rates are cheaper, or send print jobs to 
network printers when the demand is lower.

For any Flowlink scheduled operation to occur, the Wakeup 
Monitor must be configured and running. Wakeup Monitor is a 
separate application from Flowlink, giving you the ability to close 
Flowlink, but still run the schedules.

Schedules are set up using the Schedule Time and New Task 
windows.

Tips - 

• Before setting up scheduled interrogations, connect with 
each instrument and ensure that the Site Setup is 
correct. This also ensures the communications settings 
are correct for the instrument.

• Create any needed Graph or Table files beforehand. The 
graphs or tables should use a relative starting time and 
date for best results.

Wakeup Monitor The Wakeup Monitor application must be configured and 
running in order for scheduled operations to occur. See Wakeup 
Monitor online Help for complete information.

To configure Wakeup Monitor:

1. Start the Wakeup Monitor application by clicking the 
icon on your desktop or by slecting Start>Flowlink 
5.1>Wakeup Monitor. An alarm clock icon will appear in 
the Windows task bar.

2. Right-click the alarm clock icon and select Configure 
Scheduler Service.

3. On the Databases tab, click Add and use the Open 
Database window to select the database(s) you wish to 
perform scheduled tasks.

4. Use the Service tab to start and stop the scheduler 
service. Check the box under Configuration if you want 
the service to start automatically with system startup. 
Under Printing Options, select and configure the printer 
for any scheduled printing tasks.
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Schedule Times The Schedule Window contains the settings that define when a 
task or tasks will occur.

Set up a schedule by following the steps below:

1. To open the Schedule Time window, right-click on 
Schedule in the workspace and select New Schedule.

2. Select one of the Run Task options and make the 
appropriate entries:
• Manual - enter a name. The Manual option can be 

useful for performing a series of Flowlink operations 
without assigning fixed or recurring times. Start a 
Manual schedule with Item>Run Now from the 
menu.

• Once - enter the time (e.g. 7:00 AM), and the month, 
day, and year.

• Hourly - enter the minutes after the hour.
• Daily - enter the time, and check the applicable days 

of the week.
• Weekly - enter the time, and select the day of the 

week from the pull-down list.
• Monthly - enter the time and the day of the month.

3. Set up the Error Handling. This provides instructions for 
Flowlink when it cannot complete a scheduled task. 
Problems such as a bad modem connection or “printer off-
line” can cause these errors. 
• Fill in the Retry ____ times before quitting and Allow 

____ minutes before each retry boxes. Use care so 
that later time-critical schedules are not delayed.

• Select the appropriate On Hard Error radio button. A 
hard error is when the task has failed all of the 
retries. Generally, you would want to abort the task 
list if the following tasks at the same scheduled time 
relied on this task. For example, if Flowlink was 
unable to complete a scheduled interrogation, there 
would be no need to continue with the next scheduled 
task - printing the graph. Flowlink will log a message 
in the Logs Folder after a hard error.

4. Press the Apply Changes button and the schedule will 
appear under “Schedules” in the Workspace. If you have 
modified an existing scheduled time and wish to restore 
the last applied settings, use the Cancel button.

Temporarily Disable 
Check box

When checked, the schedule is placed on hold. Flowlink will skip 
this schedule and all of its tasks as long as this check box is 
filled. This does not affect other schedules.
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Schedule Task The Schedule Task Window contains the settings that define the 
operation to be performed.

Schedule a task by following the steps below:

1. To set up a new task, right-click on a schedule in the 
workspace and select New Task.

2. Select the type of operation. Tasks that can be scheduled 
include site interrogations, printing graphs or tables, 
running a program, importing from a file, exportnig or 
saving to a file, calculating data sets, compacting a 
database, backing up a database, archiving a database, 
and restoring a database.

3. Type or select the name of the task item. Depending on 
the type of operation selected in step 1, this can be done 
by typing the name of the item, or by clicking the 
Select… button and selecting an item from the list.

4. If necessary, specify the target directory for file export 
operations.

5. Select a Schedule from the Pull-down list. These are 
schedules that already appear in the Workspace.
When all of the entries have been made, click the OK 
button to save the Schedule Task. 

Note: To add another site to an existing scheduled task, simply 
drag and drop the site over the desired schedule.

Temporarily Disable 
Tasks

Individual tasks may be put on temporary hold in one of two 
ways:

• Right-click a task and select Disable Task, or highlight a 
task and select Disable Task from the Item menu.
or

• Double-click a task to open the task window and check 
the box near the bottom, next to “Temporarily disable 
this scheduled task.”

This action puts this scheduled task on hold. Flowlink will skip 
this scheduled task as long as this check box is filled. The action 
does not affect other tasks at the same scheduled time, or 
identical tasks at different scheduled times.

Re-enable the task by selecting Enable Task or deselecting the 
Disable check box.

Notes:

• Retrieve data from site - The site must already exist in 
the current database.

• Print a graph or table - The graph or table settings 
must be pre-defined and saved. The graph or table should 
use a relative start time so that the viewed data is 
updated whenever the graph or table is opened or 
scheduled.

• Run a program - This type of scheduled task will 
behave differently depending on its position among other 
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tasks at the same scheduled time. If the external 
program task is followed by additional scheduled tasks, 
the schedule will wait for the external program to close 
before continuing. If the external program is the last (or 
only) scheduled task, schedule starts the external 
program and initiates the task, at which point the 
schedule closes.

• Import from a file - Imports a data file. Comma 
Separated Value (.CSV) files must include a header.

• Export to a file - Exports graph/table data to a selected 
location.

• Calculate Data Sets - Creates a new “site” in the 
workspace using a snapshot of data appearing in a 
specified graph or table.

• Compact this database - This option will compact the 
current database by defragmenting it.

• Backup this database - This option will backup the 
current database. Use the “Item” field to specify the 
filename and directory.
When selecting this type of operation, you choose to 
“Autogenerate unique filename.” Check this box and 
Flowlink appends the filename you entered in the Item 
field with the date and time that the backup file was 
created. Deselect this check box and Flowlink will 
overwrite the specified backup file if one exists.

• Archive this database - Copy or move data and/or site 
information or ensemble data from a database to another 
location.

• Restore this database - Restores data in the current 
database from another database or archive file.

Schedule Time 
Prompt

This window is displayed when a schedule is about to run while 
the database is still open in Flowlink.

• To proceed with the schedule, click OK. You will be able 
to continue with Flowlink after the schedule is done.

• To stop the schedule, click Cancel. You can then continue 
your work in Flowlink without interruption.

• If you do not respond within 30 seconds, the schedule will 
automatically run.

If you are modifying an item in the database that may affect the 
results of the schedule, cancel the schedule. Run the schedule 
manually (Item>Run Now) when you are through with the 
modifications.
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How Do I... ?

Create a site There are many reasons for adding a site to the workspace. The 
most common need is to place a new instrument in the field. 

Adding a new instrument to the Flowlink database is simple. The 
Direct Connect method is described below.

1. Connect your PC to the instrument. Use an interrogator 
cable to connect to 4100/4200/6700 instruments; use the 
Communications Cable to connect to a Pulse Doppler or 
2100 instrument, or Field Wizard.

2. Click the  Quick Connect button on the toolbar, or 
press F11.

3. Select “Direct” as the connection type.
4. Select the Com port from the pull down list. This will 

correspond to the serial port to which you attached the 
interrogator or communications cable. For more 
information on Com ports, refer to your computer’s 
manual. If you choose the “Default” Com port, Flowlink 
will use the port selected on the Utilities>Options 
window. 

5. Click the large button for the type of instrument to which 
you are connecting.
a. For Pulse Doppler instruments, another window will 

appear for entering the site and device name, and to 
select the flow meter type.

Flowlink starts to communicate with the instrument, then adds 
the site to the workspace. The site name is usually a factory 
default name, such as “4250 Flow Meter.” If an existing site in 
the workspace already uses the name, Flowlink modifies it. All 
sites in the workspace must have a unique name.

If this new instrument replaces an instrument at an existing 
site, you can merge the sites (see page 42). Merging the sites will 
allow you to use the data collected by the original instrument as 
if it had been collected by the new one.

Other ways to add sites to the workspace include:

• Converting data from earlier versions of Flowlink.
• Importing adds a “site” to the workspace, but it only 

holds the attached data sets. The data sets are available 
for editing and graphing. However, imported sites do not 
include instrument settings; they cannot be opened in a 
Site window.
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Make a direct 
connection

Direct connections use a cable to attach your PC to the Isco 
instrument.

• 4100, 4200, and 6700 Series instruments use an 
Interrogator Cable for direct connections. The 
interrogator cable is also compatible with the 675 and 
676 Logging Rain Gauge.

• 2100 Series instruments including the Field Wizard use a 
Communications Cable for direct connections.

• Pulse Doppler Series instruments use a Communications 
Cable for direct connections.

Direct connections - 
4100/4200/6700

When the interrogator port is easily accessible, you may use the 
10-foot long one-piece interrogator cable. Unrestricted access to 
the interrogator port allows you to connect to the instrument as 
needed, and to disconnect and cap the port when you are 
through.

• Part Number 60-2544-044 - for computers with a 9-pin 
connector

• Part Number 60-2544-040 - for computers with a 25-pin 
connector

• Part Number 60-2004-507 - for computers with a USB 
connector

If the instrument’s location is inaccessible, use the two-piece 
interrogator cable. It is a set of two cables, one 10 feet long and 
one 3 feet long. The 10-foot cable connects to the instrument, 
while the 3-foot cable connects to your PC. These two cables are 
connected to communicate with the instrument. When you are 
done, disconnect the two cables from each other. Because the 10-
foot section should remain connected to the instrument, a 10-foot 
cable is needed for each inaccessible instrument.

• Part Number 60-2544-025 - 10-foot cable, connects to the 
instrument

• Part Number 60-2544-026 - 3-foot cable, connects to 
computer with a 9-pin connector

• Part Number 60-2544-027 - 3-foot cable, connects to 
computer with a 25-pin connector

• Part Number 60-2544-028 - 25-foot extension cable
Note: 4100 Series Flow Loggers and 4200 Series Flow Meters - If 
you are connecting a battery-powered flow logger, the 
interrogator cable must be disconnected when not in use. 
Otherwise, the flow logger will drain its battery unnecessarily. 
One-piece cables must be completely removed from the flow 
logger, and the interrogator port should be capped to prevent 
damage. If you are using a two-piece cable, they must be 
separated. 



Isco Flowlink 5.1® Software

155

Instrument 
connection diagram

Direct connections - 
2100 and Field 
Wizard

A USB RS-232 Communications Cable, Isco P/N 60-2004-507, 
connects the 2100 Series instrument to your PC’s USB port. An 
RS-232 Communications Cable, Isco P/N 60-2004-046, connects 
the 2100 Series instrument to your PC’s Com port. Refer to the 
diagram below.

Instrument 
Connection 
Diagram

The 2101 Field Wizard does not have a case top connector. 
Instead, the communications cable attaches to the connector on 
the right side of the case. 

Extension and custom-length cables are available from Teledyne 
Isco. 
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Direct Connections 
- Pulse Doppler 
Instruments

A Communications Cable, Isco P/N 60-7004-057, connects the 
accQmin/accQpro, ADFM box, or canister with amphenol 
connectors to your PC’s com port. To connect the ADFM canister 
with crown connector, use Cable P/N 60-7004-027.

Instrument 
Connection 
Diagram

(accQmin/accQpro electronics shown here)

Move an instrument 
to a new site

You may need to periodically move an instrument to a new 
location. Flowlink will continue to connect to the instrument as it 
did in its original location, but you will probably want to create a 
new site in the workspace and clear the old readings stored in the 
instrument’s memory.

To create a new site after relocating an instrument:

1. Click the  Quick Connect button on the toolbar, or 
press F11.

2. Check the “Create new site” check box on the Quick 
Connect window.

3. Click the large Connect button that matches the 
instrument type.

4. Flowlink connects to the instrument and asks you to 
enter a new name for the site. Click Ok.

5. Flowlink opens the Save As window. Type in the new site 
name and click the OK button. Flowlink continues to 
connect to the instrument.

6. After Flowlink reads the instrument settings, it will 
pause and ask if you would like to clear the memory 
partitions (4100/4200/6700), or delete all of the data in 
the modules (2100). Select “Yes” to clear all of the data. If 
you select “No,” the instrument will retain the data 
collected at its original location. Flowlink then completes 
the connection process.

After connecting to the instrument, Flowlink adds the new site to 
the workspace and displays the Site Window - all under the new 
Site Name.
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Import data Importing brings data from non-Isco instruments or from other 
applications into the Flowlink database. The imported data is 
added to the Flowlink database and will show up in the 
workspace as a site, although it is not a site to which you can 
“connect.”

Flowlink can import files created with WinADFM (software 
formerly used with Pulse Doppler instruments). These include 
station files (*.stn), which contain site information, and their 
corresponding data files (*.nnn where nnn is a number from 0-9). 
Both file types must be imported before the data can be viewed.

Flowlink can also import 2100 data dump files (*.ddp) and data 
files in comma-delimited format, also known as comma-
separated values (*.csv).

The beginning of a CSV file must include a “Data Definition 
Header” (see page 17) to instruct Flowlink how to handle the 
information in the file. Data from non-Isco devices and data from 
spreadsheet applications must comply with this header format.

How to Import a Formatted CSV File:

1. From the Flowlink menu, select File>Import.
2. Type the path and file name, or browse for the file by 

clicking the Select… button. 
3. Click Import.

At this point, watch the Status box that reports the current 
status and a progress bar, and the Statistics box that reports the 
number of data records, data types, and total records imported. 

Edit data sets Reading adjustments may be needed for several reasons. Some 
examples are:

• To correct erroneous readings caused by mis-calibrated 
sensors

• To fill in gaps caused by power outages, signal loss, etc.
• Clock changes
• Memory partition changes

To adjust the data:

1. Open the data set for editing. To do this: 
• Highlight the data set in the workspace and click the 

 Edit Data set button. Or, 

• Graph the data. Then click the  Edit/View toolbar 
button to enable the editor. After graphing the data 
you can enable the editor also by right-clicking on the 
graph and selecting the Edit option, or use the Alt+E 
keyboard shortcut. 

2. Locate the incorrect data and highlight it. 
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3. Determine the type of reading adjustment that will be 
necessary.
• Constant value - changes all of the highlighted 

readings to a single value.
• Fixed offset - increases or decreases the highlighted 

readings by a fixed amount.
• Proportional - distributes an adjustment 

proportionately over selected readings.
• Multiply by Constant Value - multiplies the readings 

by a specified constant value. Specify a value greater 
than 1 to increase the readings; less than 1 to 
decrease the readings.

• Auto Correct - When selected, Flowlink will adjust 
the highlighted readings to fit adjacent readings. 
Because the amount is calculated by Flowlink, the 
Amount value is not needed.

• Time (minutes) - shifts the highlighted times forward 
or backward a fixed amount.

• Restore to Original - removes any corrections made to 
the readings to restore it to the original data. 

4. Enter the Amount.
5. Click Adjust. Flowlink changes the data according to the 

Type and Amount. The new readings are displayed on 
the table. The graph shows both the original and the new 
readings.

6. Click Save Changes.
Sometimes you may find that a combination of adjustment types 
may work best to produce the desired results. Repeat the steps 
above to apply additional adjustments.

Other Adjustment 
Methods

• Copy and Paste - Highlight correct readings and Copy 
(Ctrl-C) them. This places the readings on the clipboard. 
Highlight the incorrect data and Paste (Ctrl-V). Flowlink 
replaces the readings with those on the clipboard. You 
can also copy and paste using the buttons on the toolbar 
or using the “Actions” menu options.

• Cut - Highlight the readings to remove and Cut (Ctrl-X) 
them. This places them on the clipboard. They will be 
available for pasting elsewhere until they are replaced by 
another Copy or Cut. Cut can be used to remove 
unwanted readings or No Data codes from the data set. 
You can also cut readings with the Cut button on the 
toolbar or using the Actions>Cut menu option.

• Insert - Highlight the beginning point where you wish to 
insert readings. Select Actions>Insert or press Ctrl-I and 
complete the entries in the insert window. Insert may be 
used to fill gaps, or to add readings at the beginning or 
end of the data. It cannot overwrite valid readings.

Notes: 
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• It is possible to insert readings that will not appear in 
the time span currently viewed on the graph and the 
table. It may be necessary to move to the previous or next 
time span to see the adjustments.

• When Flowlink combines sites to form a line of data on a 
graph or report, it will not combine error codes with 
readings. Instead, it will report no data. Changing the no 
data codes to simulated readings prevents the codes from 
appearing in graphs or tables.

• New values that you can store in the database are 
limited to only the resolution and significant digits for 
the data set. Viewing the Data set Properties (Highlight 
a data set in the workspace and press Ctrl+F2) will 
reveal this information.

• When editing, Flowlink saves both the original and the 
edited data. If necessary, the original values can be 
restored. 

Create a Graph There are a number of methods that you can use to create a 
graph or table in Flowlink - Quick Graph a data set or site, New 
Graph, and Quick Graph with DEFAULT. Any of these methods 
will open a Graph window.

Quick Graph a data set - graphs a data set using the default 
graph properties.

To Quick Graph a data set you can double-click on it, or:

1. Highlight a data set in the workspace.

2. Click the  Quick Graph button.
The default properties will typically allow Flowlink to present a 
graph displaying the latest readings in the data set. 

From this point you can modify several items, such as the titles, 
to customize your graph (see page 119).

Tip: You can quickly add more data sets to a graph. From the 
workspace, click and drag a data set to the open Graph window 
and release. Flowlink displays the data set in a second pane.

Quick Graph a site - This method graphs a site using a 
template. A template is any existing graph in the open database. 
When you quick graph a site, the original graph’s data is 
substituted by the data of the desired site, while all of the graph 
properties remain unchanged. For your convenience, the 
Flowlink database can be pre-loaded with graph and table 
templates during installation. The templates, which are located 
in the Templates sub-directory of the Graphs and Tables folder, 
support many of the common needs of Flowlink users. For easy 
reference, each template is identified by a descriptive name.

The easiest way to quick graph a site using a template is to left-
click on the site in the workspace and then drag and drop it on 
the desired graph. Or, you can:
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1. Highlight a site in the workspace.
2. Right-click and select Quick Graph, or from the menu 

select Item>Quick Graph.
3. Flowlink will open a window to select the graph to be 

used as a template. Highlight the graph and click OK. 
Flowlink substitutes the new site data in the existing 
graph properties and then displays the graph.
Notes: 

When using existing graphs as quick graph 
templates, the site that is to be substituted is defined 
on the General Properties tab.
Graph templates can be imported into a database 
using the File>Import>Graphs and Tables menu 
command.

New Graph or Table - opens a blank Graph window. To create a 
new graph:

This opens a blank Graph window. To create a new graph:

1. Click the  New button, or select File>New (Ctrl-N) 
from the menu. Flowlink displays the New window.

2. Select Graph or Table from the list and click OK. 
Flowlink opens a blank Graph window using the default 
graph properties. 

3. Add data to the graph. This can be done by clicking and 
dragging a data set from the workspace onto the graph. 
Data may also be added to the graph from the Graph 
Properties window. 

Quick Graph with DEFAULT - This graphs the site data using 
the DEFAULT graph/table template (usually imported from the 
set of templates provided with Flowlink) in the Graphs and 
Tables folder of the workspace. 

You can view data in a DEFAULT graph by first highlighting a 
site in the workspace. Then, right click and select the Quick 
Graph with DEFAULT option. 

If the DEFAULT graph has not yet been defined, it may be 
necessary to change the properties of the DEFAULT template. To 
do so, right click on the graph after it is displayed, and select 
Properties.

DEFAULT graphs may also be generated while a Site window is 
open. To do so, click the DEFAULT button at the bottom of the 
site window, or press the F3 keyboard button. A common use of 
this feature is to quickly graph the site data before disconnecting 
from a site so you can view the data at a glance to check site 
conditions.

Use a Flowlink graph 
in another 
application

When you save a graph or table, it not only appears in the 
workspace, but an IGD (Isco Graph Document) file is also saved 
in the current directory. You can import an IGD file as an object 
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into any application that supports OLE 2.1. For example, you can 
insert a Flowlink graph or table into your word-processing, 
spreadsheet, or presentation files.

There are several ways to import an object. Before importing an 
IGD file as an object, you should consider whether linking or 
embedding would work best for your needs. Linking and 
embedding differ in how they update the file. For this discussion, 
let’s consider the Flowlink IGD file as the source, and the 
external application’s document as the destination.

A linked object is not part of the destination file. The destination 
file only displays a representation of the linked object while it 
remembers the location of the source. It remembers the location 
so the representation can be updated. If you allow the application 
to update the links as the document is opened, it builds a new 
representation of the object. If an IGD file is constantly reused 
and updated, linking would be ideal if you always wanted the 
current view. Another advantage to linking is that it reduces the 
destination’s file size. There are some disadvantages to linking. 
Since the destination file must remember the location of the 
source, the destination file is not very portable. Moving the 
destination or the source file will destroy the link.

An embedded object is part of the destination file, but is no 
longer part of the source file. The view of the IGD file cannot be 
updated by the source. However, you can double-click on it to 
open the object in the source application to manually update the 
view.

If you are running an application as a scheduled task to process 
an IGD file, you must link the IGD file. The application should 
also be set to update the links as the document is opened. 
Otherwise, the representation of the IGD file will never be 
updated.

Inserting an IGD file:

1. Open the application and the destination document.
2. From the menu, select Insert>Object...
3. Select Create from file.
4. Browse for and select the IGD file.
5. (Optional) Check the Link to file box.
6. Click OK. The application will display the IGD file inside 

the document.

Export Data When a graph, table, or scatter plot is active on the Flowlink 
desktop (see How do I Create a Graph), selecting File>Export 
will export the series data shown on the graph, table, or plot. 
Several export formats are available:

• CSV (“Comma Separated Values”, also known as comma-
delimited), without summary. 
Most spreadsheet applications can open or read .CSV 
formats, and as an ASCII text file, the .CSV file can be 
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opened with any text editor. Flowlink exports CSV files 
with a Data Definition Header.

• CSV, with summary. For tables, the summary 
information appears in the last line of the file.

• PDF (Portable Document Format), for sharing and 
viewing data using Adobe Acrobat family of products, 
including the free Adobe Reader.

• HTML (HyperText Markup Language), for sharing and 
viewing data using an Internet browser.

• IGD (Isco Graph Document), for sharing of graph and 
table templates.

How to export data:

1. From the Flowlink menu, select File>Export.
2. Type the path and file name, or browse for the new 

location by clicking the Select… button.
3. Select the export format from the Save As Type box and 

click OK.
4. Click Export.

Flowlink displays its progress on the bar in the status box.

Run Flowlink from a 
command line

Flowlink includes command line switches so tasks can be run 
from a command line, macro, or a script.

Flowlink Command Line Options:

To open a specific database, it must be the first parameter and 
include the full path name. Use absolute path names; relative 
path names are not recognized. Any single other parameter can 
follow the open database command. If a database is not specified, 
the default (last opened) database is assumed. When specifying 
graph/table and schedule names in command lines, they must 

Task Syntax

• open a specific database: /db FullPathToDatabase

• data retrieval (interrogate): /int SiteName

• print a graph/table: /pg GraphTableName

• import a file: /imp FullPathToImportFile.csv

• export a graph/table as a 
CSV file:

/exp GraphTableName

• export a graph/table as an 
HTML file:

/html GraphTableName

• export a graph/table as a 
PDF file:

/pdf GraphTableName

• run a schedule: /man ScheduleName

http://www.adobe.com/products/acrobat/readstep2.html
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appear exactly as shown in the workspace. Remember to use 
double-quotes for any names that contain spaces.

Examples:

• Open a specific database:
c:\FL5\isco.exe /db 
"c:\FL5\data\isco.mdb"

• Retrieve data from a site found in the default database:
c:\FL5\isco.exe /int "Fifth and Vine"

• Open a particular database and print a graph/table:
c:\FL5\isco.exe /db c:\FL5\data\isco.mdb 
/pg "Manhole B5"

• Import a file into the default (last) database:
c:\FL5\isco.exe /imp "c:\My 
Documents\Main Street.csv"

• Export a graph/table:
c:\FL5\isco.exe /exp "Graph 723"

• Manually run a schedule from the default database:
c:\FL5\isco.exe /man "Run Daily at 08:00 
AM on Mo Tu We Th Fr"

• Run a manual schedule from the default database:
c:\FL5\isco.exe /man "Manual Retrieve 
Data Fifth and Vine"

Notes: 

• Keep in mind that only one instance of the database may 
be in use at a time. Flowlink cannot perform a command 
line task if the requested database is already open. 

• The commands should be entered on a single line 
followed by a return. The line breaks in the above 
examples are due to limitations of the printed page 
margins.

Manage the 
database

Teledyne Isco recommends that you keep all of your sites in a 
single database. The single database allows you to use Flowlink’s 
abilities to meet your flow monitoring needs. Flowlink can 
perform advanced analysis (I&I, CSO, Flow comparisons, 
stormwater, etc.) on numerous sites, as long as it can access the 
data. More than one database would only be recommended when 
there is a need to perform independent studies, such as 
contractual or short-term analysis.

To help maintain the database, consider the following:

• Sorting Data in the workspace so sites are easy to find.
• Defragment the Database at regular intervals.
• Periodically Backup the Database for easy recovery.
• Periodically Archive the Database to remove data no 

longer needed.
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Sorting Data To keep a large number of sites in the database, it is often best to 
group multiple sites in folders in the same way files are kept in 
directories. Creating folders in the workspace to sort the sites 
will make them easier to locate.

1. Highlight the parent-level folder labeled “Sites.”
2. Select Item>Create Folder. Flowlink adds an empty 

folder under Sites.
3. Name the folder.
4. You can position the new folder anywhere in the 

workspace under Sites. It does not need to be in 
alphanumeric order. To move the folder, click and drag.

5. Click and drag sites to the folder.
Folders can also be used to sort Graphs and Tables.

Defragment the 
Database

Defragmenting an .MDB database keeps the internal structure 
of the data intact while minimizing the database file size. 
Flowlink can automatically defragment the database by allowing 
it to perform database maintenance at regular intervals.

Backup the 
Database

Periodically, you may want to backup the database, should data 
recovery ever become necessary. Flowlink allows you to backup 
the current database using the Database>Backup… menu 
command. The backup saves the sites and site data, graphs and 
tables, and schedules. You can schedule a backup to be performed 
at regular intervals. 

When running a backup, you specify the destination (removable 
media, network drives, recordable CDs, 3.5" diskettes) and 
Flowlink saves the database in a compressed .ZIP file. Flowlink 
can restore the database from this backup file.

Archive the 
Database

As you continue to retrieve data from sites, the file size of the 
database continues to grow to hold the data. Archiving lets you 
remove data from the database that is no longer needed. For 
example, if you analyze the data to produce just weekly and 
monthly graphs, the previous month of data is no longer needed 
in the database. Archiving the data at regular intervals will 
greatly reduce the need for storage space. 

Archives are not the same as backups. An archive only stores the 
sites and the site data, whereas a backup will include the graphs, 
tables, and schedules.

Archiving the database lets you specify the date range or date of 
interrogation to pull from the database. Archives can be saved as 
an .MDB file, an ADFM ensemble data file, or a compressed .ZIP 
file. .MDB files can be opened directly in Flowlink; reopen 
compressed files with the Restore from Archive menu command.

Automate Flowlink 
tasks

You can use schedules to automate many of Flowlink’s 
operations. Schedules allow you to accomplish a variety of tasks 
without being present at the computer. Flowlink can 
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automatically interrogate remote instruments, print graphs or 
tables, update documents in your word processing application, 
etc. Schedules let you control the workflow and save both time 
and money. For example, you can interrogate instruments at 
night or on weekends when rates are cheaper, or send print jobs 
to network printers when the demand is lower.

Before setting up a schedule, create the items that Flowlink will 
be working from. 

• To schedule a site interrogation the site must be set up 
correctly in the workspace.

• To print a graph the graph must be predefined and saved 
in the workspace.

• To import a file, a CSV, IGD, or ADFM data or station file 
must be present in the location specified.

To set up a schedule:

1. Create a Schedule time. Click the  New button.
2. Select Schedule from the New list and click OK. Flowlink 

opens the Schedule Time settings window.
3. Enter the Start time and error handling settings and 

click OK. Flowlink adds the time to the Schedules folder 
in the workspace.

4. Create a Schedule task. Click the  New button.
5. Select Schedule Task from the list and click OK. Flowlink 

opens the Schedule Task settings window.
6. Follow the yellow instructions that appear on the screen.
7. Click OK. Flowlink adds the task to the schedule time in 

the workspace.
Hint: You can add tasks to a schedule directly from the 
workspace. To interrogate a site or print a graph, click and drag 
the site or graph icon to a schedule time.

Flowlink now has the information it needs to process the tasks, 
but your computer requires an application to monitor its clock 
and start this process at the schedule time. To run a schedule, 
your computer must be running WakeUp Monitor in the 
background. Look for an alarm clock icon in the status area of the 
windows task bar. If it is not present, start the WakeUp Monitor.

To start the WakeUp Monitor, locate the Windows Start button. 
Click on the Start button and select Programs>Flowlink 
5.1>Wakeup Monitor. Teledyne Isco recommends that you place a 
shortcut to the WakeUp Monitor in your Windows Startup folder 
if you will be using schedules regularly.
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Comparison matrix, 5 & LE, 4
Compatible instruments, 3
Condition, 70, 96

grouping conditions, 99
hysteresis, 71
rainfall, 73
range, 72
rate, 72, 98
sensor error, 71
setting up, 70, 98
threshold, 71, 98
time, 72, 99

Connection options, 37
Connection settings, 78
Connection window, 14

Pulse Doppler, 14
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Signature Flow Meter, 110
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Data definition header, 17
Data point flow conversion, 41, 60, 86, 91
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Data sets - calculating, 25
Data storage - site window, 83
Data storage setup, 52, 54
data table, 36
Database, 26

archive/transfer, 29
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DEFAULT graph, 22
Default units options, 39
Defining a condition, 98
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94
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2100/4100/4200/6700 series, 9
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Duration modifier, 96, 101

E
Edit bar, 34
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cut, 142
fixed offset adjustments, 143
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making adjustments, 139
multiply by constant value, 144
no data codes, 146
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restore original data, 145
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undo all editing, 145
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logical operators, 101
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Equation flow conversion, 41, 60, 86, 91
Equation view, 96, 97
Export data, 136, 161

F
Feature comparison, 4
Field Wizard description, 114
Field Wizard site window, 113
File Commands

close, 13
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export, 19
import data, 16
import graphs and tables, 18
new, 13
open, 13
print, 20
print preview, 20
print setup, 20
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RTD transfer, 16
save, 13
save as, 13
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Flow conversion
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edit, 41
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flow metering inserts, 87
flume, 87
list, 41
manning formula, 87
site window, 60, 86
weir, 87

Flow conversion methods, 86
Flow conversion offline, 53
Flow metering inserts, 87
flow profile, 36
Flow profile cross section, 36
Flow pulse, 92, 93
Flow rate - site window, 60, 86, 106
Flow rate diagnostics - 2100, 61
Flowlink LE comparison, 4
Flume, 41, 60, 86, 87
Folder, 163
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Global graphs, 21
Graph, 35, 115

create, 116
default, 116
default options, 39
local and global, 21
modifying, 119
printing, 135
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text, 132
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Graph Properties, 119
defining series, 123
general, 119
scatterplots, 126
series formulas, 125
time scale, 121
time series, 122

Graph/table view toggle, 25
Graphs menu

amplitude graph, 36
correlation graph, 36
flow profile, 36
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scatterplot, 36
table, 36
time series, 35
vector graph, 36
velocity graph, 36

H
Header for CSV format, 17
How do I...

create a graph, 159
create a site, 153
edit data sets, 157
export data, 136, 161
import data, 157
make a direct connection, 154
manage the database, 163
move an instrument to a new site, 156
run Flowlink from a command line, 162
use a Flowlink graph in another applica-

tion, 160
Hysteresis, 71

I
Import data, 16, 157
Import graphs and tables, 18
Instrument connection options, 37
Item menu options, 20
Item properties, 22

L
LaserFlow, 59, 65
Level - site window, 57
Level diagnostics - 2100, 57
Line - adding to graphs, 132
Lite edition comparison, 4

Local and global graphs, 21
Log, 43
Logical operators in equations, 96, 101

M
Magnify graph display, 24
Main toolbar, 32
Make a direct connection, 154
Manage the database, 163
Manning formula, 41, 60, 86, 87
Maximize display, 24
Maximum - reporting highest reading, 129
Maximum level, 92
Measurement properties - site window, 56
Measurements - site window, 52, 79, 105
menu commands, 13
Merge sites, 42
Minimum - reporting lowest reading, 129
Minimum depth for velocity, 81
Miscellaneous options, 40
Modbus, 68
Modem

2100 dialout alarms, 66
4100/4200/6700 dialout alarms, 94
commands, 14, 78, 94
connections, 8, 14, 78
default, 51, 79, 105
power control, 68
pushed data, 52, 55

modem, 69
Move an instrument to a new site, 156
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Names, 50
Network resolution, 74
No data codes, 146
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Offline flow conversion, 53
Options - Default, 37

P
Parentheses and order of execution, 96, 99
Partition sizes, 84
Password, 82
password, 45
Power control, 68
Properties, 22
Pulse Doppler

2105 interface, 68
flow profiles, 134
quick connect, 14

pulse doppler connection, 9
Pulse Doppler data - site window, 106
pulsed Doppler

toolbar, 34
Pushed data
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4200/6700, 56
configuring, 55
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Q
Quick connections, 14

Pulse Doppler, 14
Quick graph

button, 21
with DEFAULT, 22

R
Rainfall - site window, 62
Rainfall conditions, 73
Range conditions, 72
Rate of change conditions, 72, 96, 98
Recent measurements, 35
Reference curve, 131
Refresh graph display, 24
Report, 73
Restore from backup, 31
Retrieving data, 49, 77, 103
Roughness, 87, 88
RTD transfer, 16
Run Flowlink from a command line, 162

S
Sampler control - site widow, 92
Sampler control - site window, 63

enable, 63
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Sampler diagnostics - 2100, 64
Sampler enable, 92
Sampler enable flow count, 80, 83
scatterplot, 126, 131
Schedule, 149

disable schedule, 150
disable/enable task, 151
tasks, 151
time prompt, 152
times, 150
Wakeup Monitor, 149

Sensor error conditions, 71
server alarms, 44, 67
Server logs, 43
Set Home, 25
Signature connection, 10
Signature Flow Meter, 109

data, 110
data integrity, 110
default options, 38

Silt level, 91
Site info, 50, 104
Site matching, 95
Site selection, 45
Site window, 49, 77, 103, 109

2100 alarms, 66

4100/4200/6700 alarms, 94
basic info, 78
data, 52
data storage, 83
device setup, 80
devices, 50, 78, 104
flow, 60, 86
flow rate, 106
level, 57, 79
measurement properties, 56
measurements, 52, 79, 105
Modbus, 68
Pulse Doppler data, 106
Pulse Doppler interfacing, 68
rainfall, 62
sampler control, 63, 92
site info, 50, 104
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TIENet, 65
total flow, 61
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velocity, 58
velocity corrected, 59

Slope, 87, 88
SMS text messaging, 66
sonde - 2105, 64

activate & configure, 64
manual configuration, 65
saved settings, 65

Statistical functions, 129
Status bar, 34
Sum statistical function, 129

T
Table

create, 116
templates, 19

Table/graph view toggle, 25
templates, 19
Text - adding to graphs, 132
Threshold conditions, 71, 96, 98
time series graph, 35
Time table conditions, 72, 96, 99
Toolbar

graph, 33
main, 32
pulsed Doppler, 34

Total flow - site window, 61
Total flow diagnostics - 2100, 62
Transfer archive, 29

U
Units - site window, 94
Unmagnify graph display, 24
Unzoom display, 24
USB direct connection, 8
Use a Flowlink graph in another application,
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options, 37
view log file, 43
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Variable blanking, 80, 81
Vector graph display, 36
Velocity - site window, 58
Velocity Corrected - site window, 59
Velocity diagnostics - 2100, 60
Velocity graph display, 36
Velocity input, 90
View, 32

edit bar, 34
graph toolbar, 33
main toolbar, 32
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status bar, 34
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Viewing the log, 43
Viewing the Server logs, 43
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Wakeup Monitor, 149
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close all, 47
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Wireless power control, 68
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